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C1: The MallincamSky DS10CTEC User 

Manual 

 

Use this User Manual to obtain a deep understanding of  all the 
features of  both the MallincamSky and the SkyRaider 
DS10CTEC camera.  See the Quick Guide for an expeditious 
look at getting up and running with the camera and software.  

o save time for those of you who are familiar with Mallincam imaging cameras, this 
User Guide will provide a Table of Contents to allow you to quickly locate the 
commands and controls you need in controlling the DS10CTEC camera. It will include 
instructions on how to install the Software and Drivers and how to connect the 

SkyRaider DS10CTEC Camera to your computer. This manual will provide explanations of all the 
camera’s settings so you can get up and running quickly and can experience the wonders of 
video imaging.   

The ICONS on the left are quick indications of what that section performs. 
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Introduction 
 
MallinCam Introduces the new DS10CTEC - designed from the ground up to accommodate the 
most demanding astronomical video imaging applications. Since most CMOS sensors cannot 
be directly cooled via a cold finger without causing damage and delamination with time which 
will ultimately shorten their life, a new cooling system had to be developed.  MallinCam 
developed a unique cooling system that provides no direct physical contact between the 
Peltier cooler and the sensor.  Instead, the Peltier cooler creates a convection system 
“refrigerator-like” environment that cools the sensor without contacting it.  This cooling 
system is unique to MallinCam and not found on other astronomical imaging cameras. 
  
Since the back illuminated IMX294 class 1 CMOS sensor of the MallinCam DS10CTEC is cooled 
via convection, thermal shock to it and its associated circuitry is reduced. CMOS sensors have 
other components mounted on the same wafer with the imaging section which do not require 
or can be adversely affected by cooling. This includes the digital logic circuitry (interface, 
timing, processing, output amplifiers, pad rings and associated oscillators), clocks and timing 
controls, analog signal processing, analog-to-digital converter (which when under cooling from 
direct cold finger and Peltier results in instability).  These parts of the CMOS sensor do not 
need to be direct cooled from a cold finger application. 
  
MallinCam has successfully design a working alternative - a cooling chamber called 
refrigeration cooling - which subjects the CMOS sensor to cooling inside a triple sealed 
vacuumed sensor chamber controlled with a heating element mounted around the internal 
optical window to control and avoid dew formation on the optical window and surroundings. 
A vacuumed sealed chamber is used to eliminate the use of desiccant material and keep dew 
free environment permanently. 
  
The result of this new technology, the SkyRaider DS10CTEC, will not require a dark frame for 
live application or imaging in most cases. It is built to laboratory specification, where CNC 
machining is used throughout to provide the rigid tolerances needed to provide precise 
component matching. The chamber has six stainless steel screws securing the chamber cover 
under 100 pounds of pressure to avoid possible air leaks into the chamber.  
  
The internal electronics use Grade 1 components with tolerance of 0.5%, a military and 
aerospace standard. The camera contains 4Gb DDR3 internal memory to insure the smooth 
flow of data to the computer. The DS10CTEC also has a built-in USB2 hub that can support a 
guider or a USB type focuser. 
 
 
So, thank you for your purchase, and let the adventure begin. 
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The Contents of the DS10C TEC 
 
Specifications: 

 
• Convection Linear Cooling 

• Refrigeration Chamber 

• Vacuumed Sealed Optical Chamber 

• Built-in Heater for Optical Window Dew Removal and Chamber Temperature Control 

• 100 Pound Chamber Plate Pressure Held with 6- Stainless Steel Screws 

• Built-In USB2 hub for Guider, Focuser, Filter Wheel etc. 

• Four Blue LED Status Indicators (power, system, cooler, fan) 

• High velocity Ultra Quiet Fan with Dual Air Output 

• 4Gb DDR3 Internal Memory for smooth operation 

• Sony IMX294 Back Illuminated, Class 1 Hand Picked CMOS Sensor (Scientific grade) 

• T-Mount 

• Pixel Size: 4.63 X 4.63 microns. 

• 1900 mv Output 

• Spectral Range:  350nm to 1100nm. 

• Light Pollution Electronic Removal System using the White Balance Feature 

• HCG and LCG Mode (High Conversion gain, Low Conversion Gain Selectable) 

• Correlated Double Sampling 

• A high S/N ratio with no Amp Glow 

• Precision All Aluminum Construction and Stainless-Steel hardware 

• 10.0 cm X 8.00 cm (3.93 Inches X 3.14 inches) 

• 34 Grams / 1.17 Pounds 

• 5 volts operation @900 ma. 

• Pixel Size: 4.63 X 4.63 microns. 

• 21.63mm Diagonal Sensor Size 

• Resolution Sizes: 

   - 4096 X 2160, 38 FPS @0.100ms 

   - 3704 X 2778, 35 FPS @ 0.100ms 

   - 2048 X 1080, 70 FPS @ 0.100ms 

   - 1360 X 720, 100 FPS @ 0.100ms 

• Digital Binning Mode:  1 x 1, 2 x 2, 3 x 3, 4 x 4, All in Color 

• Global Shutter 

• Image Format, FITS, JPEG, BMP, PNG 

• Full Video Mode: AVI, SER 

• Vacuumed Sealed Optical Window 
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In the Box 

 
The SkyRaider DS10CTEC includes the following standard equipment: 
 

• MALLINCAM SkyRaider-DS10CTEC Camera  

• High Precision T-mount to 2” mount Eyepiece Adapter 

• 5-metre (15 ft) USB 3.0 cable. 

• 12 volts dc, AC power supply. 

•  High-Grade Carrying Case. 

 

 
System Requirements: 

 
• Equal to Intel Core2 2.8GHz or Higher 

• Memory: 4GB or More 

• USB port: USB 3.0 Port (Recommended) 

• Display: 17" or Larger Recommended 

• 200MB Free HDD 

  
 

Updated Software and Drivers can be downloaded at the Software Downloads Window 
located in the Support Tab at www.mallincam.net 

 
 

 

 

 

 

 

Dimensions 

 

 

 

 

 

M42 x 0.75 

http://www.mallincam.net/
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Download and Install MallincamSky 
Visit the following website: www.mallincam.net. Select the Support Tab, then Software 
Downloads. Select and download the latest required software and drivers for your system. 

 

 

 

 

 

 

 

 

 

 

 

 
Ensure DS10CTEC is not connected. 

 

Once downloaded, place your mouse on the zipped file, Right-Click to pop-up an Action Window, and 
choose Extract All … 

 
Just Click on the Extract button when the next Window pops-up. Windows should now open 
the actual folder that contains the software to install. 

 

 
 
Un-Zip the folder, then Double-Click on it to open it up, revealing the programs it contains (or 
1 program if just downloading MallincamSky). 

 

 

 

Step 1 

 

http://www.mallincam.net/


M A L L I N C A M S K Y  D S 1 0 C T E C  U S E R  M A N U A L  

 

15 

 

The ASCOM Setup contains the ASCOM Drivers for the camera 
The DIRECTSHOW Setup contains the Direct Show Drivers for the camera 
The Mallincam APPLICATION contains camera control software. 

 
 
Double-Click on the WINDOWS APPLICATION folder to open it up. 
 
 
 
Double-Click on the MALLINCAMSKYSetup file and follow instructions to install the 
MallincamSKy software and drivers onto your computer: 
 
 
Your version of Windows may give you warnings and then ask you for permission to open the 
program (or the DirectShow program). This is just another level of security offered by 
Windows. 
 
 
If the following screen appears, then click 
on the More info line. In the window. You 
will then be presented with another 
window. 
 
 
 
 
 
 
 
 
 
 
 
 
 
Now just click on the Run anyway button at 
the bottom of this window to start the 
installation process. 
 
 
 
 
 
 
 
 
 
 
 
 
 

Step 2 

Step 3 
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The following MallincamSky Setup Screen will then appear: 
 

 
 
Click on Next to start the installation process. 
 
 
The installation program now wants to know where you would like to install the software. 
Either choose your own location or select the default.  

 

 
 
Click on Install to proceed. 
 
 
 
 
Windows may again ask for permission to install the device software.  
 

 
 
Click on Install to accept. 
 

Step 4 

Step 5 

Step 6 
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The MallincamSky Software will take about a minute to be installed. When completed, the 
following screen will appear: 
 

 
 

 
Click on Finish, and the MallincamSky Icon will appear on your screen. 
 
 
 
MallincamSky and its drivers are typically all you need to install to control the DS10C camera, 
but if you would like to have other image programs control of the DS10C then you can install 
two other optional drivers: ASCOM and DIRECTSHOW. 
 
 
 
Optionally (see Installing the ASCOM Driver for more in-depth details), Double-Click on 
ASCOM DRIVER folder, then Double-Click on the ASCOMMallincamSetup program and follow 
the instructions to install the ASCOM driver. 
 
 
 
 
 
Optionally, (see Installing the DIRECTSHOW Driver for more in-depth details), Double-Click 
on the DIRECTSHOW DRIVER Folder to open it up, then Double-Click on the 
MALLINCAMDshowSetup program and follow the instructions to install the Directshow 
drivers onto your computer. 
 
 
 
Windows may display a warning asking for permission to run the program, if it does, select 
YES. 

 

Step 7 

Uncheck the Run 
MALLINCAMSKY 3.7 

checkbox 

Step 8 

Step 9 
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Connecting the DS10CTEC to your 

computer 
Un-screw the plastic dust cover from the front of the SkyRaider-DS10CTEC camera (place it 
back in the box for safe keeping) and Screw in the 2-inch eyepiece adapter (M42 x 0.75mm) to 
the front of the DS10CTEC and inset camera into a 2” eyepiece adapter on your Telescope.  
 

 

 

 

 

 

Depending upon the telescope, you may need extenders so that you can reach focus with your 
telescope. It is recommended that you set this up in the daytime, so you can see what you are 
doing (plus can aim at an easy to find tree or telephone pole).  
 

 
 
 
The T2 (M 42 x 0.75 mm) female thread on the SkyRaider-DS10CTEC is a standard size, and 
numerous adapters are available to connect your camera to various devices such as filter 
wheels, camera lenses, filters, etc… 
 
Now connect the 12V AC adapter to a power source and attach the other end to the camera.  
 
 
Attach the 5 metre USB 3.0 cable from the back of the to the SkyRaider DS10CTEC to a free 
USB 3.0 (or USB 2.0) port on your computer. 
 
 
 
 
 

 

432 
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The SkyRaider DS10CTEC has some strict power and through-put requirements, and not all 
computers are created equal. If you find you are having difficulties with the following steps, it 
may be the USB 3.0 port on your computer. If that is the case, one option to try is: connect a 
Powered USB 3.0 Hub to your USB 3.0 port on your computer. This simple step can improve 
both the throughput distance and power between your computer and the SkyRaider 
DS10CTEC camera. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Power on the DS10C (plug in the power adapter to an AC outlet) 

The first time the DS10C camera is powered on and 
connected to the computer, Windows will finish installing 
its drivers will recognize the camera. You will hear a beep 
acknowledging the connection. 

Using the USB 2.0 Ports on the SkyRaider DS10CTEC 
The USB 2.0 HUB on the SkyRaider-DS10CTEC can be used to connect with various 
accessories, such as a guide camera, filter wheel, or electronic focuser. This will allow you 
better management of your cables. The integrated USB 2.0 hub on the SkyRaider-DS10CTEC is 
powered by the 12V external power source.  
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USB 3.0 Cable Issues 

 

USB 3.0 boasts 4.8 Gbits/s as long as your high-quality cable is within the 5-meter threshold. 
Anything longer and the full throughput speed is not guaranteed.  

This also requires that the USB 3.0 port on your computer is not overtasked and can produce 
the required output power (5V at 0.9A or 4.5 Watts). 

Most users that have connection issues is because the USB 3.0 cable or computer’s USB 3.0 port 
is not making the grade (computer may continuously try to connect to the camera, the DS10C 
TEC camera name says USB 2.0 behind its name, MallincamSky cannot control/connect to the 
camera, nothing seems to be working). 

If you are having connection issues, there are a few remedies to try: 

1.  Test with a short USB 3.0 cable. If you obtain a successful 
connection, then you know that the SkyRaider camera is OK. 

 

 

2.  Use a powered USB 3.0 Hub. Connect the hub to the computer with 
a short USB 3.0 Cable, then connect your longer USB 3.0 cable to 
the Camera. 

 

 

3. Use a powered (active) USB extender cable. Connect that to the 
computer with a short USB 3.0 cable, then connect your longer 
cable to the Camera. 

 

 

Note: the use of USB 3.0 extender cables and powered hubs can help provide you with longer 
than 5m cable runs. 
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Running MallincamSky 
Locate and double-click on the MallincamSky icon located on your Desktop to start 
MallincamSky. When the software loads, you will be able to locate under the 
Camera Tab the DS10CTEC camera name. Click on this name to activate the camera 
and thus display in the Video window what the telescope is pointing at.  

 

FIGURE 1.0 - MallincamSky’s opening screen.  

If the driver has been successfully loaded, you will see the name of the SkyRaiderDS10CTEC 
Camera in the MallincamSky Camera List on the upper left of the Window. You can install 
more than one SkyRaider Camera to your computer, but the software can only control one 
SkyRaider Camera at a time.  
 
You can run multiple instances of MallincamSky at the same time, this way you can have one 
instance control one Mallincam camera and the other instance control the other Mallincam 
camera. 
 

 
If you notice that the SkyRaiderDS10CTEC has a (USB2.0) behind it, then you are either using a 
USB 2.0 port, or the distance is too great for the USB 3.0 cable, and the system has entered 
USB 2.0 speeds. Remember USB 2.0 utilizes slower speeds but gives you greater distances. 
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C2: The MallincamSky Window 

 
 
 
 
 

 
 
The MallincamSky Software Window is segmented into a few regions to make viewing and 
adjusting the SkyRaider camera easy and intuitive. 
 
① The Top Menu Line provides dropdown menus and icons to allow you to make major 

settings of the software. 
 
②  The MallincamSky Left SideBar provides the simple click activation and selection 

capabilities to control all aspects of the image and camera. 
 
③ The Left SideBar Base provides selection options for Camera, Folders, or Undo. Left 

Clicking on the selection choice will fill the Left SideBar with its options. 
 
④ The Video Window will contain the display image from the SkyRaider Camera. It is here 

that you will see the live video, or images. 
 
⑤ The Information Line will indicate the current camera, current frame rate, number of 

frames displayed, resolution, information about captures, etc. 

 

Chapter 

2 
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Helpful Suggestions when Imaging 
 
The following are some hints and suggestions on how to image Planets, Sun, Moon, and 
DeepSky Objects with the DS10CTEC. These are just some recommendations, so use them as 
you see fit. They will make more sense when you understand MallincamSky’s controls. 
 
You will notice the Blue channel is a bit weaker than the Red or Green channel, so some final 
colour adjustments may be required if you use third party software for enhancing your 
images. 
 

How to image planets 
 
Imaging planets usually requires a high magnification through a telescope and therefore using 
a Barlow lens is recommended.   
 
Since most of us will want to enhance our planetary images, the technique of capturing short 
videos (between 1 to 10 minutes, depending upon planet) with the highest frame rate allows 
for the best video frames to be extracted and combined. This will reveal surface details and 
enhance the colours and contrasts. 
 
Depending upon the planetary object, increasing your Binning will also increase the frame 
rate. Try different Bin settings to see which one produces the best frame rate and still retain 
planetary details. 
 
With the DS10CTEC, use the Region of Interest (see instructions later in the User Manual). 
This will dramatically increase the frame rate. Also, you will want to decrease the exposure 
time, so by increasing the Gain you will reduce the exposure time and thus increase the frame 
rate.  
 
A balance is needed, as increased Gain also increases noise. See what works best for your 
environment. 
 
Some Postproduction software to help produce the best image is PIPP and AstroSurface or 
AutoStakkert. 
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How to Image the Moon 
 

When it comes to imaging the Moon, a large sensor and a small pixel size become essential for 
producing sharp high contrasted images.  Just as in imaging planets, we want to capture short 
videos (less than 5 minutes, as the terminator shadow does move), with a decently fast frame 
rate. You will want to use the 3704 x 2778 at 14-bit to provide the largest view (adding a focal 
reducer will increase the view) at the highest bit detail (but this slows down the frame per 
second). As always you will want to balance these values depending upon your equipment. If 
possible, try to use Region of Interest to increase the frames per second rate. 
 
Increase the Gain, to shorten the exposure time (faster frames per second).  
 
Note: that if the Gain is increased too much then noise will appear in the image. It’s all about 
balance. 
 
If possible, have your equipment track in Lunar Mode, as this will keep the current image of 
the Moon centered. 
 
Use your Histogram to help ensure your image is not too bright or dark (with my equipment 
my histogram peak is between 50 and 100, but this depends upon phase of Moon). 
 
With your video saved, use stacking and adjustment software to choose and align the best 
frames (you made have between 2000 to 10000 frames captured, depending upon frame rate 
and duration of capture). 
 
Some Postproduction software to help produce the best image are PIPP and AstroSurface or 
AutoStakkert. 
. 
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How to Image the Sun 
 
When it comes to imaging the Sun, a large sensor and a small pixel size become essential for 
producing sharp high contrasted images.  Just as in imaging the Moon we want to capture 
short videos (less than 5 minutes), with a decently fast frame rate. You will need to ensure 
that your telescope has the correct Solar Filters attached. 
 
Depending upon the required image closeups, you may choose to also include a Barlow (you 
will need to increase the exposure rate). 
 
You will want to use the 3704 x 2778 at 14-bit to provide the largest view (adding a Focal 
Reducer will increase the view) at the highest bit detail (but this slows down the frame per 
second). As always you will want to balance these values depending upon your equipment. If 
possible, try to use Region of Interest to increase the frames per second rate. 
 
Increase the Gain, to shorten the exposure time (faster frames per second).  
 
Note: that if the Gain is increased too much then noise will appear in the image. It’s all about 
balance. 
 
If possible, have your equipment track in Solar Mode, as this will keep the current image of 
the Sun centered. 
 
Use your Histogram to help ensure your image is not too bright or dark, but this depends 
upon the type of Solar Filter you are using). 
 
With your video saved, use stacking and adjustment software to choose and align the best 
frames (you made have between 2000 to 10000 frames captured, depending upon frame rate 
and duration of capture). 
 
Some Postproduction software to help produce the best image are PIPP and AstroSurface or 
AutoStakkert. 
. 
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How to Image Deep Sky Objects 
 
The DS10CTEC was designed for Deep Sky Objects; you may expect that it cannot image any 
other type of object. But you will be surprised that it can still image Planetary objects. 
 
Since the pixel size of the DS10CTEC is 4.63 microns, we would recommend that you 
experiment with Binning to provide you with better success by combining those pixels. 
 
You will need to use longer exposure (between 20 and 120 seconds along with MallincamSky’s 
Live stacking enabled (Aligned and Average selected). 
 
You also will want to use Dark Fields as you may obtain some amp glow (due to longer 
exposure times) and this control will remove that. 
 
Again, play with the Histogram to produce the best image you can so it shows the most 
amount of detail.  
 
You will want to take many Snapshots of your object and then combine to increase the Signal 
to Noise Ratio. 
 
Some Software to help produce the best image are: PixInsight, DeepSkyStacker, and Astro 
Pixel Processor. 
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Quick Work-Flow Procedures 
 
Quick Workflow for Starting MallincamSky 

 
So, you do not like to read manuals, and you just want to just jump right into imaging. Then 
this section gives you a Quick and Dirty method to get going. Then, I follow this section with 
an even more detailed section on Planetary Imaging Workflow, and finally a more detailed 
section on Workflow on Imaging Deep Sky Objects. 
  
 
Double Click on the MallincamSky Icon to start the program.  

 
 
 
Select the SkyRaiderDS10C TEC from the Camera List in the Camera Tab. 
 
With the Camera Tab selected on the Left SideBar; Left-Click on the 
SkyRaiderDS10CTEC (between lines in Camera Heading). 
Once the SkyRaider is selected, a black rectangle (with 
SkyRaider Camera name) will appear in the Video Window 
of the MallincamSky Software along with the Horizontal and 
Vertical Rulers, and the fan on the SkyRaider DS10CTEC may start 
running. 

 
 
Activate TEC from the Cooling tab to cool camera (set about 30o below ambient temperature). 
The current temperature of your camera is displayed on the bottom right corner of the 
MallincamSky Window. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
You can also turn On or OFF the fan via the Slider in the Cooling Tab 
 
 
The Mallincam SkyRaider DS10CTEC Camera provides a processing technique called Dark 
Field and Flat Field Corrections (see Detailed Sections below for techniques and explanations 
on using both Dark Fields and Flat Fields). 

Step 2 

Step 3 

Step 1 
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Reduce Exposure Time to Align Telescope 
 
As you will most likely use the camera to align and focus your Telescope, now is the time to 
reduce the Exposure Time to 1 or 2 seconds, and if not already attached to the Telescope, 
remove the lens cap from the SkyRaider Camera and insert the camera into the eyepiece 
holder of your telescope. The shorter exposure will make it easier for you to align and focus 
your telescope. 
 
Select the Video Mode radial button on the Capture and 
Resolution Tab. The DS10C TEC will start imaging and 
displaying what it sees, now move the Exposure Time 
slider to some value less than 5 seconds (note that the 
units are in milliseconds, so 1 second = 1000 ms), and 
align and focus your telescope. In Video Mode, images 
are automatically continuously taken once activated. 

 
 
 
Hint: You can ask MallincamSky to provide you with an approximate exposure time by 
checking the Auto Exposure box in Video Mode, and then move the Exposure Target slider to 
the middle of the range. MallincamSky will automatically adjust the Exposure Time (and 
display it) for you. Now just uncheck the Auto Exposure box and the Exposure Time will 
remain at the selected value. 

 

 
 
 
Increase Exposure Time to Image 
 
Now is the time to expose some Deep Sky Objects or Planetary Objects. So, go back into 
Trigger Mode (if you are imaging Deep Sky Objects, else remain in Video Mode if imaging 
Planetary Objects) and adjust the Exposure Time to match the current target and the 
equipment you are using.  
 

Video Mode 
 
Simply adjust the Expose Time slider anywhere from 1 ms to 5 seconds (5000ms) so the object 
you are imaging is not over or under exposed. 
 
Also play with the Gain Slider to see how that affects 
your image (don’t be afraid of Gain). 
 

 

Step 4 

Step 5 

 



M A L L I N C A M S K Y  D S 1 0 C T E C  U S E R  M A N U A L  

 

29 

 

Trigger Mode 
 
In selecting Trigger Mode, the camera will wait for you to tell it to commence (Loop). So, 
enter your time in the m(in), s(ec), ms, and us boxes, and Click on the Single button to do just 
one exposure. 

 

 
 
If necessary, adjust the exposure time settings and repeat. Once you are happy with the 
exposure time, you can now tell MallincamSky to continuously take images at that exposure 
by clicking on the Loop button. To stop the camera from imaging, again Click on the Loop 
button (which has now changed its name to Stop). 
 

Adjust the Parameters 
 
Choose a parameter from the Camera Tab on the Left Side Bar 
and see what you can adjust, and how it affects your image.  

 
You will have to wait until the next image is exposed to see how 
your adjustments look (keep an eye at the bottom of the screen 
to see when the next adjusted image will appear). 

 
 
Video Mode 
 
You can adjust all the control commands in real-time to 
experience how the adjustment affects your image. We 
recommend you experiment with the Gain, White Balance, 
Color Adjustment, and Histogram to see how easy they are to 
control your image. 
 

Trigger Mode 
 
Trigger Mode is more restrictive to what you can perform in real-time, not to mention that 
you will not see how your adjustment affects the image until the camera’s next exposure. 
 
The control commands available to you when Looping are: White Balance, Color Adjustment, 
Frame Rate, Color/Gray, Flip, Histogram, Dark Field Correction, Flat Field Correction, Black 
Level, and Live Stack. 
 
You will have to wait until the next image is exposed to see how your adjustments look (keep 
an eye at the bottom of the screen to see when the next adjusted image will appear). 
 
 
 

Step 6 
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Have Fun and Experiment 
 
You can now spend some time to become more comfortable with the MallincamSky Software. 
The SkyRaider DS10CTEC User Manual will go into more detail about all the options and 
adjustments you can perform with the SkyRaider series of cameras. But do not be afraid to 
experiment. 
 
The DS10CTEC is not afraid of Gain so experiment with it.  Also, we recommend starting 
Gamma at a low value. These settings will give a very responsive and fast imaging machine 
with a great image. 
 

 

Exit 

To Shutdown MallincamSky (after you have saved your images). Click 
on the x located on the extreme right side of the Top-Bar in 
MallincamSky. It may pop-up a message to remind you that you have 
not saved your images and will give you the opportunity to do so. 

 

  

Step 7 

Step 8 



M A L L I N C A M S K Y  D S 1 0 C T E C  U S E R  M A N U A L  

 

31 

 

Detailed Work-Flow Procedures 
 
Detailed Workflow of Video Imaging Planetary Objects 

  

The following instructions will guide you in setting up your SkyRaider camera for imaging 

Solar, Lunar, or Planetary Objects. 
 
For planetary objects, the exposure setting will be very small (as the objects themselves are 
usually very bright). It is recommended that you start imaging objects, such as the Moon and 
bright Planets, as it will allow you to become comfortable with all the adjustments that 
MallincamSky provides for you. With planetary objects, you want as much resolution and data 
as possible, so choose the highest resolution your SkyRaider provides. 
 
Since the exposure rate is so short, you may find that you do not need to take any Dark Fields 
preparation shots before imaging. But if you do notice warm pixels and would like to eliminate 
them, then follow the step-by-step instructions located in the section called: Dark Field 
Correction later in the manual. 
 
The following instructions are used as a guide to assist you in doing planetary video imaging. 
Don’t forget, when finished with a particular step that uses a particular feature Tab, you can 
collapse the Tab by Clicking on the little up- arrow in the 
right corner of that Tab (This will remove, any green, red, 
or blue boxes which may be displayed over your image). 
 
 
 
If not started, Double Click on the MallincamSky Icon on your Desktop to start the 
program.  
 
 
Select the SkyRaiderDS10C TEC from the Camera List in the 
Camera Tab. 
 
Once the SkyRaider is selected, a black rectangle (with SkyRaider Camera name) will appear 
in the Video Window of the MallincamSky Software along with the Horizontal and Vertical 
Rulers and if the camera is connected, it will display what it is imaging.  

 
 
 
 
 
 
 
 
 
 
 
 

Step 2 

 

Step 1 
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If needed, activate the TEC from the Cooling tab to cool camera (set about 30o below ambient 
temperature). When TEC is activated, the Fan may automatically turn On. If you turn Off the 
Fan by moving the Fan Slider to Off, then TEC will also be deactivated. 
 

 
 
 
 
 
 
 
 
 
 
 
Have your telescope pointed to the Planetary Object of Interest, and it is recommended that 

you use a Barlow Lens attached to your Telescope when imaging Planetary Objects to provide 

a “Larger (Longer Focal Length)” image. 

Since you will want to “push” the capabilities of the DS10CTEC in displaying the Planetary 

object, you will require the highest resolution that the DS10CTEC can produce (see resolution 

section below for the three different resolutions provided), along with the largest bits of data 

(for color or shades of Back and White) for each pixel that the DS10CTEC is able to produce. 

This will provide enough data for external stacking programs to pull out the finest detail from 

your video images. The higher the resolution and data bit setting, the more your computer’s 

CPU must work, along with a larger image file (more disk space) when saved. 

From the Capture and Resolution Tab on the MallincamSky ToolBar, select the Largest 

resolution values that your SkyRaider is capable of. 

 

The SkyRaiderDS10C TEC is capable of 4 resolutions: 3704 x 2778, 4096 x 2160, 2048 x 1080, 

and 1360 x 720. 

 

If you are going to be saving and processing images taken with the SkyRaider, you will want to 

increase the Bit depth to 14 bits, the highest value your DS10CTEC supports. 

 

Step 4 

Step 6 

Step 5 

Step 3 

Do you have your AC 
adapter plugged into the 

Camera? 
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Since you have chosen a High Resolution and a Large Bit Count, this will slow down the 

Frames per Second rate at which the MallincamSky can process the images (huge amounts of 

data moving through the system). We will make an adjustment in a later step that will 

increase the Frames per Second rate. 

  

With MallincamSky running, Left-Click on 

the Capture and Resolution Tab to expand 

the exposure window. 

➢ Move the Gain Slider all the way 

to the Left. 

➢ Click in the Video Mode Selector 

to choose Video Mode. 

➢ Make sure that the Auto 

Exposure CheckBox is 

unchecked. 

 
The SkyRaider DS10CTEC has two exposure modes:  
 

• Video Mode 

• Trigger Mode 

 

 

 
 
 
 
 
 
 
 
Since we are imaging planetary objects, our exposure should not exceed 5 seconds. Therefore, 
we will be using Video Mode exclusively for setting our exposure times. Video Mode will 
continuously take and display images at the duration you set in the Exposure Time slider. 
 
If you have the Green Exposure Rectangle on your image, then you have selected the Auto 
Exposure checkbox, just uncheck it to remove the rectangle. 
 
If you want to use Auto Exposure and the Green Box annoys you, you can Left-Click Hold and 
Drag corners of the rectangle to resize it to either cover the whole image window, or even to 
be a zero-size box at one of the corners of your image window. This way you can always have 
the Capture and Resolution Tab open without the annoying green rectangle in the middle of 
your image.  

 

Step 7 
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Set the Exposure Time 
 

Set your exposure to a small value, say 10ms as a starting point. We are using a small time- 
setting, but the actual exposure amount depends upon the f/ratio, size of telescope, filters, 
seeing conditions, .... You can adjust the exposure using one of the three methods below: 

 

o You can either use the mouse button and Left-Click-Hold and Drag the 

Slider Marker (This method is best for making large movements). 

o You can also Click on the Slider Marker, then use the Left and Right arrows 

keys on your keyboard to precisely move the Exposure Marker (this method 

provides the most accurate tiny adjustments to the exposure times). 

o You can Click on the Exposure Time’s current setting and a pop-up window 

will appear that allows you to enter the required exposure time in 

milliseconds (This allows you to be very precise in the exposure time you 

require, 5000 ms = 5 seconds). 

 

   
 

You should be able to see the Planetary object of interest on your screen. So now 

adjust the Exposure Time to make the object bright enough match your viewing 

requirements. You can also adjust the Gain to the Right to brighten your image.  

 

Adjust the Parameters  

Now is the time to adjust the White Balance and Color 

Adjustment (Contrast, Gamma, …) to your required preferences.  

Located in the Left SideBar are the White Balance and Color 

Adjustment Tabs. Clicking on the Tab Title will expand the Tab 

displaying the controls you can adjust. Left-Click-Hold and Drag 

the sliders to tweak your image.  

Don’t forget Gamma setting when using the DS10CTEC. 

If you get lost by making too many wrong adjustments, just click 

on the Defaults button to reset the image back to its original 

parameters. 

 

 

Step 9 

Step 8 
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Read the appropriate sections in the User Manual (it is great reading, if I do say so myself) to 

obtain more information as to what each setting does in the White Balance and Color 

Adjustment Tabs in MallincamSky. There is no precise value for every user, as we all use 

different equipment, so this is a great time to ‘play’ with the settings to see what value works 

best for you. Just have fun. 

To improve the throughput (Frames per Second), or if you want to isolate the planetary 

object, choose a Region of Interest (ROI) that just includes the image of the planetary object.  

You select the ROI by using Left-Click-Hold and Drag the handles of the Blue Rectangle that 

will appear over your Image Window after you selected the ROI Tab. Once you have framed 

the Blue ROI Rectangle over your image, then Click on the Apply button in the ROI Tab to 

accept it. 

 

This will make the Video Screen contain just the object that was enclosed by the ROI’s Blue 
Rectangle. To return to Full Video Mode, just Click on the Defaults Button on the ROI Open 

Tab. 
 

  

 

 

 

 

 

 

Using the Scroll Wheel (or CTRL-Scroll, depending upon your preference settings; see 

Preference section of manual) on your mouse, when the mouse is over the Image Window 

will enlarge and reduce the image size in the Image Window. 

Step 10 
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Adjust the Histogram  

To finely adjust the image characteristics, open up the Histogram Tab, and either enter in the 

Left and Right values, or Left Click, Hold and Drag the two Vertical Bars so that you are not 

clipping data, on either side of the window. These adjustments will help improve the image on 

the screen. The Histogram Tab will take a bit of practice to become comfortable with it (read 

the section below covering the Histogram Command for more details). Set the exposure so 

that the peak of the histogram is someplace between 50 and 100. 

 

For any Exposure over 3 seconds (3000 ms), you can determine how long your camera’s 
exposure time has left by looking at the bottom of the MallincamSky’s Window, near the 
middle. It will provide a real-time indicator that informs you of the time used of the exposure 
time that you had previously set. 

 
 
 
The example above tells us that we have used 5.2 seconds of our 30 second exposure. 
 
 

Have Fun and Experiment 
 
You can now spend some time to become more comfortable with the MallincamSky Software. 
The SkyRaider DS10CTEC User Manual will go into more detail about all the options and 
adjustments you can perform with the SkyRaider series of cameras. But don’t be afraid to 
experiment. 
 
Move the Gain to higher values until noise becomes an issue (usually at about 100)  
 
Try the different values of Sharpen to see what details you can pull out of your planetary 
image. 
 
 
If you are imaging the Sun in the daytime, then select Options from the Top Menu Line, then 
choose Preferences. It is here that you can set options for MallincamSky. If you go into Misc., 
you can change the Display Color Style of the MallincamSky software which may be easier to 
see in bright daylight. If you select another Color Style, Apply, then Left-Click on OK. Choose 
the Color Style which works for you. (Use a bright Color Style if using computer in Daylight).  

 
 
 
 

Step 11 

 

 

 

Step 12 
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Detailed Workflow of Video Imaging Deep Sky Objects 
 

The following instructions will guide you in setting up your SkyRaider DS10CTEC camera for 
imaging Deep Sky Objects (DSO). 
 
For Deep Sky Objects, the exposure setting will be very large (as the objects themselves are 
usually very dim). It is recommended that practice imaging objects, such as the these, as it will 
allow you to become comfortable with all the adjustments that MallincamSky provides for 
you.  
 
Optionally, since the exposure rate can be very long, you may need to prepare your system by 
taking Dark Fields and a Flat Field. If this is the first-time imaging DSO’s, you may not have 
saved previous Dark Fields, so this Walk-Through will take you through the Dark Field 
preparation step.   
 
Remember complete explanations of each of the processes and controls are provided later in 
the User Manual. 
 
The following instructions are used as a guide to assist you in doing Deep Sky imaging. Don’t 
forget, when finished with a particular 
step that uses a particular feature tab, you 
can close the Tab by clicking on the little 
arrow in the corner of a Tab (This will 
remove the red, green and blue boxes which may be displayed over your image). 
 
Have your SkyRaider DS10CTEC connected to your telescope, and since you are video imaging 

Deep Sky Objects, you should have a Focal Reducer attached. This will provide you with two 

benefits: first you will be presented with a larger field of view (see more of the object), and 

second, you will have a faster telescope (shorter exposure times). 

 If the program is not Started, Double Click on the MallincamSky Icon on your Desktop 

to start it.  

 
 
Select the SkyRaiderDS10CTEC from the Camera List in the 
Camera Tab. 
 
Once the SkyRaider is selected, a black rectangle (with SkyRaider Camera name) will appear 
in the Video Window of the MallincamSky Software along with the Horizontal and Vertical 
Rulers.  
 

 
 
 
 
 
 
 
 

Step 2 

Step 1 
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Activate TEC from the Cooling tab to cool camera (set about 30o below ambient temperature). 

 
 
 
 
 
 
 
 
 
 
 

Since you will want to “push” the capabilities of the SkyRaider in displaying the Deep Sky 

Object, you will require the highest resolution that your particular SkyRaider can produce, 

along with the largest bits of data (for color or shades of Back and White) for each pixel that 

the SkyRaider is able to produce. This will provide enough data for external stacking programs 

to pull out the finest detail from your video images. The higher the resolution and data bit 

values, the more your computer’s CPU must work, along with larger saved image files. 

From the Capture and Resolution Tab on the MallincamSky ToolBar, select the largest 

resolution values that your DS10CTEC is capable of. 

The SkyRaiderDS10CTEC is capable of 4 resolutions: 3704 x 2778, 4096 x 2160, 2048 x 1080, 

and 1360 x 720. 

 

If you are going to be saving and processing images taken with the DS10CTEC, you may want 

to increase the Bit depth to 14 bits, the highest value your DS10CTEC supports. 

 

Since you have chosen a High Resolution and a Large Bit Depth, this will slow down 
the Frames per Second rate at which MallincamSky can process the images (huge 
amounts of data moving through the system). We will make an adjustment in a later 
step that will help increase the Frames per Second rate. 
 

Step 5 

Step 4 

Step 3 
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Take a set of Dark Fields 
 
Due to the Large Exposure times that you will be using in imaging Deep Sky Objects, the 
DS10CTEC (in fact every camera no matter what the cost) will sometimes display noise such 
as, warm pixels and amp glow. The longer the exposure the more noise that can appear on 
your image. The MallincamSky software can remove this noise, by applying pre-prepared Dark 
Fields to your images, effectively removing the noise. 
  
Either place the Lens cap over your Telescope or place the dust cover cap over your SkyRaider 

DS10CTEC camera to block any light from hitting the sensor of the camera. 

Open the Dark Field Correction Tab on the Left SideBar of MallincamSky. You will normally 

determine the maximum exposure time that you will be using for the evening, but to get 

started for the first time, we will choose 5 exposures of 30 seconds. Adjust the Quantity to 5. 

 

 

 

 
 
 
 
Select an Exposure Time for Dark Field Correction 
 
With the Camera Tab selected on the Left SideBar, Left-Click 
on the Capture & Resolution. 
 
You must determine what you believe will be the maximum 
exposure for this session. As, you will create Dark Field’s with 
this time (or close to it). In this example we will choose 30 
seconds. 
 
In the Capture & Resolution Tab; Click on the Trigger Mode 
Radial Button (Trigger Mode is used to select any exposure 
time over 5 seconds).  
 
Move the Gain Slider to about where you would normally use 
it (start with 50 if not sure). 
 
Either enter the time into the appropriate exposure time unit 
boxes or use the up and down arrows beside the chosen 
Exposure time unit to set your maximum time. For us, set the 
seconds (s) time unit to 30 for 30 seconds. 

 
 
 

Step 6 

Step 7 

Step 8 
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To start the SkyRaider DS10CTEC taking continuous exposures, Left-Click on the Loop button. 
Since we have chosen 30 seconds, you will notice, on the bottom of the Main Window of 
MallincamSky is the Exposure indicator. This shows you the current set exposure time used in 
the exposure. 

 
The example on the left tells us that 
we have used 4.1 seconds of our 30 
second exposure. 

 
 
Take Dark Field Correction 
 

Ensure that the cover is either on the SkyRaider Camera or the Telescope itself is covered, 
then Left-Click on the Dark Field Correction Tab.  
 
The Dark Field Correction Tab will expand allowing you to select the Quantity of Dark Fields 
and the option to start the Dark Field Capture process. 
 
 
Select 5 for the Quantity, then Left-Click on the Capture Button 
(which will change its name to Stop in case you need to abort the 
Dark Field capture). The Software will display its progress above the 
selected Quantity. Remember, it is beneficial to set the Dark Field 
exposure time greater than the longest time you will be imaging at. 
 
 
As the Dark Fields are being exposed, you can watch the exposure 
counter in the Dark Field Correction Tab go up to let you know how 
many Dark Fields have been taken (2 out of 5 in the above example).  

 
 
 
Once the Dark Fields have been taken, you have the option of saving them by Clicking on the 
Export button and saving them in a folder of your choice. This way you can use them again on 
another night. 
 
You can also import previously saved Dark Fields by using the Import Button.  
 
 
When you are ready to apply the Dark Fields to your images (in real 
time), simply Check the Enable box in the Dark Field Tab. Unchecking 
the Enable box will prevent Dark Fields from being applied to the 
images. For now leave it unchecked. 
 
 

Now is the time to get busy with imaging our Deep Sky Object since the preliminary work is 

done. So, remove the Lens Cap from the Telescope, or Lens Cover from the DS10CTEC. 

 

Step 9 
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Hopefully, your telescope is mostly polar aligned, and you are ready to visit your first DSO, and 

produce an image to impress one friends, neighbors, and spouse (so you can justify spending 

all of your hard-earned money on those extra pieces of equipment that you just had to have 

for imaging). 

Focus your Telescope 

The first thing we need to do is align and verify the focus of our Telescope. To do that we only 

need a short duration exposure (under 5 seconds), so we will use Video Mode. 

 Open the Capture and Resolution Tab and ensure that the Auto Exposure box is unchecked. 

Move the Gain slider to about the same value you set in the Dark Field, say 50. Remember the 

higher the Gain the shorter the Exposure Time. We want short exposures to allow us to focus 

without having to wait too long until the next image refreshes.  

Now Select the Video Mode Radial indicator button, then either use the Slider or Click on the 

Current Exposure Time Value to open the Exposure Time Window. Enter in 1 second (1000 

ms) in this window and Click the OK button to accept. 

  

We will use a small exposure, so we can verify that the object is someplace in the field of view 

(if in using 1 second the star or object is too dim, increase exposure to 2 seconds or increase 

the Gain). This is a great time to check your focus as the images will be updated very quickly. 

You can use the Crosshair’s Icon at the top of the MallincamSky Window to assist in centering 

your object (or focus a star). Click on the Crosshair to activate, and again Click on the 

Crosshair to deactivate it. 

 

Again, if the image is too dim, try increasing either the Exposure or the Gain.  

Now, you have your Deep Sky Object (or at least a dim version of it, centered in your screen. It 

is time to crank-up-the-volume. Well, for us, time to increase-the-exposure-time. 

If the Capture and Resolution Tab is not open, then Click on it to expand its Window. 

When imaging Deep Sky Objects, we will need to use an exposure over 5 seconds (5000ms), 

this is where the Trigger Mode comes in, on the DS10CTEC. 

 

Step 10 

Step 11 
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Image your object  

Click on the Trigger Mode Radial selection button to activate 
Trigger Mode. 
 

Set your exposure to a large value, say 30s as a starting point 

(we are using 30 seconds, but the actual exposure amount 

depends upon the f/ratio, size of telescope, filters, seeing 

conditions, ...). You can adjust the exposure using one of the 

two methods below: 

• You can Click in the Time Units Box and enter in an 

amount (30 seconds) using your Keyboard. 

 

• You can Click on the up or down arrow in the Time 

Unit Box of choice to move the exposure time to 

your required value (30 seconds). 

 

Click on the Single Button to take a single exposure to see if the image of the object is close to 
the brightness you need. 
 
If you are satisfied with the single image, then Click on the Loop Button to have the SkyRaider 
DS10CTEC continuously take images (at 30 seconds in our example). 
 
Since we have chosen 30 seconds, MallincamSky will continuously display the exposure time 

and the current amount of time captured in the exposure info box located on the Bottom of 

the MallincamSky Window (MallincamSky does this automatically for any exposure over 3 

seconds). 

 
The example on the left is telling us that we have exposed 5.2 
seconds of our 30 second exposure. 

 
 
Now, we are heading into the “Art” of video imaging. You can decrease the Exposure Time, as 

long as you increase the Gain. But, by increasing the Gain, you also increase any noise that is 

present. Use your own judgment in what you are willing to accept on your image. 

 

The DS10CTEC will continuously refresh the image based on the exposure time, and any 

adjustment you make will not be visible until the next refresh. This includes if you move your 

telescope; you may see streaks until the next complete refresh of the image. 

 

Now, that we have an image that we are happy with, it is time to enable Dark Field 

subtraction (if you took Dark Field Images). 

Step 12 
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Apply Dark Fields 

 

Click on the Enable CheckBox in the Dark Field Correction 

Tab. Dark Fields will be automatically applied during the 

next image refresh, so in our example you may have to 

wait up to 30 seconds before the Dark fields are applied. 

 

 

 

   
 
 
 
 
 
 

 

You can deactivate the dark field correction at any time by unchecking the enable box in the 

Dark Field Correction Tab. 

 

Do not forget to read the section on how to make and save Dark Fields to improve your 

imaging results. 

 

Obtaining an Image of our First Deep Sky Object is enough for most to start the celebration 

process (again most of us will call for our spouse to have a look at the amazing image we have 

just produced, again trying to justify the money used in buying those extra pieces of 

hardware). 

 

Next, we want to fine tune our image to perfection (at least that is what you will tell yourself), 

but this is a great time to get familiar with some of the adjustment options available in 

MallincamSky. 

 

 

 

Step 13 

M57, 20 Seconds exposure, VRC 6", F/4.5 with 
MallinCam 0.5X focal reducer, NO Dark Field 
Correction. No processing, as seen live on 
monitor. Single frame. 

M57, 20 Seconds exposure, VRC 6", F/4.5 
with MallinCam 0.5X focal reducer, One 
Single DARK FIELD CORRECTION APPLIED 
LIVE, No processing, as seen live on 
monitor, Single frame. 
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Adjust the Parameters 

 

Now is the time to adjust the White Balance and Color Adjustment 

(Contrast, Gamma, …) to your required preferences.  

Located in the Left SideBar are the White Balance and Color 

Adjustment Tabs. Clicking on the Tab Title will expand the Tab 

displaying the controls you can adjust. Left-Click-Hold and Drag the 

sliders to tweak your image.  

If you get lost by making too many wrong adjustments, just click on 

the Defaults button to reset the image back to its original 

parameters. 

You can adjust the Gamma (start with a low Gamma value), Brightness, Contrast, … in real 

time, but it will not appear on the Video Window until the SkyRaider has done its next refresh 

(which depends upon the current exposure time). 

Read the appropriate sections in the User Manual (it is great reading, if I do say so myself) to 

obtain more information as to what each setting does in the White Balance and Color 

Adjustment Tabs in MallincamSky. There is no precise value for every user, as we all use 

different equipment, so this is a great time to ‘play’ with the settings to see what values work 

best for you. Just have fun. The best part is if you mess up, there is always the Defaults Button 

to bring your image back to the way it was. 

Histogram 

To finely adjust the image characteristics, open 

the Histogram Tab, and either enter in the Left 

and Right values, or Left-Click-Hold and Drag 

the two Vertical Bars so that you are not 

clipping data, on either side of the window. 

These adjustments will help improve the image 

on the screen. The Histogram Tab will take a bit 

of practice to become comfortable with it. For 

more detailed information on how to use the 

Histogram Tab, locate that section in the User 

Manual.  Set the exposure so that the peak of the Histogram is someplace between 

50 and 100. 

 
You cannot adjust Exposure or Gain, when the SkyRaider is in loop mode. You will 

need to stop the looping, adjust the exposure or gain, then restart the looping. 

Step 14 

Step 15 
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This is where you must take over adjusting the parameters, as each telescope, night-

sky, seeing conditions are different from user to user. So, have fun and experiment 

with the settings and see how they affect your image. Remember, these are your 

images, and you decide what is best for you.  

 

 

 

   
 
 
 
 
 
 
Digital Binning 
 

To shorten the exposure (also reduces the resolution), you have the option of 

selecting Digital Binning. You can choose no Binning (1 x 1) all the way to 8 x 8 

Binning.  Note, you will need to re-adjust 

appropriate histograms, contract, … after 

choosing a different binning number. You 

will also notice the Video Screen image size 

is reduced to match the “digital resolution” 

of the Mallincam Camera when the Digital Binning is applied. You need only increase 

the Zoom factor to increase the size of the window. 

You can also indicate if you would like the binning process to use Additive (sums) or 

Average algorithms.  

Additive provides a faster image (so it will appear brighter), while the Average setting 

will produce a sharper image with no increase in exposure time. Play with it to see 

what you prefer.  

Exit 

To Shutdown MallincamSky (after you have saved your images). Click 
on the x located on the extreme right side of the Top-Bar in 
MallincamSky. It may pop-up a message to remind you that you have 
not saved your images and will give you the opportunity to do so. 

 

Step 16 

 
Step 17 
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C3: Quick Overview of the Left Sidebar 
To expand the control just click on the down-arrow symbol that is located on the right of the control. 
The control will expand providing you will its options. You can expand as many controls as necessary, 
but you may need to use the slider (which automatically appears if the control information is larger 
than the MallincamSky Window. To close the control, just click on the little up-arrow symbol located 
on the right side of the control. 

 

 The Camera List contains the list of attached Mallincam Cameras. If a USB 

3.0 camera is attached to a USB 2.0 port, then (USB 2.0) will be appended 

to the name. Clicking on the camera name will activate the camera and 

display its image in the Video Window. 

 

 Snap takes a picture of what is currently being displayed in the Video 

Window and places that image in its own tab with default name 0001*. 

Record starts recording a video of what is being imaged. The recording 

will stop when you click on the recording button again. 

Resolution contains the current resolution of the camera. 

Format of the camera RGB24, or RAW. 

Gain adjusts the amplification of the signal from the camera. 

 

Video Mode displays the image in Video Window in real-time 

Auto Exposure has MallincamSky choose best exposure for you when 

checked. 

Exposure Target gives Auto Exposure some value to aim for. 

 

Exposure Time allows you to set an exact exposure from 0 s to 5 s. 

 

Trigger Mode displays long exposure images from 0.100 ms to 1 h in the 

Video Window. Activated by the Loop control. 

 

Exposure Time allows you to set the Exposure time. 

 

Single allows you to take a single exposure. 

Loop allows MallincamSky to repeatedly take exposures. 

Sequence allows you to set up a sequence of looped exposures. 

Number determines the number of exposures in sequence. 

Options… allows you to set the destination and format of the video 

sequences. 

 

 

Chapter 
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Bit Depth sets the number of bits the camera assigned to the image for 

Windows display. When set to 8 bits you have 256 available colors. When 

set to 14 bits you have 16384 available colors. The larger the bit depth the 

larger its size is and the more load it places on the cpu. 

 

 White Balance allows you to select a region of the Video image via a red 

box and do a white balance correction by clicking on the White Balance 

button. 

 

The Red slider allows you to manually adjust the red level in the video 

image. 

 

The Green slider allows you to manually adjust the green level in the 

video image. 

 

The Blue slider allows you to manually adjust the blue level in the video 

image. 

 

The White Balance button allows you to activate red box as the White 

Balance template and MallincamSky will adjust the Red, Green, and Blue 

values. 

The Defaults button resets the White balance to red=0, green=0, and 

blue=0.  

 

 

 Color Adjustment allows you to adjust its real-time various components 

of the video image. 

 

Hue – the slider allows you to modify the indicator of dominant color. 

 

Saturation – the slider allows you to modify the intensity of color in the 

video image. 

 

Brightness – the slider allows you to modify the brightness of the video 

image. 

 

Contrast – the slider allows you to modify the difference in brightness of 

the elements in the image. 

 

Gamma – the slider allows you to modify the captured brightness to the 

perceived brightness. 

 

The Defaults button returns all the Color Adjustments to their default 

value. 

 

 

The Frame Rate control allows you via the slider to adjust the rate at 

which the SkyRaider camera streams its data through the USB port. If 

your video window does not display an image, then move the slider 

toward the Low end of the Bar, as your computer cannot handle the rate 

at which the data is being pushed. 

 

 

The Color/Gray command allows you to determine if you would like to 

view the video image in color or in shades of grey. Select by clicking in the 

appropriate radial button. 



M A L L I N C A M S K Y  D S 1 0 C T E C  U S E R  M A N U A L  

 

48 

 

 

 

The Flip command allows you to flip the video image in the Horizontal, 

Vertical, or Both. Flip in the required direction by checking the 

appropriate checkmark box. The flip command can be used to match the 

orientation of the image to your needs. 

 

 

The Rotate command allows you to rotate the image clockwise in four set 

angles: 0o, 90o, 180o, and 270o. Click in the require radial button the rotate 

the image. 

 The Sampling command, which the DS10CTEC does not use), allows you 
to select a sampling style. 
-Bin refers to the method of combining (averaging) pixels of block of 
neighboring same color pixels to resize the video to a lower resolution 
(can increase video frames/second). 
-Skip (also known as decimation) means that a certain number of pixels is 
not read out but skipped (horizontally, vertically or in both axes). This 
reduces resolution of the resulting video but introduces subsampling 
artifacts. 

 

The ROI (Region of Interest) command presents a saleable and draggable 

Blue box which you can adjust with your mouse. Enclosing a region of 

your image and clicking on the Apply button will make the Video Window 

only contain what was enclosed within the Blue box. To return to the full 

Video Window click on the Defaults button. 

 

 

 

 The Digital Binning command will allow you to Bin your displayed video 

image to either increase the sensitivity of the camera or improve the 

quality of the image. 

 

Method selects style of binning (Additive or Average) 

Additive: add pixels together (bases on the number selected) to increase 

sensitivity. 

Average: adds pixels together (bases on the number selected) to increase 

quality of image. 

 

Number determines the amount of binning selected. 

1: No binning 

2: 2 x 2 binning 

3: 3 x 3 binning 

4: 4 x 4 binning 

5: 5 x 5 binning 

6: 6 x 6 binning 

7: 7 x 7 binning 

8: 8 x 8 binning 

 

The Histogram command displays the relationship of the distribution 

comparing the number of pixels at a specific color level. This Realtime 

graph allows you to adjust the dark and light endpoints to stretch the 

image to reveal more detail in the shaded areas. 

 

RGB: allows you to select a color channel. 

Linear: displays the distribution using either a linear or logarithmic scale. 

Left: lets you manually enter the starting dark region. 

Right: lets you manually enter the ending light region. 

Manual: Allows you to adjust the Histogram. 

Once: lets MallincamSky select what it feels is the best values for Left and 

Right.  
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The Dark Field Correction command will allow you to take and apply Dark 

Fields. 

Enable: once checked will apply the previously taken Dark Fields to your 

video image in Realtime. 

Caption: will take (ensure camera is covered) the Quantity number of 

Dark Fields. 

Quantity: the number of Dark Field images to take. 

 

Import…: allows you to load previously taken Dark Fields. 

Export…: will allow you to save currently taken Dark Fields. 

 

The Flat Field Correction command will allow you to take and apply Flat 

Fields. 

Enable: once checked will apply the previously taken Flat Fields to your 

video image in Realtime. 

Caption: will take (ensure camera is covered) the Quantity number of Flat 

Fields. 

Quantity: the number of Flat Field images to take. 

 

Import…: allows you to load previously taken Flat Fields. 

Export…: will allow you to save currently taken Flat Fields. 

  

The Dark Level command allows you to adjust the range of the blackness 

in the video image. The left end (0) is the darkest, while the right end 

(496) is the highest. 

 

The Live Stack control allows you to combine numerous images together 

in Realtime. 

Enable: activates the stacking process. 

Align Frames: when checked will align the frames before stacking. 

Number: contains the number of rolling frames that will be stacked 

Mode: determines the type of stacking that will be performed. You have a 

choice of Additive (produces brighter image), or Average (produces better 

quality image). 

Type: Allows you to choose the type of object you are imaging, so to 

improve the Alignment algorithms. Choices are Planet or DeepSky. 

Input: number of images accepted into algorithm 

Output: number of Stacked images produced 

Status: if alignment is successful 

 

The Conversion Gain control will allow you to choose what Gain algorithm 

that MallincamSky should use.  

HCG: High Conversion Gain produces a brighter image is the specific time, 

but more noise. 

LCG: Low Conversion Gain produces a dimmer image in the specific time, 

but less noise. 

HDR: High Dynamic Range is not available for DS10CTEC. 

 

The Cooling control will allow you to set a target temperature and 

activate the internal cooling mechanism. This control also allows you to 

activate the camera’s internal fan (ac adapter must be powered on). 

 

TEC: allows you to activate with the On radial button, or deactivate with 

the Off radial button. Once activated you can select a Target temperature 

and apply it. 

 

Fan: via the slider, you can allows activate the internal fan in the camera. 
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The Sharpen control allows you to tweak the sharpening of the finer 

details of the Realtime video image. The slider gives a range of 0% (which 

is off) to 500% (all the way to the right). 

 

The Misc control allows you to produce an inverse or negative of the 

Realtime video image by checking in the checkbox. 

 

Low Noise internal operation to help reduce noise on output. 

 

The Preset control allows you to save and load previous control settings 

that you have used to image of previous sessions. A drop-down list 

displays the names of previously saved presets including a Factor Reset 

for the settings. 

Load: loads in the settings from the drop-down list  

Save: saves the current control settings in the name of your choice 

Overwrite: resaves any current setting changes using the same name 

Management: allows you to import or export settings from other users 

 

C3b: Quick Overview of the Icons 
The Top-Line icons provide quick access to the most often used controls not used for adjusting the 
image). Just click on the icon to activate. Some icons have associated Hot-Keys which also can be used 
by the user (or other programs). 

          

Open Save Auto 
Capture 

Browse Thumbnail Target Image Type Batch 
Record 

Pause/Start 
Recording 

Open 
Recording 

Folder 

Ctrl-O Ctrl-S F7 Ctrl-B Ctrl-T   F10   

 

         

Zoom Track Histogram Cross 
Hairs 

ST4 Video 
Frame 

Advance 

Stitch Preferences Customize 

Ctrl-Scroll 
Wheel 

Ctrl-Num 
(/*02345+-) 

     Ctrl-Shit-T Ctrl-P  
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C4: Detailed Description of 

MallincamSky Controls 
This Chapter of the User Manual will describe in exact detail what each control on both the Top 
Line Menu and the Icon Toolbar does. This Chapter is best read on a rainy day or can be used 
to jump to the specific section that describes how to use a particular control. 
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Top Line Menu  

 
 
 

File 
 
This Drop-Down Menu will allow you to Load and 
Save images, play video files that are stored on your 
computer, and examine recent videos or images that 
you have view using MallincamSky.  

 
 
 
 
 
 
 
 
 
Open Image 

 
The Open Image command is used to 
open an existing image file. This command 
can also be used to preview an image (just 
check the Preview box to see the image), 
or to view its statistics and information 
without opening the image itself. You can 
use this command to quickly locate an 
image on your computer. MallincamSky 
supports and can open a variety of image 
formats. These are identified in the Files 
of type list box. 

 
MallincamSky can open more than one 
image simultaneously by: 
 
➢ Ctrl + Left Mouse Click on each 

required File, then Left-Click on 

Open 

➢ Shift + Left Mouse Click method 

to highlight the files to be opened, then Left-Click on Open 

When an image is opened, MallincamSky places it into a new image window and that image 
window then becomes the active image.  
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O p e n  V i d e o   

 
Use the Open Video Command to open an existing video on your computer.  
The Open Video command is only enabled when no SkyRaider Camera is active when 
MallincamSky is running. Only a single video can be opened at a time.  
 
Right-Click on Video [SkyRaiderDS10CTEC] Title in Video Window, then choose Close. This 
will shut down the video stream and allow you to use the File>Open Video command. 
 

 
 
Select the name of the file you want to open. If the file does not appear, select the option for 
showing all files from the Video Files Drop-Down Button. The video file type can be wmv, asf, 
ser, mp4, or avi format. 
 
You can preview the Video by Left-Clicking on the Play Button on the Preview Window on the 
right side of the Open Window. 
 
Click on the Open Button to open a video file, this will create a New Video Window and begin 
to start playing the video stream. The video window will be associated a name called “Video 
[XXX.XXX]” (i.e., its title bar will display “Video [XXX.XXX]”, here, XXX.XXX is the video file 
name). No sound will be heard when playing the video stream. 

 

 
 
 
You can control the Video with controls or slider located on the Bottom Left of the Video 
Window. Current Frame Number is also displayed on the Bottom of the Video window. 
 

➢ The  icons control the video speed. 

➢ The  icon can pause or run the video. 

➢ The  icon can move the Video one frame at a time. 
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S a v e    

 
For Save and Save as…, we are assuming you are using the RGB format for the camera. If you 
are using RAW format for the DS10CTEC then the saving format will only be FITS. 
 
The Save command allows you to save a snapshot of the image (not live Video recording) onto 
your computer. The command opens a folder box for you to choose a name, location, and 
format for the image.  
 
If you are looking at a snapshot of an image which you have already saved (and thus named), 
then the Save command is disabled. You will need to use the Save As Command to resave the 
image. The default “Save as type” will be “Window Bitmap (*.bmp,*.dib,*.rle)”.  
 
If Format Resolution is set to RGB48 then the saved image will not match the viewed stacked 
image. 
 
The File>Save command can be used to save the most recent image changes to disk (unless 
you have already saved and named the image, then you must use File>Save As). It is often 
performed as a precautionary measure during lengthy or involved processes to reduce the 
amount of reprocessing that might be required in the event of a system failure or operational 
error. 
 
When an image is being closed (Right-Click on Image title) and you have chosen not to save its 
changes from the Popup Window, MallincamSky discards all changes made since the last 
File>Save operation. 
 
The File>Save command saves the contents of the entire window, unless if there was an ROI 

(Region of Interest) defined on it, in which case it will save the ROI contents. The File>Save 

command will be disabled if the file is not changed or the changes have been saved. 

 

SAVE AS …  

The Save As command allows you to save an image onto your computer with a specified file 
format. At the end of a File>Save As ••• operation, the image window will be associated with 
the new file and the new format (i.e., its title bar will display the new file name). 
MallincamSky supports the following file formats: 
• Window Bitmap (*.bmp,*.dib,*.rle) 

• JPEG (*.jpg,*.jpeg,*.jpe,*.jif,*.jfif) 

• Portable Network Graphics (*.png) 

• Tag Image File Format (*.tif, *.tiff) 

• PCX(*.pcx) 

• Targa (*.tga) 

• JPEG 2000 Standard (*.jp2) 

• JPEG 2000 Codestream (*.j2k) 

• MallincamSky File Type (*.tft) 

• FITS (*.fit, *.fits) 
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The Save As command has several important uses beyond simply saving an image to a new file 
name. Left-Click on the Option button to select the different parameters to encode the file 
(based on selected Save as Type).  
 
For Bitmap (*.bmp), PCX (*.pcx), Targa (*.tga); There is no Option choices. 
 
 
 

 
 
 

 
 
 
 
 
 
 
 

 
 
 
 

 

 
 
 
 
 

 
 
 
 
 
 
 
 
 

JPEG 

Image quality If you save an image in 
JPEG format (*.jpg), you 
may adjust the image 
quality in the edit box. The 
values range from 0 to 100. 
Default value is 75. 

Progressive The default is unchecked. 

Optimize Huffman 
codes 

The default is unchecked. 

Smoothing The values range between 
0 and 100. The default 
value is 0. 

Save these setting 
as defaults 

When saving a file, the 
current settings will be 
saved as defaults for the 
next file save operation. 

PNG 

Interlaced The default is 
unchecked. 

Save these 
setting as 
defaults 

When saving a file, the 
current settings will be 
saved as defaults for the 
next file save operation. 
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Appended Pages Determine whether the 
current image will be 
saved in multiple pages’ 
style or not. 

Compression Specifies a method for 
compressing the 
composite image data. For 
saving a 32-bit TIFF file, 
one can specify that the 
file be saved with 
predictor compression. 

Image Quality If choosing Compressions 
as "JPEG", the Image 
quality can be adjusted by 
the slider bar. The values 
range between 0 and 100. 
The Default value is 75. 

Save these setting 
as defaults 

When saving a file, the 
current settings will be 
saved as defaults for the 
next file save operation. 

TIFF 

JPEG 2000 

Compress Ratio If choosing Compressions 
as "JPEG 2000", the Image 
quality can be adjusted by 
the slider bar. The values 
range between 0 and 100. 
The Default value is 0. 

Save these setting 
as defaults 

When saving a file, the 
current settings will be 
saved as defaults for the 
next file save operation. 

TFT 

Compression Choose Lossless or JPG 
(Lossy) 

Image Quality If choosing Compressions 
as "JPEG", the Image 
quality can be adjusted by 
the slider bar. The values 
range between 0 and 100. 
The Default value is 75. 

Save these setting 
as defaults 

When saving a file, the 
current settings will be 
saved as defaults for the 
next file save operation. 



M A L L I N C A M S K Y  D S 1 0 C T E C  U S E R  M A N U A L  

 

57 

 

B a t c h  S a v e …    

 
The File>Batch Save••• command will be enabled when: 
 

a) Image(s) are captured from the camera using Snap (There will be * after name). 

b) An image window is created by choosing the File>Paste as New File command. 

c) An image window is created copied from the Undo/Redo Sidebar. 

To start the File>Batch Save•••command, you must: 
 

1. Choose the File>Batch Save ••• command which will bring up a Batch Save dialog: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Directory: Enter the name of the drive and directory where your captured images 

will be saved. You may either type the path information or use the Browse button to 
locate it from the standard Windows Browse Folder dialog. 
 

Sub: Select from the list an optional sub-director name to create within the above 

selected directory.  
 

Name Format: The year, month, date, hour, minute and second or a number 

nnnn (sequence) are used as part of the filename. If more files are saved within a 
second when using a time format, a (xx) suffix is attached to the end of Name Format 
to avoid the possible name conflict. For the nnnn (sequence) “Name Format”, no 
suffix is needed. 

 

File Prefix: Enter a file name prefix for Batch Save when generating files names 

for a series of images. This prefix will be combined with Name Format to form a final 
file name naming paradigm. 
 

File Type: In this combo box, select the format in which you want the image to be 

saved (can be BMP, JPG, PNG, TIF). Click the Option Button to set the different 
parameters for encoding the file (For BMP format, the Option will be disabled. See 
File>Save As ••• command about the details of the format encoding methods). 

 

Sample: The final file name is shown at the right of the Sample label for quick 

reference to see if you like it. 
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2.  Once the settings are made, Left-Click the OK button to begin the file batch save 

process or Cancel to “cancel the File>Batch Save •••” command and return to the 
application. 

 
When the File>Batch Save••• command has finished, the Title on the Image Tab or Image 

Window will be modified with the file name formed in the Batch Save dialog. 

 

The File>Batch Save••• will perform no saving operation if the file is not modified. 

 

To view the folder where Batch Saved images are stored, 

use the open folder icon and choose the open image folder 

option. 

 
P a s t e  a s  N e w  F i l e   

 
The File>Paste as New File command will be enabled when there is valid image data on the 
Windows clipboard. (See the Edit>Copy command). If there is no image data on the clipboard, 
the File>Paste as New File command will be disabled (greyed out). 
 
Choose the File>Paste as New File command to place the contents of the clipboard image into 
a new tabbed image window, which becomes the active image. 
 
The Tab Name will be in the XXXX* format (remember the asterisk reminds you that the new 
Tabbed image has not been saved). 
 
This is useful for bringing in a previously saved image (that you have selected via the operating 
systems copy command) into the MallincamSky Image Window. You can modify the image 
properties via the Image Menu choice (see Image section in user Manual). 
 
MallincamSky will accept image data from other applications via the clipboard as long as it is 
in Windows Bitmap format. 
 
MallincamSky will automatically assign a digital number to the Paste as New File command in 
the created image window Title Bar. 

 

 

 

 



M A L L I N C A M S K Y  D S 1 0 C T E C  U S E R  M A N U A L  

 

59 

 

R e c e n t  F i l e s    

 
MallincamSky maintains 4 (the default) of the most recently opened document files under the 
Recent Files command. Choosing one of these submenus will reopen that file immediately. 
 
 

 
 
The maximum number of Recent Files can be modified by choosing the 
Options>Preferences••• command and clicking the Misc selection. Here, clicking the 4 
(default) edit box will allow you to enter the number of the Recent Files Submenu that you 
want. The value ranges from 0 to 8, the default is 4. 
 
One can also check the Clear the Recent Files when exit the application to clear the Recent 
Files after exiting the MallincamSky application.  

 

 

 
E x i t   

Choosing the File>Exit command will close the video window along with all of the image and 
browse windows. After all the windows are closed, MallincamSky will then shut itself down. 

 
If an image has been modified before attempting to Exit, MallincamSky will issue a warning to 
ask if user wants to save the images or not. 
 

 
 
 
 
 
 
 
You then have an option of saving an image, or saving all images, or discarding an image or all 
images. 
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Edit 
 
This Drop-Down Menu will allow you to Cut, Copy and 
Paste Layers over your images.  From the Edit Menu you 
can also select a Region of Interest (ROI) from your image 
and copy it to the Windows Clipboard, or even de-select 
the ROI if you have changed your mind. 

 
Some of the following commands are only active when 
the Folders Tab is selected, and Files are displayed in a 
Browse Window. 
 
 
C u t    

 
This command is used to move a File from one directory to another when using the Folders 

Tab. 

Click on the Folders Tab to make it active, then Double Click 

on a Folder to open it up in the Browse Window.  

Select a File you would Like to Move. 

 

Now use Edit>Cut (or Ctrl-X) to copy this into the Clipboard. 

Select and Open the folder you would like to Move the File into using the Folders Tab (the 

current files in that Folder will appear in the Browse Window. 

 

Now choose Edit>Paste (Ctrl-C). 

The file will be removed from the first folder and transferred to the second folder. 

Note: you will find it easier to use Microsoft Windows to perform this task. 
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C o p y    

 
This Edit>Copy command can be used to copy a selected part of your image (see Select Image 

command) to the Windows Clipboard. Then you can use another software’s Paste Command 

to place this selected image inside that software, or File>Paste as New File to paste into a new 

MallincamSky Window Tab. 

Using the Select Image command, you can select a region of your currently live image (using 

the Left-click Hold and Drag technique) then choose Edit>Copy (or Ctrl+C). Now you can 

Paste that selected image into another document (such as Microsoft Word, or Microsoft 

Paint) for later use.  

  

 

P a s t e    

This control allows you to place a Copied File (you have previously selected the File and then 

used Edit>Copy) into your currently selected folder. Remember to use File>Paste as New File 

to paste image into a new MallincamSky Window Tab. 

 

P a s t e  S h o r t c u t    

This control allows you to place a copied File Shortcut (you have previously selected the File 

and then have used Edit>Copy) into your currently selected folder. 

D e l e t e  

 
This control allows you to delete a selected file from your currently selected folder. 

 
I m a g e  S e l e c t    

 
You can select a Region of Interest on your Image Tab (live or static) by using the Left-Click 

Hold and Drag technique. Once selected then you can Copy (Ctrl+C) the selected region and 

then Paste it into another software program or use the File>Paste as New File to paste image 

into a new MallincamSky Window Tab. 

 

 

 



M A L L I N C A M S K Y  D S 1 0 C T E C  U S E R  M A N U A L  

 

62 

 

 
S e l e c t  A l l  

 
You use this command to select the Whole Video Image Window (live or static). Once 

selected, then you can Copy (Ctrl+C) the selected region and then Paste it into another 

software program or File>Paste as New File to paste image into a new MallincamSky Window. 

 

S e l e c t  N o n e  

 

This command can be used to De-Select the image that was selected using either the Image 
Select or the Select All commands. 
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View 
 
This Drop-Down Menu will allow you to Browse folders, Display or 
Remove Tabs from the Sidebar, Activate Grids or Reticles on the Video 
Window, Change the Video Window Size to match your computer real-
estate, and allows you to move the image around in your Video 
Window.  

  
 
 
 
 
 
B r o w s e   

 
The View>Browse command from the View Menu (or the Browse Icon on 
the Icon Tool Bar) is used to browse images under the specified directory 
in the Folders Sidebar.  
 
The Browse Window resembles Windows Explorer. Left-Clicking on the + 
will expand a folder so that you can examine its contents in the 
MallincamSky Video Window under the Tab name Browse. 
 
You can Right-Click on a Folder (or file) and the actual Windows controls 
will pop as in Windows Explorer.  
 
 

 
 

As you get deeper into the Browse Window, you can Back-Out or Move Deeper via 
the Green Left or Right Arrow in the Browse Window. 

 
The Blue Right Arrow will take you to your computer’s Root Directory.  
 

Left-Double Clicking on a Folder will open a Window Tab in the Video Window (this Window 
will be labeled Browse).  This Tab will display all the graphic files inside that Folder. If you Left-
Double Click on a Graphics File inside the Video Window, it would open up that Graphics File 
in a new Tab in the Video Window. 
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You can adjust how you would like the files in the folder views. Just click and any 
image in the Browse Tab and Right-Click your mouse Button. 
 
This will open up a side Tab Window where you can select how you would like the 
images sorted or viewed. 
 

 
 
 
You can view the Properties of a specific file.  
 
If you select multiple files (hold down the Ctrl Key when Right-
Clicking on files), you will can also now stitch the files together 
(see the Stitch Command in User Manual) 
 
 
 
 
To close the Folders Tab on the sidebar and get 
access to the camera controls, simply Left-Click 
on the Camera Tab heading on the bottom of 
the sidebar.  

 
 
You can close the Browse Tab in the Video Window by Right-Clicking on the Tab’s Title 

(Browse), then choosing Close. 

 

The Folder you choose to browse to will become the default folder when you Save a snapshot. 
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T h u m b n a i l   

The Thumbnail control opens an image tab and displays small (thumbnails) images of all your 

current loaded or snap-shotted images you have taken during this session. A thumbnail of the 

active video Window will also be displayed (this is a real time Window). This way you can 

compare various snapshots with the active window all in small thumbnail sizes. 

 

To Close the Thumbnail Tab, place mouse on the Tab Heading Thumbnail, Right-Click to open 

up a Side Window and choose Close. 

 
S i d e b a r   

The SideBar can contain 4 different Tabs: 

3 of the Tabs; Camera, Folders, and Undo/Redo can be 

selected from the Tabs located at the bottom of the Left 

Side Bar while Histogram can be turned on and off and will 

display underneath the main Imaging Window.  

You will see the 4 choices (each with a checkmark beside it), Left-Click on the checkmark to 

Select or De-Select which one of the 3 choices you would like to see displayed in the Left 

SideBar. 

 

Left-Click on the Left SideBar Tab control to activate the appropriate Tab. 

As mentioned, the Live Histogram will appear underneath the Imaging Window. 
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The Tabs on the SideBar can remain docked to the SideBar or can be free floating (as well as 

the Histogram). Just use the Left-Click Hold and Drag technique to move the Tab to another 

location on your Desktop Window. 

 

To Re-Dock the Floating Tabs back to their Home SideBar, just Left-Double Click on its Name 

(except for the Histogram where you can click on the X in its upper right corner to close it. See 

next section on the Histogram for more details). 
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H i s t o g r a m  

Selecting the Histogram Control splits the image screen with your live image on the top half 

and a live Histogram on the bottom half. You have an option to view the Histogram data as 

linear or logarithmic. Clicking on the Histogram Control again, closed the 

Histogram window. 

This Histogram is for information only and you cannot adjust any parameters 

that will affect the image. We will discuss how to use the adjustable Histogram 

later in the User Manual, but for those of you familiar with Histograms, this 

graph represents the current red, green, and blue values of the current image 

being displayed. This Histogram in an informative window you cannot adjust 

any of the Histogram settings from this display to affect the image.  

The eight icons on the left of the Histogram allow you to pause or switch 
between the linear or logarithmic scale, zoom in or zoom out, display 
statistical data or even save the output data values.  
 
 

The Histogram window is movable and resizable via the Left-Click and Hold 
technique with your mouse. You can also have the Histogram window Float, 
Remain Fixed (docked), and Auto Hide by selecting this feature from the pull-
down arrow on the upper right of the window. 

 
 
The next icon (looks like a thumb tack) on the upper right of the Histogram 

Window, is the Auto Hide control. 

Selecting this will collapse the Histogram and place a 
Histogram Tab underneath the Left-Side Bar on 
MallincamSky. By moving your cursor over this Tab will re-
display the Histogram underneath the Image Window. Moving your mouse away from the 
Histogram Tab will again close the Histogram Window. To deactivate Auto Hide just click on 
the Histogram Tab (Histogram will now remain open, and just deselect the Auto Hide 
selection from the pull-down arrow on the upper right of the Histogram Window. 
 

 
G r i d s   

The View>Grids control has the ability to display a grid 

overlay on top of your Video Window. You can use the Auto 

Grid style to create your own grid format. 

Left-Click on the choice you require (No Grids, Auto Grids, or 

Manual Grids) to activate. 
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This command will pop-up the Preferences Window.  

 

With the Grid Button selected, you can adjust the Line Style (Solid, Dash, Dot, or Dash-Dot), 

Line Width and Line Color that you are interested in, and the color of the reticule. You can 

save these selections as preferences and recall them at a later date using the Preset 

Management …  button. 

 
 

The No Grids control can be used to remove the grid overlay from the video/Image.  
 
If you re-select Manual Grids then your previously designed Grid Lines will re-appear. 
 

Auto Grids 

Clicking on this control will display the grids with color and style you had set up in the 

View>Grids>Settings Control. 

 

 

Settings 

No Grids 
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Choosing this control will display two small Right Arrow and Down Arrows 

overlaid on the top of the Vertical Ruler and on the left of the Horizontal Ruler 

as shown below:  

Use the Left-Click Hold and Drag technique to move the Down Arrow along the Horizontal 
Ruler to wherever you want. When it is dragging over the video/image, there will be a Vertical 
Line (in the Color and Style chosen by you) aiding you in judging where to release this line on 
the video/image. You can drag as many lines as you require to overlay them on the 
video/image. 
 
Similarly, you can drag down as many Vertical Lines as you like to create Vertical Grids. 

 

 

 
You can at any time, grab and move the Arrows to adjust the locations of the Horizontal and 
Vertical Grid Lines. 
 
If you re-select Manual Grids, your previously designed Grid Lines will re-appear except if you 
choose the Divide option. 

 
 
 
 

This command will draw grids on the image window with each 
grid being a specific distance away from the next. A popup 
window will appear asking you for the number that each grid 
will be from the next. 
 
For example, if you require each grid to be 100 points from the next grid you would enter 100 
into the Divide box and Left-Click on the OK button. 

 
 
 
 
 
 

Manual Grids 

Divide 
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This will remove the Grid Overlay from your video/image. It will also delete your Manual Grid 
Lines settings (thus allowing you to create a new set of Manual Grid Lines). 
 

 
 
 

 
This control allows you to save your current grid settings. MallincamSky will ask you for a 
name for this grid pattern. 

 
 

 
This command will allow you to export your Grid Presets 
or allow you to import other Grid Presets. This way you 
can pass along a grid pattern from one computer to 
another. A popup window will appear to allow you to 
manage the process. Note: This will not display the grids, 
you must use the Preset command below. 

  
 
 

 
This command allows you to select from a list of your previously saved and imported Grid 
Presets (via Preset Management). The selected grid pattern will then appear on the screen. 
 
 

B e s t  F i t   

Select the control View>Best Fit to automatically resize the image/video to fit inside the 

Video Window Tab. 

 
A c t u a l  S i z e   

Select the control View>Actual Size to reset the Zoom to 100% (Actual Size will be disabled if 

the View is already set to 100%) and place the image/video inside the Video Window Tab. 

 

F u l l  S c r e e n   

Selecting the View>Full Screen control will display the video window in full screen mode. You 

will not see any commands or controls while in this mode. 

Double clicking on the image with your left mouse button (or pressing the ESC key) will return 

MallincamSky to the Default Video Window. 

Remove All Grids  

Add Preset   

Preset Management  

Preset  
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P i p e t t e   

This will display the 3 channel color component numbers of a Snap  
Shot image. The values will be displayed at the bottom of the screen as you 
move your mouse over the image.  
 

 
T r a c k   

If the video/image's actual size is larger than the video/image Window, then this control will 
allow you to position the parts of the video/image within in the video/image Window.  This 
control is activated automatically when necessary. 
 
Its function acts like the scroll bars. It is an alternative to using the arrows on the scroll bars 
for positioning the video/image within the window. Position the mouse (make sure to choose 
a location outside a Region of Interest rectangle. You may need to close the ROI rectangle if 
necessary) on the actual video/image. 
 
Left-Click and Hold (the Open Hand will change to a Closed Hand). Now drag the image 
around inside the video/image Window 
 
If the video/image size is smaller than the video/image Window size, then the track 
operation will be disabled. 
 
 

V i d e o  F r a m e  

 
These controls are for when you have loaded a video in the ser format into MallincamSky and 
need to view the Next or Previous frame in this video. Note: SkyRaider Image window needs 
to be closed and a video loaded for this to work. It is easier to use the same commands 
located on the icon bar. 
 

R e t i c l e s   

 

 
MallincamSky provides three Reticles (or crosshairs) styles to aid in 

aligning your telescope to a star (or another stellar 

object).  

You can change the color of the Reticle via the 

Option>Preferences control in the Top Menu Line or the 

View>Grids>Settings command. 

Left-Click on Reticle icon to Activate and Left-Click again on Reticle icon to De-Activate. 

You can Left-Click and Drag the Reticles across the screen. Select the Center command to 

recenter the reticle on the screen.  
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Browse 
 

This Command Tab is used to determine how MallincamSky 

should display the graphic files when you are viewing the 

Folders Tab. This control will allow you to change the size of 

the image icons, determine how to sort the files, add 

shortcuts to the folders, delete files, refresh the folders, and 

even determine the properties of the image file all without 

having to perform these tasks thru the Windows 

Environment. 

 

S o r t  

This control allows you the option of 

rearranging the image files via a variety of 

choices (Name, Type, size, Width, and 

Height. All in either Ascending or 

Descending order.). Just Left-Click on the 

choice that best suits your needs and 

MallincamSky will automatically rearrange 

the files. 

 
I c o n s  

  

This control allows you to display the Graphic Files as either 

Large or Small Icons. Simply Left-Click to make your Selection.  

 

 
R e f r e s h  

 
This control allows you to refresh the contents of the currently selected folder. It is useful if 

you are using another program to move files around while also running MallincamSky. 

 
P r o p e r t i e s   

 
This control will display the current File properties for the Graphics File that you have selected 

(This is identical to Right Clicking on a File while using Windows Explorer). 
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O p e n  R e c o r d  F o l d e r   

 
This control will display the current Video Record Folder (the default Video Record Folder is 
selected thru the Options->Preference Command). 

 
O p e n  I m a g e  F o l d e r   

 
This control will display the current Image Folder (the default Image Folder is chosen by using 
the Options->Preference Command). 

 
 

Setup 
 
The SkyRaider DS10CTEC Camera does not have a ST4 port 
on the camera, so this command is deactivated. 
 

 
 
 
F r e e z e  

 
Clicking on this control will Start or Pause a loaded avi or mp4 video. It is easier to 
use the Pause Key on your keyboard or even the Start/Pause icon on the icon bar. 
 
 
S T 4  T e s t …  

The SkyRaider DS10CTEC series of cameras do not have a ST4 port, so it cannot be used to 

Auto Guide, using ST4, your telescope mount using these commands. But, since it has a the 

DS10CTEC has an ASCOM driver, PHD2 can use this camera as a guide camera using pulse 

guiding. SkyRaider cameras that do have a ST4 port can test the port using this control. 
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Capture 
 
This Top Menu Line command allows you a more 

in-depth capture routine of either a still image or a 

video stream.  

 

 

C a p t u r e  I m a g e  

 
During a video preview, you can always choose the Capture>Image Capture command to 
capture a still picture of the active video image. After the image is captured, this captured 
image (still image) will be placed as the current active window with an automated title 
(0001*).  

 
The Snap Button on the Camera SideBar can continuously shoot the image more easily. Left-
Click this Snap button on the Camera Sidebar to capture an image. 
 
If camera Format Resolution is RGB48, then the Snap image will not match the viewed 
stacked image. 
 
You can also just hit the F8 key on your keyboard to take a snapshot. 

 

 
 
A u t o  C a p t u r e  

 
This function can capture a sequence of pictures when using either Video Mode or Trigger 

Mode.  

First you must set up the Location, File Format, Prefix, 

and the Number of Exposures required in the 

Options>Preferences Tab (see OPTIONS->Preferences-

>Auto Capture Tab for more details on how to setup for 

Auto Capture).  

To begin the capturing process, just Click on this Tab or press the F7 Function key 

or click on the Auto Capture Icon.  

Note: Auto Capture name will change to Stop Capture, so Click on it if you need to abort the 

process. 

You will see a counter on the bottom left of the screen indicating the capture process i.e., 

Auto Capture 05/20 (this says taking the 5th image of the required 20). 
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Start Record… 
 
This function can record a video of what you are viewing. 

 
First you must set up the location, File Format, Prefix, and 

Duration required for the video in the Options>Preferences 

Tab (see OPTIONS->Preferences->Record Tab for more 

details on how to setup for Recording Videos). 

 

Duration only works for ser and avi file formats, not for the mp4 format.  

 

To start the capturing process, just Click on this Tab or press the F9 Function key. Note: The 

Start Record name will change to Stop Capture, so Click on it (or press the F9 Function Key) to 

stop the recording process. 

Note: it is easier to Click on the Record button on the main sidebar in the Capture and 

Resolution box. This button will change to a Stop Record icon so if you click on it again the 

recording can be stopped. 

       

A dialog box will open at the bottom left of the MallincamSky Window providing you with real 

time information about the recording process. 

 
 
Follow instructions in User Manual on using the Record Button on Left Side Panel, to record 
video in Trigger Mode as this command is identical. 

 
The only way to view saved Videos, using MallincamSky is to Right-Click on Video Tab to 
Close the Video Window, then you will be able open a video using the File>Open Video 
command. 
 
When capturing a Video, you will notice that in the Capture & Resolution Tab in the left 
window sidebar that the Blue Arrow Record icon has now changed to a Red Stop icon. Left-
Clicking on this Button will stop the video capture process. 
 
Use Windows Explorer to View your saved videos by using any Video viewing software of your 
choice. 
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B a t c h  R e c o r d  

This command will allow you to save a sequence of videos onto your computer.  
You will need to have already chosen the location and format (only works with ser and avi 

formats) when saving the videos using the Option->Preferences->Record Tab, and the 

number and duration of each of the videos in the Option->Preferences->Batch Record Tab. 

See Options->Preferences… Tab for more detailed information on setting up the parameters 

for Batch Record, but below is a quick walk-through. 

In the Record Tab in Options->Preferences…, choose the location and file type and duration 

for recorded Video Files. 

 

In the Batch Record Tab in Options->Preferences…, choose the number of Videos to be 

recorded, plus the Time Interval between each Video (as you have set the duration of each 

video in the Record Tab). 

 

Once these have been set, all you need to do is Click on the Batch Record Tab (F10) in the 

Capture Tab. 

MallincamSky will automatically start the recording process and the Record Button on the 

Left-Sidebar turns to a Red STOP symbol (in case you need to stop the recording process).  
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By Clicking on the Batch Record Tab again, MallincamSky will then abort the whole capturing 

process. 

By Clicking on the Red STOP symbol in the Left Sidebar, MallincamSky will only abort the 

current Video sequence, but will continue with the next sequence. 

MallincamSky will also inform you of the status on how the recording is going by displaying a 

Status Information Line on the bottom of its window. 

It will provide you the real time status of the Recording process. 

 

And the real time status of the Pause between each Recording. 

 

 

Again, I want to emphasize that the Batch Record control only works when you are 

saving the video in either the ser or the avi format. It will just continuously record if 

you are using the mp4 format. 

 

Also Note: it may take your computer a couple of seconds to process and save each 

video segment between each pause. Just be patient and let the software do its thing 

between each recorded segment. 
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Image 
 

The Image Menu will allow you to adjust the 

properties of any captured still image in an active 

Image Tab in MallincamSky video/image window. 

This is quite a powerful set of commands and can 

tweak your snapshots for amazing results. Not 

quite at the level of dedicated image adjusting 

software but it may be more than sufficient for 

your needs. 

 

You can use the SideBar’s Undo/Redo Tab to revert 

any correction you made back to a previous state.   

 
M o d e  

 
The Mode Control will give you the 

ability Color Quantize, Gray Scale, 

and Decolorize the selected still 

image. 

 
The Color Quantize••• command is widely used to change the image 

bit. MallincamSky supports the mutual changes among 24-bit, 8-bit, or 

1-bit images. When the Colour Bits dialog is opened, the default 

checked color bit is the current image's color bit. Check the desired bit 

and click OK to end the command. The image will be converted to the 

selected color bits in the image window. 

The current bit size (BPP) will be displayed on the bottom of the Image Window.  

The next two controls require that you have Color Quantized your image. 

The Gray Scale command is used to convert a color image (true color image or index color 

image) to a gray scale image. If the original image is 24-bit, the new image will become an 8-

bit image.  Other images bit size will not change. 

The Contrast Preserving Decolorization command to convert a color image (true color image 

or index color image) to a gray scale image with a unique algorithm to preserved as much of 

the color contrast for each channel into Monochrome image. If the original image is 24-bit, 

the new image is 8-bit. Otherwise, the bit of the image will not be modified. 
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A d j u s t  

 
The Adjust menu will allow you to adjust the Brightness and 

Contrast of the image. You will be able to modify the RGB Color 

balance, as well as the High-Lights, Mid-Tones and Shadows 

values. Color Curves and Filtering algorithms are also in the 

menu control. You will have the ability to Invert the image as 

well as perform some Detail Enhancement procedures on the 

image. 

 

Adjust Brightness/Contrast  

The Image>Adjust>Brightness/Contrast••• 

command offers simple adjustments to the tonal 

range of an image. This command makes the 

same adjustment to every pixel in the image. The 

Brightness/Contrast command does not work 

with individual channels and is not recommended 

for high-end output because it can result in the loss of details about the image. 

Brightness:   Dragging the slider bar to the left decreases the level and dragging it to the right 

increases the level. The numbers on the right of the slider bar display the 

Brightness value. Values can range from -150 to +150. The Default value is 0.  

Contrast:  Dragging the slider bar to the left decreases the level and dragging it to the right 

increases the level. The numbers on the right of the slider bar display the 

Contrast value. Values can range from -150 to +150. The Default value is 0. 

Make your adjustments to the Brightness and Contrast values and Left-Click on OK to accept. 

 

Color 

Choose the Image>Adjust>Color••• command to 
modify the overall mixture of the colors in an image. 
 
There are four color modules that are supported by 

MallincamSky: 

RBG, CMYK, HSI, HLS 
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MallincamSky uses the RGB model. It assigns an intensity value to each pixel ranging from 0 
(black) to 255 (white) for each of the RGB components in a color image. 
 
For example, a bright red color might have an R value of 232, a G value of 45, and a B value of 
37. When the values of all three components are equal, the result is a shade of neutral gray. 
When the value of all components is 255, the result is pure white; when the value is 0, the 
result is pure black. 
 
RGB images use three channels to reproduce up to 224 or 16.7 million colors on-screen. In 
addition to being the default mode for new Mallincam images, the RGB mode is used by 
computer monitors to display the colors. This means that when working in color modes other 
than RGB, such as CMYK, MallincamSky still uses RGB mode for displaying on-screen images. 
 
Although RGB is a standard color mode, the exact range of colors represented can vary, 
depending on the application or display device attached to your computer. 
 

 
 

The CMYK mode is based on the light-absorbing quality of ink printed on paper. As white light 
strikes translucent inks, certain visible wavelengths are absorbed while others are reflected 
back to the eyes. 
 
In theory, pure cyan (C), magenta (M), and yellow (Y) pigments should combine to absorb all 
light and produce black. For this reason, these colors are called subtractive colors. Because all 
printing inks contain some impurities, these three inks produce a muddy brown and must be 
combined with black (K) ink to produce a true black. (K is used instead of B to avoid confusion 
with blue.) Combining these inks to reproduce color is called four-color process printing. 
 
The subtractive (CMY) and additive (RGB) colors are complementary colors. Each pair of 
subtractive colors creates an additive color, and vice versa. 
 

 
 
 

Based on the human perception of color, the HSI model describes three fundamental 
characteristics of colors: 
 
Hue is the color reflected from or transmitted through an object. It is measured as a location 
on the standard color wheel, expressed as a degree between 0° and 360°.  In common use, 
Hue is identified by the name of the color such as red, orange, or green. 
 
Intensity is the relative lightness or darkness of the color, usually measured as a percentage 
from 0% (black) to 100% (white). 
 
Saturation, sometimes called Chroma, is the strength or purity of the color. Saturation 
represents the amount of gray in proportion to the hue, measured as a percentage from 0% 
(gray) to 100% (fully saturated). On the standard color wheel, Saturation increases from the 
center to the edge.  
 

RGB 

CMYK 

HSI 
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The HLS model is remarkably similar to the HSI color model. The main difference between 
them is the calculation used to produce the brightness value. In the HLS model, a pixel's 
brightness (L) is derived from its three (R, G and B) color values. That is, a pixel's brightness (L) 
is determined by the minimum and maximum values of its three-color values. 
 
The values beside the slider bar show the color changes in various color channels. 
 

• The RGB channel values can range from -100 to +100. The Default values are 0. 

• The CMYK channel values, they can range from -100 to +100. The Default values are 

0. 

• In the HSI channel, the H value can range from -180 to 180, the S value can range 

from -275 to 275, and the I value can range from -442 to 442. The Default value are 0. 

• In the HLS channel values, the H value can range from -180 to 180, the L value can 

range from -100 to 100, and the S value can range from -100 to 100. The Default 

values are 0. 

 

HMS 

Select the Image>Adjust>HMS••• command to 
adjust the HL (Highlight), M (Midtone), and S 
(Shadow) parts of the image.  
 
Each part's value ranges from -100 to 100. This 
command is only available for 24-bit true color 
image. 
 

 

 

 
Sometimes you may desire more precise 
control, or more unusual, nonlinear effects. 
The Curves tool in MallincamSky provides 
more arbitrary remapping of the color 
channels (rather than the HMS control). It 
takes the input tones and allows you to 
selectively stretch or compress them. 

Using Curves, the input-output mapping of 
color channels can be defined by an arbitrary 
cubic spline or can be drawn freehand. This 

flexibility provides extreme generality.  

It is worth the effort to review how color curves work in graphics programs such as Photoshop 
(tons of information about curves on the internet). 

 

HLS 

Curve 

 
 

 

Highlights 

Mid Tones 

Shadows 

White Point 

Dark Point 
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Curves all you to adjust shadows, midtones, and highlights separately. 
 
The grid represents the ratio of input to output. When you see the straight line when you first 
activate curves, this indicates at every pixel brightness (from dark to light) that is input has the 
same value on output. Think of it as if a brightness level of ten is input its output also has a 
brightness level of 10. This 1 to 1 mapping produces a straight-line equation y=x. 
 

Output (vertical axis) = Input (horizontal axis) 
 
So, you can change this mapping (ratio) by moving this straight line to either decrease the 
intensity mapping (an input of 10 at a specific brightness level is reduce to an output of 5) or 
increase the intensity mapping (an input of 10 at a specific brightness level is increased to an 
output of 20). This allows you to either enhance or diminish tonal areas of your image to pull 
out good data and restrict bad data. 
 
Shadows 

Add control points and adjust the bottom left corner of the RGB Curves control line to change 
the shadows. Moving this marker to the right compresses the darks. Moving this marker 
upwards diminishes the role of the darks (starts muting them). The higher you move this 
marker the more fade you will obtain in your image. 

 

Midtones 

Adjust the middle of the line to adjust the midtones. If you drag the Midtone down, it acts as 
if the exposure is reduced. If you drag the Midtone upwards, it acts as if it increased the 
exposure. 

 

Highlights 

Adjust the top right corner of the line to change the highlights. Moving this marker to the left 
compresses the lights. Moving this marker downwards diminishes the role of the lights (starts 
muting them). This lower you move this marker the more fade you will obtain in your image. 

The RGB (White box is selected) Curves control line adjusts all the pixels in the image based 
on their brightness, so when you make an adjustment at a particular brightness level, all other 
levels are also adjusted according to the shape of the line. 

If you create an S-curve in the RGB Curves control line, it increases the appearance of contrast 
without extending or compressing the overall brightness. 
 
You can selectively adjust the color channels by Clicking the colored square at the bottom of 
the RGB Curves control to selectively adjust the individual Red, Green, and Blue color 
channels. 
 
Horizontal Axis: The horizontal axis of the Curves graph represents the original intensity 

values of the pixels (these are the Input levels). 
 
Vertical Axis: The vertical axis represents the new color values (these are the Output 

levels). Notice that in the default diagonal line, all of the pixels have identical 
Input and Output values. 
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Curve Shape: The Shape of the curve, as specified with the rectangle locking points, setups 
a map between input and output values. 

 
a)  When you open the Curve dialog you will not a curve 

but a straight line. As a default, the input values are 
the same as the output values, so there’s no change. 

 
  
 
b) By left clicking in the center of the line and dragging it 

upwards, we make a simple curve. Raising the curve 
increases the overall brightness of the Image.  

 
 
 
 
c)  By left clicking in the center of the line and dragging it 

downwards, we make a simple curve.  Lowering the 
curve decreases the overall brightness (making image 
darker) of the Image. 

 
 
 
d)  You can also adjust the endpoints of the curve. By 

dragging down the top right point limits the brightest 
part of the image while dragging up the bottom left 
point limits the darkest part of the image, thus 
reducing the image’s overall contrast.  

 
e)  If we drag the top right point to the left or the 

bottom left point to the right, we increase the 
contrast of the image (either bright side or dark side).  

 
 
 
 

f)  If you Click once in the center of the curve to create a 
control point, and now drag just the top half of the 
curve upwards and the bottom half of the curve 
downwards to make this S shape. This process will 
increase the overall contrast of the image.  

 
You can add as many control points to the curve as required. To remove a control point; just 
drag it off the graph or right click on the control point.  
 
Grid: Checking this control will display the grid overlay on the curve, un-checking 

this will remove the grid line overlay. 
 
Color Channel: You can use this control to adjust either the Red, Green, Blue, or all three 

channels -RGB (White). 
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Spline: When this is selected (default), the curve will be smooth 

between anchor points. You can toggle between this 
and Pencil by clicking on the other control. 

 
 
 
 
Pencil: When this is selected, the curve will be a free form line 

between the anchor points. You can toggle between this 
and Spline by clicking on the other control. 

 
 
 
 
 
Do not be afraid to experiment (it takes a while to get really proficient in using curves), if you 
do not like what you get, you can always click on the Reset button (before you permanently 
apply changes by clicking on Apply button) to put everything back to normal (the Undo/Redo 
Tab can even fix the image even if you used the Apply button). 
 

 
 
 

Select the Image>Adjust>Filter Color command to 
filter out a special color channel from a color 
image. Check either Red, Green, or Blue color to 
filter.  
 
For Example, if the Red color is checked, then only 
information about the Red channel will be 
discarded. The Green and Blue information will 
remain there. 
 
 

 

 
 

Select the Image>Adjust>Filter Color command to 
retain a special color channel from a color image. 
Check either Red, Green, or Blue color to filter.  
 
For Example, if the Red color is checked, then only 
information about the Red channel will be 
retained. The Green and Blue information will be 
discarded. 
 
 
 
 
 

Filter Color 

Extract Color  
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Select the Image>Adjust>Invert command to reverse the pixel values of the active image. 
 
 
 

Edge Preserving Smooth 

 

This control looks for the most homogeneous 
neighborhood area around each point in a 
picture, and then gives each point the average 
gray level of the selected neighborhood area. It 
removes noise in a flat region without blurring 
sharp edges, nor destroying the details of the 
boundary of a region. This smoothing also can 
sharpen blurred edges. 
 
Choose either the Recursive or the Normalized Convolution. By adjusting the Spatial Sigma 
(like the domain) and the Range Sigma, you can affect how many pixels the algorithm uses 

when applying the smoothing. The larger these values are the more aggressive the 
smoothing. 
 
 

 
 

 
 

This filter works by identifying sharp edge 
boundaries in the image, such as the edge 
between a subject and a background of a 
contrasting color and increasing the image 
contrast in the area immediately around 
the edge. This has the effect of creating 
subtle bright and dark highlights on either 
side of any edges in the image, called over 
shoot and undershoot, leading the edge 
to look more defined when viewed from a 
typical viewing distance.  
 
Choose either a Recursive or the Normalized Convolution. By adjusting the Spatial Sigma (like 
the domain) and the Range Sigma, you can affect how many pixels the algorithm uses when 
applying the smoothing. The larger the values are the more aggressive the enhancing. 
 
 
 
 
 

Invert 

Detail Enhance 

https://en.wikipedia.org/wiki/Overshoot_(signal)
https://en.wikipedia.org/wiki/Overshoot_(signal)
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R o t a t e  

This control allows you to rotate and or flip your image across an axis. 

Your options include: 

➢ Rotate the image 90 degrees Clockwise (CW) 

➢ Rotate the image 180 degrees Clockwise (CW) 

➢ Rotate the image 270 degrees Clockwise (CW)  

➢ Rotate the image an Arbitrary degree amount. 

To Rotate the image a specified amount (in 

degrees) in a chosen direction (clockwise or 

counterclockwise), Left-Click on the Arbitrary 

control. When this option is selected, the 

Image Rotate Window will popup, where you 

can enter in the required values. You also have 

two redrawing algorithm choices for it to use 

when rotating the image (Bilinear or Bicubic).  

 

The bilinear interpolation technique uses a weighted average of pixels in the nearest 2-by-2 
neighborhood to come up with the value of the new pixel. 

The bicubic interpolation technique uses a weighted average of pixels in the nearest 4-by-4 
neighborhood to come up with the value of the new pixel. 

 

 

This control also allows you to flip your image Horizontally or Vertically. 

Flip Horizontal reverses the image in the application area so that the top right corner of the 

original image is now the top left, and the top left corner of the original image is now the top 

right corner. 

Flip Vertical reverses the image in the application area so that the top right corner of the 

original image is now the bottom right corner, and the top left corner of the original image is 

now the bottom left corner. 

 

 

 

Flip 
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C r o p  

Choose the Image>Crop command to remove the portions of an image that you do not want 

so that the focus is on the part of the image that is left.  

First select Edit>Image Select (the mouse cursor will change into cross hairs) from the Top 

Menu Line.  

Next use the Left-Click Hold and Drag technique to draw a rectangle around the portion of the 

image you would like to keep.  

Finally select Image>Crop and your image window will now only contain the portion of the 

original image that was inside the Image Select’s Rectangle. 

When you create an Image Select Rectangle, you can Left-Click Hold and Drag the rectangle 

around your full image to move it to a different location. 

You can also resize the Image Select Rectangle by grabbing one of the little boxes around the 

rectangle and dragging the mouse to increase, decrease, or change dimensions of the 

rectangle. 

 
I m a g e  S c a l e  

 

Select the Image>Scale••• command to 

change the dimensions of the image to a 

specified size. This process changes spatial 

resolution by adding (replicating) or removing 

(decimating) pixels to achieve the specified 

dimensions.  

 
 

Width and Height:     When choosing the Image Scale command; the dialog box 

displays the dimensions of the original image in pixels. The 
Width and the Height can be set on the new image by adding 
or removing pixels. If the Constrain Proportions are checked, 
the Width and Height will stay proportionate to each other. 
If the Constrain Proportions are unchecked, the Width and 
the Height can be set independently, but this will distort the 
image. 

 

Reset:  Resets the image’s Width and Height to the original settings. 
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Constrain Proportions:  To maintain the current proportions of pixel Width and 

Height, check Constrain Proportions. This option 
automatically updates the Width as the Height is modified, 
and vice versa. Otherwise, uncheck the Constrain 
Proportions button. 

 

Scale method:   There are 2 options for the algorithm that the Scale method 

uses to resize the image. They are: Bilinear, and Bicubic. The 

default scaling method is Bilinear. 

The bilinear interpolation technique uses a weighted average of pixels in the nearest 2-by-2 
neighborhood to come up with the value of the new pixel. 

The bicubic interpolation technique uses a weighted average of pixels in the nearest 4-by-4 
neighborhood to come up with the value of the new pixel. 

Once you have selected your parameters, Left-Click on OK to make the new Image Scale final. 

 
H i s t o g r a m  

 
A Histogram illustrates how pixels in an image 
are distributed by graphing the number of pixels 
at each color intensity level. The Histogram 
shows detail in the shadows (shown in the left 
part of the histogram), mid-tones (shown in the 
middle), and highlights (shown in the right part).  
 
A Histogram can help you determine whether 
an image has enough detail to make a good 
correction. 
 
 
A histogram is a mathematical graph that shows you the current tonal range of an image. This 
way you can evaluate it and, if necessary, correct it. 
 
Tonal range refers to the range of brightness levels in the image. A histogram shows us how 
much of the image is currently pure black, how much is currently pure white, and how much 
of it falls somewhere in between. 

 
It is especially important to note that even though we are talking about brightness levels, we 
are not just talking about black and white (grayscale) images, but Histograms work equally 
well, and are just as important, with full color images. 
 
This is because, even though we do not always think of color as being anything but color; yet 
every color in your image has its own brightness level.  
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Orange, for example, are typically exceptionally light, while blues and reds are much darker. 
These differences in brightness values mean that color can have a huge impact on the tonal 
range of your image. 
 
Do a Google Search on How to Read and Understand Image Histograms in Photoshop to find 
out more information on how to use Histograms to improve your images.  
 
Choose the Image>Histogram••• command to open the Histogram Window. Depending on 
the image’s color mode, choose R, G and B, or Luminosity to view a composite Histogram of 
all the channels. 
 
If the image is RGB true color, choose Luminosity to display a Histogram representing the 

luminance or intensity values of the composite channel. 

If the image is RGB true color, choose R, G and B to display a composite Histogram of the 
individual color channels in color. 
 

 
 
Do one of the following: 
 
➢ To view information about a specific pixel value, place the mouse pointer in the 

Histogram graph. 

➢ To view information about a range of values, click down the Left-Click hold and Drag 

the mouse into the Histogram to highlight the range. 
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The Histogram Window displays the following statistical information below the Histogram: 

 

Pixels:  Represents the total number of pixels used to calculate the Histogram. 

 

Level:  Displays the intensity level of the area underneath the pointer. 

 

Count:  Shows the total number of pixels corresponding to the intensity level 

underneath the pointer. 
 

Percentile:  Displays the cumulative number of pixels at or below the level underneath 

the pointer. This value is expressed as a percentage of all of the pixels in the 
image, from 0% at the far left to 100% at the far right. 

 
The Histogram from Image>Histogram (still images) provides different information about the 

video/image window than the SideBar’s Histogram (live video capture). This Control does not 

allow you to adjust the Histogram, but rather provides detailed information about the image.  
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Process 
 

MallincamSky provides some very advanced image processing tools. You can apply these tools 

to your image to tweak the final output. It would take a novel to explain each of these 

standard graphical enhancement tools. So, I will leave it up to you to Google Search the 

enhancement type to see if it is something you could use. 

You must Color Quantize your images before complete access to the Process controls. 

(Image>Mode>Color Quantize to a maximum of 24 bits) 

You can use the SideBar’s Undo/Redo Tab to revert any correction back to a previous state. 
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Stitch      
 
There are two ways to use the Stitch control in MallincamSky. One is an automated approach, 
while the other allows you to manually stitch together snapshots. 
 

AUTOMATED 

 
Have the telescope and Mallincam DS10CTEC point to the area of the sky you are interested in 
stitching together.  
 
Once the area is visible in the Video Window, Click on the Stitch icon and a Stitch* Window 
will open which contains the real time active video inside the window frame. Using your 
telescope controls tweak the position of the object you are interested in. 
 

 
 
Now slowly move your telescope around in the location in the sky, and MallincamSky will 
automatically Stitch together that image area of the sky. 
 
Do not move the telescope too fast, as the algorithm needs time to synchronize the common 
area of the image together, so to stitch together a larger image. 
 
 
Once satisfied, Left-Click on the Stitch Icon to signify you are finished and the Stitch* will 
contain your final image. 
 
The Stitched Tab contains your final image, ready to be saved. 
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MANUAL 

 
The purpose on this control is to Stitch (glue) together images to create a panoramic view 
(image), so plan ahead with this control. Determine if you are going to create a horizontal 
panoramic image, or a vertical panoramic image. 
 
➢ Have the camera imaging a specific location (or object), Now Left-Click on the Snap 

button. This will place a snapshot in the viewing box. 

➢ Move the telescope so that you have some overlap in the image and Left-Click on the 

Snap button again. 

➢ Repeat as needed. 

➢ When you are completed taking the snaps, Left-Click on any of the Snapshots to 

make it active. 

➢ Left-Click on the Stitch Icon and the following window will open. 

 
 

➢ Move as many of the available images to the selected side as you need to be stitched 

together by using either the Add>> or Add all>> buttons. 

➢ Click on Next to move to the next step. 

 
 
➢ Examine the options in this window and make the appropriate decisions on how you 

would like MallincamSky to Stitch the snapped images together (this is where the 

pre-planning comes in handy). You will still be experimenting with your decisions. 
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Panorama Straighten:  The image stitching direction can be Horizontal, 

Vertical, or None (try this if not sure). 
 
Projection Type:  For image pieces that have been taken from the 

same location, stitched images can be arranged 
using one of following projection mappings: Plane, 
Cylindrical, Spherical, Fisheye, Stereographic, 
Mercator or Transverse Mercator. 

 
Seam Finder:  MallincamSky provides four Sean Finding 

algorithms: None, Voronoi Diagram, Graph Cut 
Color, or Graph Cut Color Grad. 

 
Exposure Compensation:  This is used to minimize the exposure differences 

between the stitched images. Compensation 
algorithms available are: None, Gain, and Blocks 
Gain. 

 
Bundle Adjust:  This is the process of simultaneously refining the 

3D coordinates that describe the geometry in 
accounting for the relative motion of the images. 
Two algorithms are available: Ray Adjust and 
Reprojection Error.  

 
Once completed, Left-Click on Next to bring up the final Stitch Window. 
 

 
 
 

 
Again, make some logical guesses with the numbers on the sliders, and Left-Click on the Finish 
button when decisions have been made. 
 
MallincamSky will work through the Snaps (and apply the choices you have made) and will 
place the final result in a new image window for your viewing pleasure. 
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You can try other Stitching decisions by having the Stitched image active in your Video 
Window and Left Clicking on the Stitch Icon again. You will notice that your original snapped 
image is available for you to play with and combine in other ways.  
 
 
You can also load in previously saved images, via the Open Icon, 
and then make one of these images the active window. Now 
again selecting the Stitch Icon, you can combine these images 
into a final image. 
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Once you have captured stitched, or imported an image, you can have MallincamSky’s image 
processing tools enhance the image. 
 

D E N O I S E   

 
This tool offers three different techniques to help remove the noise 
from the image. 
 

 
 

The Adaptive Wiener Filter can preserve more image detail than the median filter, mean 
filter, or Gauss filter. This filter is great at removing additive noise (such as Gaussian noise) and 
multiplicative noise (such as Poisson noise). 
 

     
Before        After 
  

Adaptive Wiener Filter 
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The Bilateral Filter is a is a non-linear, edge-preserving, and noise-reducing smoothing filter 
for images. It replaces the intensity of each pixel with a weighted average of intensity values 
from nearby pixels. This weight can be based on a Gaussian distribution. Crucially, the weights 
depend not only on Euclidean distance of pixels, but also on the radiometric differences (e.g., 
range differences, such as color intensity, depth distance, etc.). The Bilateral Filter is good to 
preserve image edge compared with Wiener filter or Gauss filter. 
 
Once selected, a Pop-up Window will appear to allow you to adjust two parameters: The 
Value Domain and Space Domain. 
 

 
 
 
 
Value Domain:  The radiometric differences (e.g., range differences, such as color intensity, 

depth distance the greater the value, the slower process speed. 
 
Space Domain:  Sigma value, the higher the value, the more effective the denoising effect. 
 

     
Before        After 
 
 
 
 
 
 
 
 
 
 
 

Bilateral Filter  

https://en.wikipedia.org/wiki/Non-linear
https://en.wikipedia.org/wiki/Edge-preserving_smoothing
https://en.wikipedia.org/wiki/Noise_reduction
https://en.wikipedia.org/wiki/Smoothing
https://en.wikipedia.org/wiki/Digital_image_processing
https://en.wikipedia.org/wiki/Digital_image_processing
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While the traditional local mean filter is a pixels average method around the target pixel, the 
Non-Local means filter is a weighted average method to average all of the image patches over 
the search window. The weight is determined according to the similarity between the target 
patch and neighborhood patches in the search window. Compared to other famous denoising 
algorithms, such as Gaussian, Wiener filter, total variation, and wavelet denoising, The Non-
Local Means method can get better effect. 
 
Once selected, a Pop-up Window will appear to allow you to adjust three parameters: The 
Strength, Template Window and Search Window. 
 

 
 
Strength:    This slider controls the amount of denoise that is being applied to your 

image. The larger the value the more aggressive the effect. 
 
Template Window:   This is the block size that is used to calculate the weight in the weighted 

average (start with 7, the default, and increase). 
 
Search Window:    This slider is used to calculate the weighted average value among image 

patches (the size of which was set through the Template Window). The 
larger the setting, the more the processing time.  

 

    
Before     After 
 
 
 
 
 
 
 
 
 
 

Non-Local Means Filter  
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S H A R P E N   

 
This tool provides you with the ability to sharpen your images. Two 
different processes are provided for you. 
 

 
 

The unsharp of the name derives from the fact that the technique uses a blurred, or unsharp, 
positive image to create a mask of the original image. The unsharped mask is then combined 
with the negative image, creating an image that is less blurry than the original one. 
 
Once selected, a Pop-up Window will appear to allow you to adjust three parameters: The 
Radius, Threshold and Amount. 
 

 
 
Radius:    This slider affects the size of the edges to be enhanced, so a smaller 

radius enhances smaller-scale detail. Higher Radius values can cause 
halos at the edges. As a result, fine detail needs a smaller Radius. In 
addition, Radius and Amount interact; reducing one allows more of the 
other. 

 
Threshold:    Controls the minimum brightness change that will be sharpened. This 

value is important to prevent smooth areas from becoming speckled. The 
threshold setting can be used to sharpen more-pronounced edges, while 
leaving subtler edges untouched. Low values should sharpen more 
because fewer areas are excluded. Higher threshold values exclude areas 
of lower contrast. 

 
Search Window:    This slider controls the magnitude of each overshoot (how much darker 

and how much lighter the edge borders become) as a percentage. It can 
also be thought of as how much contrast is added at the edges. It does 
not affect the width of the edge rims.  

 

      
Before         After 

UnSharp Mask 



M A L L I N C A M S K Y  D S 1 0 C T E C  U S E R  M A N U A L  

 

100 

 

 
 

The Laplacian Sharpen technique is an example of a second derivative method of 
enhancement. It is particularly good at finding the fine detail in an image. Any feature with a 
sharp discontinuity (like noise, unfortunately) will be enhanced by a Laplacian operator. Thus, 
one application of a Laplacian operator is to restore fine detail to an image which has been 
smoothed to remove noise. 
 
 

      
Before         After 
 
 

C O L O R  T O N I N G   

 
Color toning is one of those final steps that can really make 
your photos both pop and add a very personal stylistic touch. 
MallincamSky provides four approaches to color toning for you 
to experiment with. 
 

 
 

Gamma measures the brightness of midtone values produced by 
the image. A higher gamma value yields an overall darker image. 
Dragging the slider bar to the left decreases the level, while 
moving it to the right increases the level. Values can range from 
0 to 3.0 
 

      
Before          After 
 
 

Laplacian Sharpen 

Gamma 
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Adaptive histogram equalization (AHE) is a computer image processing technique used to 
improve contrast in images. It differs from ordinary histogram equalization (HE) in the respect 
that the adaptive method computes several histograms, each corresponding to a distinct 
section of the image, and uses them to redistribute the lightness values of the image. It is 
therefore suitable for improving the local contrast. However, AHE has a tendency to 
overamplify noise in relatively homogeneous regions of an image. 
 

 
 
 
Strength:    This Strength slider will affect the enhancement effect. The larger the 

value, the more obvious the effect. 
 
 

      
Before          After 
 
 

 
 

The Local Color Correction algorithm is computed in two steps: 
 
The first part of the algorithm consists of a derivation of an input mask. The mask image is 
computed from the input image as the average of R, G and B values, which is I=(R+G+B)/3. 
The use of intensity information avoids distortions of the chroma.  
 
The second part of the algorithm is the combination of the mask and the input image. 
 
The combination operation consists of a power function, where the exponent is computed 
using the mask value previously found. If the mask value is greater than 128, it will result in 
an exponent less than 1, while if the mask value is lower than 128, it will result in an exponent 
greater than1. Moreover, if the mask value is precisely 128, the exponent will be 1, and it will 
have no effect on the input image. The operation is equivalent to a pixel-wise gamma 
correction. 

 
 
 

Histogram Equalization 

Local Color Correction 
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Once selected, a Pop-up Window will appear to allow you to adjust one parameter: The 
Strength. 
 

 
 
 
Strength:    This Strength slider will affect the enhancement effect. The larger the 

value, the more obvious the effect. It ranges from 1 to 100. 
 
 

      
Before          After 
 
 

 
 

There are limited dynamic range problems when real world scenes are captured from a digital 
camera and displayed on computer monitors. Tone mapping algorithms are applied to image 
processing to reduce the dynamic range of an image to be displayed on low dynamic range 
devices. Multi-Scale Retinex is one of the most popular methods for dynamic range 
compression, color constancy and color rendition. Here, we improve its performance by 
adopting the adaptive weight functions, named Adaptive Multi-Scale Retinex (AMSR).  
 

      
Before          After 
 
 

AMSR 
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D E I N T E R L A C E   

 
Deinterlacing is the process of converting interlaced image or video, such as interlace sensor 

into a non-interlaced form. So, if you imported an image or video that was interlaced, this 

command will de-interlace it. 

 
 

      
Before          After 
 
 

F I L T E R S   

 
This command works on previously Color Quantized images. 

 
MallincamSky provides an extensive set of convolution and non-convolution (morphological) 
filters. You can also create custom filter kernels and apply them with the Filter commands if 
you desire. 
 
Choosing the Filter command will open the Filter dialog Window where each group of filters 

has its own property page or tab, where the Filter type and size can be selected. The filtered 

results are almost always written to the active image in real time, so using the Undo/Redo 

Tab can be used to remove any applied Filter operations. 

 
 
 

 

 

Image Enhance 
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Each of the Image Enhance selection also have some Options: 
 
3 x 3: Checking the 3 x 3 kernel will produce a more subtle filtering effect. 
5 x 5: Checking the 5 x 5 kernel will produce a moderate filtering effect. 
7 x 7: Checking the 7 x 7 kernel will produces a more extreme filtering effect. 
 
Passes:    Applies the filter this many times on the image. When a filter is applied multiple 

times, its effect is amplified by each pass. An image that has been softened by one 
pass of the Low Pass filter will be softened further by a second pass. 

 
Strength: Enter a value from 1-10 that reflects how much of the filtering has an effect on the 

image. 
 

  A value of 10 specifies the full strength (100%) of the filtered result applied to each 
pixel. Values less than 10 cut the full weight of the filter. 

 

  A value of 1 indicates that only 10% of the difference between the filtered pixel 

value and the original pixel value should be applied, a value of 2 indicates that 20% 

of the difference should be applied, and so forth. 

 

Low Pass:    This filter is used to soften an image by eliminating high-frequency information 
(this has the effect of blurring sharp edges). The Low Pass filter replaces the 
center pixel with the mean value in its neighborhood. The Low Pass filter can also 
be used to remove noise. 

 

    
Before     After 
 
High Pass:    This filter is used to enhance high-frequency information. The High Pass filter 

replaces the center pixel with a convolved value that significantly increases its 
contrast from its neighbors. The High Pass filter leaves only elements of high 
contrast. 

 

      
Before          After 
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Gauss:    This filter is used to soften an image by eliminating the high-frequency 
information by using a Gauss function. This has the effect of blurring sharp edges. 
The operation of the Gauss filter is similar to the Low Pass filter, but it degrades 
the image less than the Low Pass filter. 

 

      
Before          After 
 
High Gauss:    This filter is used to enhance fine details. This operation is similar to the unsharp 

masking technique (see the Sharpen filter), but it introduces less noise into the 
image. It uses a Gaussian curve type of kernel. Available in 7x7 and 9x9 kernel 
sizes. 

 

      
Before          After 
 
Equalization:    This filter is used to enhance the contrast based on the histogram of the local 

neighborhood based on the following options: 
 
Window: Image pixels statistics (min, max, histogram, mean, standard deviation, etc.) 

will be calculated on a small Window of the image. These measurements are 
then used to derive the local contrast for that area of the image. In short, an 
area of Window x Window around each pixel is all that is considered when 
modifying the intensities in the image. Larger Window produces smoother 
results, while small Window track small details more closely. 

 
Best Fit: Choose the Best Fit button to optimize the values for the particular image. The 

results are achieved by stretching the local histogram to maximize the contrast 
between the brightest and darkest pixels in the local window region. 

 
Linear: This option distributes the histogram linearly across the intensity scale. This 

function produces a high contrast image with the highest possible dynamic 
range. 

 
Logarithmic:  This option concentrates the histogram at the low endo f the scale. This function 

produces a high contrast image with little dynamic image. It will tend to darken 
the image overall. It is useful for increasing the contrast in a very light image. 
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Exponential: This option concentrates the histogram at the high end of the scale. This 
function produces a high contrast image with little dynamic image. It will tend to 
lighten the image overall. It is useful for increasing the contrast in a very dark 
image. 

 

      
Before          After 
 
Sharpness:   This filter is used to enhance fine details or refocus an image that is blurred. The 

sharpen filter sharpens the image using the un-sharp masking technique. 
 

      
Before          After 
 
 
Flatten:   This filter is used to enhance fine details by flattening the image. 
 

      
Before          After 
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Median:   This filter is used to remove impulse noise from an image. The Median filter 
replaces the center pixel with the Median value in its neighborhood. It will also 
blur the image. 

 

      
Before          After 
 
Rank:   This filter is used to remove impulse noise from an image. The pixels in the kernel 

are ranked by order of intensity, and the pixel in that range at the rank 
percentage is chosen for comparison. For example, in a 5x5 kernel, there are 25 
pixels. A rank percentage of 95% would choose the second-brightest pixel for 
comparison. If the difference between the selected pixel and the center pixel is 
greater than the threshold value, the Rank filter replaces the value of the center 
pixel with the value of the selected pixel. 

 

      
Before          After 
 

 
 

These filters are used to enhance edges around objects in images. Play with them. 

Sobel : This filter is used to enhance just the principal edges in an image. The Sobel 
applies a mathematical formula to a 3x3 neighborhood to locate and highlight its 
edges. 

 
Roberts:  This filter is used to enhance fine edges in an image. The Roberts filter is not a 

convolution filter. It applies a mathematical formula upon a 4 x 4 neighborhood to 
produce its effect. The upper left pixel in the neighborhood is the one that is 
replaced. 

 
Sculpt:  This filter is used to apply a sculpted effect on the image. 
 
Horizontal:  This filter is used to detect and emphasize horizontal edges. 
 

Vertical:  This filter is used to detect and emphasize vertical edges. 

Edge Enhance 
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The idea of the morphological filter is a shrink and grow process. The word “shrink” means 
using median filter to round off the large structures and to remove the small structures and in 
grow process, remaining structures are enlarged back by the same amount. 
 
Erode: This filter is used to modify the size of objects in the image. The Erode filter 

erodes the edges of bright objects and enlarges the edges of dark ones. 
 
Dilate:  This filter is used to modify the size of objects in the image. The Dilation filter 

dilates bright objects and erodes dark ones.  
 
Open:  This filter is used to modify the shape of objects in the image. Assuming the 

image contains bright objects on a dark field, the Open filter will smooth object 
contours, separate narrowly connected objects, and remove small dark holes.  

 
Close:  This filter is used to modify the shape of the objects in the image. Assuming the 

image contains bright objects on a dark field; the Close filter will fill gaps and 
enlarge protrusions to connect objects that are close together.  

 
Tophat:  This filter is used to detect and emphasize points, or grains, which are brighter 

than the background. There are 3 kernel sizes for this processing. Click the radio 
button to change the kernel size to the value that most closely matches the size of 
the grains to detect.  

 
Well:  This filter is used to detect and emphasize points, or grains, which are darker than 

the background. There are 3 kernel sizes for this processing. Click the radio button 
to change the kernel size to the value that most closely matches the size of the 
grains to detect. 

 
Gradient:  This filter is used to enhance edges in an image. 
 
Watershed: This filter is used to separate objects that are touching. The Watershed filter 

erodes objects until they disappear, then dilates them again, but will not allow 
them to touch. The Watershed filter will not operate upon True Color images. If 
one wants to separate objects in a True Color image, he must first convert it to 
Gray Scale (see Process Frame: Image>Gray Scale). 

 
Thinning:  This filter is used to reduce an image to its skeleton. When choosing this filter, 

one must set the threshold that determines whether a pixel is part of the subject 
or part of the background (see Options below). The Thinning filter will not operate 
upon True Color images. If one wants to thin a True Color image, he must first 
convert it to Gray Scale.  

 
Distance:  This filter is used to used to show the distances of pixels within blobs to the outer 

boundaries of those blobs. After applying the distance filter, the background will 
be black (i.e., pixels with value 0). Only the area within the blobs will have non-
zero values (will be white). The values of each pixel within the blob will be a count 
of the shortest distance from that pixel to the edge of the blob. Thus, all pixels 
along the blob's border will have a value of 1 (since they are one pixel away from 
the edge of the blob); pixels that are a distance of 2 from the border will have the 
value 2, and so on. This creates a distance map of the image. The Distance filter 
will not operate upon True Color images. If one wants to use the Distance filter 
with a True Color image, he must first convert it to Gray Scale. 

 
Options 
 
If Erode, Dilate, Open, or Close filters is checked, the options will relate to the kernel size 
and shape.  
 
 
 

Morphological 
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The following options will be presented: 
 
2 x 2 Square:  use the 2x2 square kernel configurations. 
3 x 1 Row:   use the 3x1 row kernel configuration.  
1 x 3 Column:  use the 1x3 column kernel configuration. 
3 x 3 Cross:   use the 3x3 cross kernel configuration. 
5 x 5 Circle:   use the 5x5 circular kernel configurations. 
7 x 7 Circle:   use the 7x7 circular kernel configurations. This is a two-pass filter, 

accomplished using a 5 x 5 circle followed by a 3x3 cross. 
11 x 11 Circle:  use the 11 x 11 circular kernel configurations. This is a three-pass filter, 

accomplished using a 5 x 5 circle followed by another 5 x 5 circle, followed 
by a 3 x 3 cross. 

 

Note:  The circular kernels are especially effective on round objects (stars) because their 
circular configuration preserves the circular shape of the objects better than square 
configurations. 

  

 
 
 

The idea of the Kernal Tab is to allow you to create and/or edit a filter and apply it. 
 

 
 

Note: Do not delete or rename the HiPass, LowPass, Laplacian, or Unsharp kernel files as 
they are used by the Filters program. 
 
Filter type: Select a Filter type, either Convolution or Morphological. 
 
Edit•••: Invoke the Edit Kernel dialog to modify the selected filter kernel. 
 
Name•••: This combo box contains the name of the selected kernel file. If you want to 

save the modified kernel file to the same file, leave it as it is. If you want to 
save the file to a new location, enter the new filename here. 

 
Kernel Size: Use the controls or enter the number to change the size of the kernel. Either 

direction may consider one to nine pixels. As you modify the Kernel Size, the 
shape of the kernel representation changes accordingly. In the center of the 
dialog, there are white boxes containing coefficients that will be multiplied with 
each pixel that will be considered by the filter kernel. You can change any 
coefficient by clicking on it and adjust it as desired. 

 
Fill:  Use the control to fill every element of the kernel with a particular value. The 

Fill kernel dialog appears. You may enter a value between 0 and 10. Using the 
Fill button is useful for setting all coefficients to the same value. You may then 
change the coefficients that require a different value. 

 

Kernal 
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Offset: The pixel whose value is being modified is usually the center-most pixel. One 
may, however, designate any pixel. MallincamSky indicates the pixel to be 
changed by putting a box around it. Choose the X and Y Offset spin buttons to 
apply. 

 
New•••: Select this to create a new filter kernel. The Edit Kernel dialog will appear. The 

functions of the dialog are the same way as the dialog for Edit••• described 
above), with the exception that the file name for the new kernel file must be 
provided. 

 
Delete: Click to delete the selected filter kernel file. 
 
Options: The choices in this group box will vary depending upon the kind of selected 

filter. 

 
I M A G E  S T A C K I N G  

Image Stacking control will allow you to select a saved video file, then it will do an elementary 

stacking process on the file. 

In the Image Stacking process, MallincamSky takes the first frame as the reference image, this 

means the first frame is very important and should be assure the first frame to be the right 

image scene and the subsequent frames have a greater overlap region with the first frame. 

The stacked image signal to noise ratio is greatly improved. The stacked image may have had 
some black edges, this is because the images in the video have moved and in the stacking 
process, MallincamSky will add black to the image area that has no corresponding pixel in the 
reference image.  
 
This Image Stacking process will not align the video images, so this control may be better 
suited for Deep Sky objects than for planets.  
 
Left-Click on the Image Stacking control and MallincamSky will open a Dialog Window.  
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Using the Open Dialog Window move to the directory and Left-Click on the File you would like 

to apply the Stacking process to, then Left-Click on Open. 

MallincamSky supports the following video formats for the Image Stacking process: wmv，

asf，avi，mp4，m4v，3gp，3g2，3gp2，3gpp，mov，mkv，flv，rm，and rmvb. 

MallincamSky will Open an Image Stacking Progress Bar to inform you of the process. 

 

Once completed, the stacked image will appear in the Video/Image window. You can now 

apply other processing techniques to this image which as a bonus will now have a larger signal 

to noise ratio. 
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R A N G E  

You can modify the color effectiveness range with the Range control to color sharpen your 
image. This control allows you to set the intensity levels of the image to increase the contrast 

and enhance the display in low-light situations. Choose the Range command to open the 
Range dialog box. 
 
The Two vertical markers show the upper and lower limits of the intensity levels. These 

markers can be moved with mouse through the drag and drop method. For a color image, the 

histogram will reflect the red, green, and blue values with corresponding colors lines. 

 

The two Edit controls indicate the values of the intensity levels. Choose the spin buttons to 
increase or decrease these values. All values between 0 and the lower limit will be black and 
all values between the upper limit and the upper end of the scale will be white. These two edit 
control values corresponding to the two vertical markers show the upper and lower limits of 
the intensity levels. Defaults are 0 and 255, respectively. 
 
Reset: The Reset button allows Reset the black and white levels to the high and low ends 

of the dynamic Range. 
 
Best Fit: The Best Fit button automatically sets the intensity levels to the Best Fit. Best Fit 

instructs MallincamSky to optimize the brightness and contrast values for the 
image. 

 
Invert: The Invert button reverses the color of the image. 
 
Update: Update will refresh the display Range with the most current image information. 
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B I N A R Y  

You can modify the value of the pixel/no pixel count with the Binary control. 

Binary is a kind of gray level process. If the gray of the pixel is greater than the given 

threshold, the pixel's color will be changed into white. Otherwise, the pixel's color will be 

changed into black. Although the process may lose some information, it is an important step 

of other processes. 

 

The curve on the Binary dialog shows the gray distribution of the image. 
 
The Line in the dialog indicates the threshold value. Drag the line to change the threshold or 
change the value in the Line position edit box (in the top left corner of the dialog) to move the 
Line. 
 
The Line position edit box shows the current position value of the Line; Modifying the value 
will move the Line at the same time. 
 
Click the "Best Fit" button to apply the auto threshold process to the image. It uses an 

automatic threshold to make the image Binary. 

 

P S E U D O  C O L O R  

 

Note: The Image must be in Gray Scale for the Pseudo Color command to be active.  
 

You use the Pseudo Color control to "colorize" the active monochromatic image. This is used 

to highlight certain features in a gray scale image such as display all densities above a certain 

point in red, or if the imaging device recorded thermal information, all temperatures below a 

certain point can be revealed in blue color. 

When you Pseudo Color a monochromatic image, a special palette needs to be built with 
which the monochromatic image is displayed. Pseudo Coloring an image does not modify the 
pixels' values in image bitmap (it does not convert image to true color or palette). It simply 
associates a Pseudo Color palette with the image that interprets the gray-level values in the 
image as color.  
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Pseudo Colored images are very similar in structure to palette class images, but they differ in a 
couple of important ways. First, the pixels' values in a Pseudo Colored image actually 
represent continuous-tone intensity information, whereas a palette image's pixels carry no 
intensity significance. Secondly, a palette image includes a palette table that is part of the 
image file. 
 
When you activate the Pseudo Color control, a Pop-up Window will appear. 
 

 
 

The colors used to map the gray values can be selected. The buttons at each end of the color 
strips will bring up the color dialog separately, which allows select the start and end colors of 
the range. This allows you to even create some artistic looking images. 
 

 

      
Before          After 
 
 

S U R F A C E  P L O T  

The Surface Plot tool creates a 3-D representation of the intensity of an image. When choosing 
the Surface Plot control, keep in mind that X=image width and Y=image height, and Z=pixel 
value. In the viewpoint window, the elevation and rotation of the image can be adjusted by 
dragging the mouse on the image. 
 

           
 
By expanding the Surface Plot, you can activate a pseudo light source to see how it affects 

your 3D contour map. This is still a work in process control. 
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Options 

 

The Options>Preferences… Menu provides 9 Tabs, they are: Record, Batch Record, Auto 

Capture, File, Target, Grids, Video, Metadata and Misc. 

 

R e c o r d  

 
The Options/Preference/R e c o r d  tab will allow you to set the default location, File Format, 

File Prefix, File Type, duration, or Frame Limit for the Video recording of the current SkyRaider 

camera. 

 

 

 
The file Directory can be selected by Left- Clicking on the          
symbol in the Base: selector. 
 
You can also have MallincamSky create a Sub-directory to 
the Primary Directory, by selecting one of the pulldown 
choices in the Sub: heading.  
 
 
 
 
 
 

Directory:  
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The File Name allows you to select, from a pull-down list, an 
automatically generated name.  

 
You can add a Prefix to the name, as well as choose the File Type (avi, MP4, or 
ser format) the video will be recorded in.  

 
The Sample: box will show a location preview of where and the chosen naming convention of 
the video file. 

 
 

 
 
 

The Limit controls only work when you are saving in the ser or the avi format. If you select the 
mp4 format, the limit commands will not be acknowledged, and you must use the Stop 
command yourself. 
 
You can either choose to capture a specific number of seconds (from 0 seconds to 36,000 
seconds) or a specific number of frames (from 1 frame to 1,000,000 frames).  
 
Just Check the box under limit and enter the required amount. If none is checked, 
MallincamSky will record until you Stop the recording by Clicking on the Red Stop Recording 
button on the Left Side Bar in the Screen (only available when recording is activated).  
 

 
 

B a t c h  R e c o r d  

 

The Options->Preferences…->B a t c h  R e c o r d  tab will allow you to set the number of Video 

recordings in the batch, plus the time interval between each separate recording. 

 

Clicking on OK accepts the settings. 

File: 

Limit: 
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A u t o  C a p t u r e  

The Options->Preferences…->Auto Capture tab will allow you to set the location, file format, 

type, interval, and number of required still images for the Auto Capture (F7) function of 

MallincamSky.  

 

 
 

The file Directory can be selected by Left- Clicking on the          symbol in the Base: selector. 
 
You can also have MallincamSky create a Sub-directory to 
the Primary Directory, by selecting one of the pulldown 
choices in the Sub: heading.  

 

 
 

The File Name allows you to select, from a pull-down list, 
an automatically generated name.  
 
 
You can add a Prefix to the name, as well as choose the File Type (bmp, jpg, 
png, tif or fit format) the image will be captured in.  

 
 
 
The Sample: box will show a location preview of where and the chosen naming convention of 
the image file. 

 
 
 
 

Directory:  

File: 
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You can either choose to Capture every frame or select a Time interval between each 
capture. 
 

 
 

If Capture every frame is chosen, then MallincamSky will capture the number of images 
indicated by the Total Images count (do not leave unchecked). 

 
 
 

This Time slot (in Seconds from 2 s to 3600 s) is the time that MallincamSky waits before 
capturing another image (5s would indicate waiting another 5 seconds before capturing 
another image). 

 

 

 
Selecting the Total Images checkbox will enable its number selection box. You can then enter 

the Total Images (from 1 to 9999) to be captured. MallincamSky will stop the Time-lapse 

capture process automatically when the Total Images are reached. 

If Total Images is unchecked, MallincamSky will capture the images continuously until you 

Click the Capture>Stop Auto capture command to stop the Time-Lapse capture. 

Clicking on the OK Button accepts the capturing settings. 

 
To active the Capturing process use Capture->Auto Capture (F7) or Click on the Auto 
Capture Icon located on the top of the screen.  
 
 
After the Time-lapse capture is started, the Capture>Start Auto Capture••• menu will be 
changed to the Capture>Stop Auto capture menu. Choosing this command, or again Clicking 
on the Auto Capture Icon will stop the Time-lapse capture. 
 
 

F i l e  

 

One can select various File Extensions via a 

checkmark for the specified file Format, to 

determine whether it will be displayed in the 

Browse window or not (The checked Format can 

be displayed in the Browse window). 

 

 

Capture Mode: 

Capture every frame: 

Time Slot: 

Total Images: 
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T a r g e t  

The Target Tab allows you to label the target that you are currently shooting. The 10 solar 

system objects are set as the defaults in the pull-down list, but you may change the names of 

the objects, rearrange the order of the objects, add new objects, export, or import list from 

others from this Tab. 

The target list appears in the drop-down list located with the other Top Line icons. 

 

 

 

G r i d s  

The Grids Tab allows you to determine if you 

would like a Grid displayed on the Video 

Window, and if so, how should it be drawn. 

The Grids Control can also be used to define 

the color of the Reticle that can also be 

drawn over the image. 

Grid Style:  The Grid Style can be No Grid, Auto Grid or Manual Grid. Default is No 

Grid. 

 

Grid Line Style:  The Line Style for the grid can be Solid, Dash, Dot or DashDot. The 

Default is Solid. 

 

Grid Line Color:  The color of the Grid Line. The Default color is Red (255,0, 0). 

Reticle Color: The color of the Reticle. The Default color is Red (255,0, 0) 
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V i d e o  

You can overlay the Date and Time on the 

V I D E O  Window (With a location and color of 

your choice). You can also have MallincamSky 

display the Clarity Factor (can assist in focusing) 

on the image. These overlays are updated in 

Real-time. 

For Example: 

The settings on the Right will overlay the video 

stream with the following in the top left corner of 

the Video Window. 

 

 

 

M e t a d a t a   

This control allows you to determine what 

data is embedded inside the FITS and EXIF 

files when they are saved. File viewers 

that read FITS or EXIF (Tiff) images can 

then display details about how that image 

was taken, equipment and telescope used.  

 

M i s c   

The Misc Tab is mainly used for the control of the MallincamSky’s User Interface. It mainly 

includes: 

1. MallincamSky’s special file format 

warning information. 

2. Sidebars. 

3. User Interface Style 

4. Language. 

5. Graphics accelerator 

6. Privacy. 

 
Just Left-Click in a checkbox to choose your required Option. 
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Window 
 
The menu control will close all open windows (Tabs) and it 
can reset the layers back to their default settings.  

 
 
 
C l o s e  A l l  

 
Selecting the Closes All command will close all the picture windows opened or captured inside 
MallincamSky’s frame. If you have made any modifications to the pictures or if you have 
captured some pictures from the camera, choosing the Close All heading will pop up a window 
that will let you finish the saving operations quickly. 

 

 
 
The Close All will also close down the live Video Stream window. You can now use the 
File>Open Video to view a saved video. Left-Click on camera will again activate the Video 
Stream window. 

 
 
R e s e t  W i n d o w  L a y o u t  

 
Choosing this command will reset the MallincamSky window layout to the original default.  
 
The reset will be effective after restart. 
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W i n d o w s  

 
Choosing the Windows>Windows••• control will open a dialog box that lets you manage the 
currently opened windows. 
 
The dialog allows you to manage large lists of open windows by assigning them into groups. 
Let us say you have eight windows open but want to close four of them scattered through the 
list. 
 

1. Choose the Windows>Windows••• control. 

2. Select the windows you want to close. Hold Ctrl or Shift key to select more than one 

at a time. Here, 4 windows are selected. 

 
 

3. Click Close Window(s) button, those four selected windows will be closed, leaving 

the other files or captures available for editing. 

You can use this command to switch and activate a selected window on a list by hitting 
Activate. 
 

 

Help  
 
This control will pop-up a window that allows you to see detailed information About the 
current version of MallincamSky installed, and on the Diagnose Tab, detailed information 
about your computer system. 

 

 

6 
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MallincamSky Toolbar 
 

 
 

Open   
 
The Open Image command is used to open an existing image file. This command can also be 
used to preview an image in a preview size, or to view its statistics and information without 
opening the image itself. You can use this command to quickly locate an image.  
 
MallincamSky supports a variety of image formats. These are identified in the Files of type list 
box. 
 
MallincamSky can open more than one image simultaneously by: 
 
➢ Ctrl + Left Mouse Click on each required file then Left-Click on Open 

➢ Shift + Left Mouse Click method to highlight the files to be opened, then Left-Click on 

Open 

When an image is opened, MallincamSky places it into a new image window. It then becomes 
the active image. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
MallincamSky maintains, at the File>Recent Files submenu, a list of the last opened files. 
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Save   

 
 
The Save Icon allows you to save an image (or a 
snapshot of the current video stream) onto your 
computer. The command immediately stores 
the current active video window image (or an 
active non-named snapshot) to the last 
activated folder location (the filename is listed 
on the window's title bar) while leaving the 
image still active in its window.  The dialog box 
will provide you an opportunity to change the 
desired saving location, give a name to the 
image file, and choose a format. 
 
 
If the image is untitled or titled with a digit, MallincamSky will issue the File>Save As dialog 
automatically. The default “Save as type” will be “Window Bitmap (*.bmp,*.dib,*.rle)”.  
 
You can determine which image tabs can be saved, by noting if there is an asterisk, “*”, 
behind the name. If present, then that image can be saved. 
 

 
 

The Save Icon can be used to save the most recent changes to disk. It is often performed as a 
precautionary measure during lengthy or involved processes to reduce the amount of 
reprocessing that might be required in the event of a system failure or operational error. 
 
When an image is closed and told not to save its changes then MallincamSky discards all 
changes made since the last Save operation. 
 
 
The Save Icon always saves the contents of the entire window, even if there is an AOI (Area of 

Interest) defined on it. 

 
The Save Icon is an alternative way to save a SnapShot to the default File folder of an active 

Video Stream (it will ask you for a File Name). 

 
The format options that your snapshot can be saved in depends upon the capture format the 
DS10CTEC is in. If the camera is in RAW mode, then the snapshot will be saved in only FITS 
format. If the DS10CTEC capture format is in any of the RGB modes, then you will have a 
selection of possible snapshot file formats. 
 
The FITS format will look Black and White and checkered, but this is because it is in a RGGB 
bayered format. This format is used as it provides you will the truest control of each layer in 
the image. You will need astro-imaging software (Astroart) to extract (debayer) the colors to 
perform professional quality image processing. 
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Browse        
 
The Browse Icon from the MallincamSky Tool Bar is used to browse images under the 
specified directory in the Folders Sidebar.  
 
This command is identical to hitting the Folder’s Tab at the bottom of the screen. 
 

 
 

To return to the Camera Bar, just Click on the Camera Tab located at the bottom of the 
screen. 
 

 
 
You can also change the order of these tabs by Left-Click-Hold and Drag on the Tab name. 
 
The Browse Window resembles Windows Explorer, Left-Clicking on the + will expand a folder 
so that you can examine its contents.  
 
You can Right-Click on a Folder (or file) and the actual Windows controls will pop as in 
Windows Explorer.  
 

As you get deeper into the Browse Window, you can Back-Out or Move Deeper 
into the File Folders via the Green Left or Right Arrow in the Browse Window. 

 
 

The Blue Right Arrow will take you to your computer’s Root Directory.  
 

 
Left-Double Clicking on a Folder will open a Window Tab in the Video Window (this Window 
will be labeled Browse).  
 
This Tab will display all the graphic files inside that Folder. If you Left-Double Click on a 
Graphics File inside the Video Window, it would open that Graphics File in a new Tab in the 
Video Window. 
 

 
 
You can Close the Tab in the Video Window by 

Right-Clicking on the Tab’s Title (Browse), then 

choosing Close.  
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Thumbnail        
 
This icon creates an image window that contains snapshots of all your current image tabs. You 
need only click on that image to have it open that image’s window.  

 

 
 
 

Target        
 
This icon allows you to give a name to the current Target that you are 
imaging. You can add or change names in the Options>Preferences>Target 
Tab. The Target name can automatically be used as a suffix for a file folder 
name when saving images or video captures.  

 
 
 

Image Type  

 
This icon allows you to designate the type of image you are saving. This is 

only for your reference. Just select an image type from the drop-down list.  
 
 
If you save an image in FITS format, then the Image Type will be included in the 
Metadata for that image. 
 
 

Auto Capture    
 

This icon activates the Auto Capture routine in MallincamSky.  
 
You must have previously chosen the File location, File Type/Number of required images, and 
the Time Interval between each captured image from the Options->Preferences> Auto 
Capture Tab (see Options for more information). 
 
The Auto Capture Icon will remain highlighted until the capture process is completed. You can 
Abort the capture process at any time by again Clicking on the Auto Capture icon. 

 
MallincamSky will indicate the status of the Auto Capture process 
on the lower left of the MallincamSky window.  
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Batch Record 
 
 
This icon activates the Batch Record routine in MallincamSky.  
 
You must have previously chosen the File location, File Type/Number of required Videos, and 
the Time Interval between each captured video from the Options->Preferences…-> Batch 
Record Tab (see Options for more information). 
 
The Batch Record Icon will remain highlighted until the capture process is completed. You can 
Abort the capture process at any time by again Clicking on the Batch Record icon. 
 
MallincamSky will indicate the status of the Batch Record process on the lower left of the 
MallincamSky window. 

 

 
 
 

Pause Video Capture  
 
This icon Pauses the Batch Record routine in MallincamSky. It will highlight when you are able 
to pause a video capture. 

 
 

Open Video Folder  
 
This icon will allow you to open and view either the default Video Record folder or the default 
Image folder. This way you can examine the results of the recording. The folders are assigned 
via the Options->Preference Tab. 

 
 
 

Zoom        
 
The Zoom Icon allows you to Zoom-In or Zoom-Out while viewing a 
Video/image window. The Drop-Down list will offer you the zoom options. 
Just highlight the zoom option with your mouse and then release the mouse 
button. 
 
 
You can change the Zoom by rolling your Mouse Wheel while holding down 
the CTRL key on your keyboard., if your mouse has a wheel. 
 
Also look at the Hot Key’s section for keyboard shortcuts. 
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Track        
 
If the video/image's actual size is larger than the video/image Window, then this control will 
allow you to position the actual video/image within in the video/image Window. This control 
is activated automatically when necessary. 
 
Its function is like scroll bars. It is an alternative to using the arrows on the scroll bars for 
positioning the video/image within the window. Position the mouse (make sure to choose a 
location outside a Region of Interest rectangle. You may need to close the ROI rectangle if 
necessary) on the actual video/image. 
 
Left-Click and Hold (the Open Hand will change to a Closed Hand). Now drag the image 
around inside the video/image Window 
 
If the video/image size is smaller than the video/image Window size, then the track 
operation will be disabled. 

 

Histogram 
 
This icon will display a real-time Histogram (for information purposes) beneath the Video 
window being displayed. Clicking on the icon again will remove the Histogram. 
 

 
 
 
The eight icons on the left of the Histogram allow you to pause or switch between 
the linear or logarithmic scale, zoom in or zoom out, display statistical data or 
output data values.  
 
 

The Histogram window is movable and resizable via the Left-Click 
and Hold technique with your mouse. You can also have the 
Histogram window Minimize, resize, and Auto Hide by selecting this 
feature from the pull-down arrow on the upper right of the 
window. 

 
Moving your cursor over the Histogram Tab now located underneath the Left-Side Bar on 
MallincamSky will re-display the Histogram if Auto Hide is selected. 
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Reticle      

 
MallincamSky provides four Reticles (or crosshairs) to aid in 

aligning your telescope to a star (or another stellar object).  

Left-Click on a Reticle Icon to activate it and Left-Click on it 

again to De-Activate. 

You can Left-Click and Drag the location of the Reticle 

around the screen to center it on an object of interest. 

 

The           Reticle-Icon will automatically re-center the selected Reticle on your image. 
 

 
 
You can change the color of the Reticle via 

the Option>Preferences control in the Top 

Menu Line. 

 
 
 

 
 
 

ST4 Test      
 
The DS10CCTEC camera does not have an auto-guider ST4 port, so this control is deactivated.  

 

 

Advance/Reverse      
 
These icons allow you to advance or reverse the current frame when viewing an opened Video 

in the ser format. 

Recall: to load a video for examination and viewing first close the live camera window (this 

stops the camera). Then choose File->Open Video and select the ser format video to view. 

These icons will now become active, and you can view the video frame by frame if required. 
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Stitch      
 
For more detailed information on using Stitch, see the Stitch Control as described previously 
in the Top Line section of the User Manual. 
 

You can find Denoise Tools, Sharpen Tools, Color Correction Tools and Enhancement Filters 

inside the Process command to sharpen your image. 

 

 

 

You can modify the color effectiveness range with the Range control to color-sharpen your 

image. 

 

 

You can modify the image pixel/no pixel count with the Binary control. 
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You can examine the image as a 3-D color contour map with the 3-D setup control. 

 

You can apply the Pseudo Color application tools to turn a Black and White image into color 

tones. 

 

But one cool tool that is built in to MallincamSky is simply the stacking of your video 

frames to produce an improved image. 
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Preferences      
 
This icon opens the preferences window. This icon is identical to the Main Tab line Options-
>Preferences…. See previous section in the Options Tab. 
 

 

 

 

 

 

 

 

 
 

Customize      
 

This control will allow you to customize what appears on the Icon Bar. 

Left-Click on the Customize Icon to display the Add or Remove Buttons selector. 

Toolbar 

Then Left-Click on the down-triangle to 

expand and select Toolbar.  

Left-Click on its triangle to expand the 

command to show the currently displayed 

Icons. 

Select which Icons you want displayed on 

the Icon Bar by Left-Clicking on the 

checkmark to add or remove that Icon. 

You can reset the Icon bar to its default 

state by Left-Clicking on the Reset Toolbar 

button. 
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Customize 

This control will allow you to customize 

your Icon Bar, by providing a process of 

adding or removing other control icons to 

its bar.  

The left Categories Window contains the 

icons specific to that category. 

The All Commands category contains all 

available icons. 

Choose a Category. 

Left-Click Hold and Drag an icon from the Commands Window to the Icon bar (you 

will see a black marker bar appear when you move your cursor to the Icon Bar as 

position it where you would like to place the new icon. 

Release the mouse button, and the icon will appear where your mouse was pointing. 

Before:  

After:  

 

To remove an icon from the icon bar, just drag if off the icon bar. 
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Controlling the SkyRaider with Left 

Side Bar 
 
Once you have a connection to the SkyRaider Camera, your next 
task will be to adjust the controls that make it possible to improve 
the image the SkyRaider is capturing. These controls are located 
on the Left Side Bar Menu on MallincamSky.  
 
The Controls all have drop-down arrows; Left-Clicking on the 
Down-Arrow in the control heading will expand that control. Some 
controls will also display a colored rectangular box on the Video 
Window to remind you that that control is in effect. You will be 
able to collapse the control window by Left-Clicking on the Up-
Arrow on the control heading. 

 
 
 
 
 
 
Camera List 
 
The Camera List control lists the current SkyRaider cameras connected to the computer. Left-
Clicking on the camera name (SkyRaiderDS10CTEC) will start the camera video window.  

 

 
 
 
Once activated, you will see a tabbed frame (with Video [SkyRaiderDS10CTEC]) appear in the 
Video window after selecting the Camera from the list.  

 

 
 

 
You can only access one SkyRaider Camera at a time even though you may have multiple 
cameras attached. 
 
You can start another instance of MallincamSky and have this instance control a second 
SkyRaider camera at the same time as your original instance of MallincamSky controls the first 
SkyRaider camera. 
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Capture and Resolution 

 
The Capture and Resolution Tab allows you to adjust the resolution (the SkyRaider DS10CTEC 
has 4 resolutions), modify the Gain, and choose the type of Exposure Mode that you require 
for the camera. 

 
 
 

Located at the top of this control is the Resolution Command. 
This command allows you to adjust both the display and 
capture resolution of the SkyRaider Camera (each model of the 
SkyRaider Camera will have its own resolution settings that will 
appear in the list). Once the resolution is set, this control will 
also allow you to either take a Snapshot of the image or save a 
video recording of what is currently being displayed. 
 
Left-Click on the Drop-Down list on the Resolution: box to see 
all the allowable resolutions available for your SkyRaider. The 
SkyRaider DS10CTEC has four resolutions:  3704 x 2778, 4096 x 
2160, 2048 x 1080, and 1360 x 720. 
 
 
 
The Resolution of the sensor along with the Focal Length and Optical Size of the Telescope 

play a role in determining the image size, resolution of the pixels, and the exposure rate of 

the camera. Sample formulas are provided below.  

Visit https://astronomy.tools/calculators/field_of_view/ for online calculations) 

 

Formula Example (10-inch F/8 Telescope) 
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Note: The Focal Length of the Telescope is responsible for the Field of View. 
 

Resolution 

 

 

https://astronomy.tools/calculators/field_of_view/
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Adding Barlows/Focal Reducers will adjust telescopes Focal Ratio and Focal Length and thus 

will affect the objects Field of View and telescope’s Speed.  

 
Sample Image Size using 10-inch F/8 Telescope: F/L=2032mm (0.47”/pixel). 
 

Pixels Field 
of 

View 

M42 M57 M92 Moon 

3704 
x  

2778 

29.01’ 
x 

21.76’ 

    

4096 
x  

2160 

32.08’ 
x 

16.92’ 
    

2048 
X 

1080 

16.04’ 
x 

8.46’ 
    

1360 
X 

720 

10.65’ 
x 

5.64’ 
    

 
 
Sample Image Size using 10-inch F/4 Telescope: F/L=1016 (0.94”/pixel). 
 

Pixels Field 
of 

View 

M42 M57 M92 Moon 

3704 
x  

2778 

58.03’ 
x 

43.52’ 

    

4096 
x  

2160 

1.07o 
x 

0.56o 
    

2048 
X 

1080 

32.08’ 
x 

16.92’ 
    

1360 
X 

720 

21.31’ 
x 

11.28’ 
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Left-Clicking on Snap will tell MallincamSky to display in a New Tabbed Window a Snapshot 
of the image that is currently being exposed by SkyRaider Camera. The image will appear in 
the Video Display Window, with a name which follows the naming convention nnnn* (for 
example 0001*).  
 
Note: if the DS10CTEC is in RAW mode, then clicking on the SNAP button will open a save 
window, so you can choose a location to save this snapshot in FITS format. 
 
Note: if the Format resolution is RGB48, then clicking on the SNAP button, will display an 
image, but it will not match the viewed image (reset the FORMAT of image to RGB24), as 
stacking adjustment not included. 
 
Every time you Left-Click on Snap, another Tabbed Window with the name-number increased 
by one will appear in the Image Window. The image is only displayed in the Video Window; it 
is not saved on your computer. 
 
After clicking on the Snap button, the snapshot of the image will become the active window, 
you will need to Click on the Video [SkyraiderDS10CTec] Tab to return to live imaging. 
 
You can save the image (and thus rename it), by using the Save icon, or File>Save As… 
command from the Top Menu Line. 

 
 

 
 

This command is only available when the Mallincam SkyRaider is in Video Mode.  
 
See below for details on how to record video when in Trigger Mode.  
 
Prior to pressing this icon, you should use the Options->Preferences… Tab to choose the 
default location, name, format, and duration of the video. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Snap 

Record 
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Make sure that Video Mode is selected, then Left-Clicking on the Record Icon will tell 
MallincamSky to start recording a video of what is currently being captured by the SkyRaider 
(you will now be able to see the image being recorded as the Record Button will activate the 
camera).  
 
When the Mallincam SkyRaider is recording, the Icon will change to a Red STOP Symbol. By 
Clicking on the Stop Icon, MallincamSky will terminate the Video recording process, but the 
video imaging is still active. 
 
 

 
 

 
Make sure that Trigger Mode is selected but NOT Looping. Left-Clicking on the Record Icon 
will tell automatically start the Looping in Trigger Mode and MallincamSky will also start 
recording a video of what is currently being captured by the SkyRaider (you will now be able 
to see the image being recorded as the Record Button will activate the camera).  
 
When the Mallincam SkyRaider is recording, the Record Icon will change to a Red STOP 
Symbol. By Clicking on the Stop Icon, MallincamSky will terminate the Video recording 
process, and stop the Looping (camera is not imaging). 

 
 
 
 

 
 

 
This control allows you to adjust the gain. Gain will brighten up the image (but it can also 
brighten up the artifacts). The higher the Gain value; the shorter the exposure that you will 
require. All you need to do is find the highest Gain value that provides you with the image you 
are satisfied with. 
 
The Gain Control Bar has an indicator to provide you with the current Gain setting on the 
camera. Gain ranges from a low of 1 to a high of 160.  
 
You can modify the Gain in three different ways: 
 
➢ By Left-Click-Hold and Drag the marker bar to the required value. 

 
➢ If you Left-Click on the Slider Bar (which selects it), you can use the Left and Right 

Arrow Keys of your keyboard to move the slider (this gives you more control). 

 

➢ By Clicking on the Gain number to open a small window 

where you can enter in the Gain Value (the decimal 

point is missing, so off by a factor on 100) or use arrows 

to adjust the value.  

If in Video Mode 

If in Trigger Mode 

Gain 
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Gain can be modified at any time while in Video Mode, and thus the result will immediately 
be apparent after the image is refreshed. 
 
But you must STOP the Looping in Trigger Mode to change the Gain, then restart Looping to 
see its effect. 
 
 For Deep Sky Objects, start the Gain at about 70. For Planetary Objects, start the Gain at 
about 5. A high Gain on Deep Sky Objects makes them appear very quickly at a lower exposure 
time. 
 

Exposures 

 

The Mallincam SkyRaider DS10CTEC camera provides two different types of exposures. Video 

Mode, where exposures up to 5 seconds are taken, and Trigger Mode were exposures from 

100 us to 1 hour can be taken. 

Video Mode 
This control allows the SkyRaider DS10CTEC to have an exposure up to 5 seconds (5000ms), 
this mode is ideal for focusing the telescope and imaging the Sun, Moon, and bright planetary 
objects. You can have MallincamSky automatically choose the exposure by checking the Auto 
Exposure check box, or you can set an exposure time yourself (recommended).  

 
 
 
 
 
 
 
Video Mode is activated by Left-Clicking on the Video Mode Radial Button. 

 
 
 
 

MallincamSky uses the image contained in the Green Rectangle to aid in determining the best 
method to match the Exposure target number. To use Exposure Target, Auto Exposure must 
be checked. You can change the Exposure Target by Left-Click-Hold and Drag the marker bar 
to the required value. If you Left-Click on the Slider Bar (which selects it), you can use the left 
and right arrow keys of your keyboard to move the slider (this gives you more control). 
 
When Video Mode and Auto Exposure is selected, you will see a Green Rectangle (labelled 
Exposure) will appear over your Video Window. This Green Rectangle 
is a marked region that is a reference region for judging if the image 
brightness has reached the Exposure Target Value (When Auto 
Exposure is selected). Dragging or Resizing the Green Exposure 
Rectangle to a dark area will increase the video brightness and 
Dragging it or Resizing it to a bright area will decrease the video 
brightness.  
 

Exposure Target 
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The Green Exposure Rectangle will be removed when you uncheck Auto Exposure. But if you 
need Auto Exposure, then I recommend that you enlarge the Green Exposure Rectangle to 
the full size of the Video Window (Left-Click Hold and Drag) or drag and reduce the green 
rectangle to a corner of the image window. 

 
 

 
 

 
The current Exposure time is displayed above the Exposure Time slider. MallincamSky will 
display the exposure time in ms, from 0 ms to 5000 ms. 
 
 
To use Exposure Time, Auto Exposure must be unchecked. You can modify the Exposure Time 
in three different ways: 
 
➢ By Left-Click-Hold and Drag the marker bar to the required value. 

 
➢ If you Left-Click on the Slider Bar (which selects it), you can use the Left and Right 

Arrow Keys of your keyboard to move the slider (this gives you more control). 

 

➢ If you Left-Click on the Current Exposure Time Value, a window would open, and you 

can enter in the exact exposure time you require. This window will also provide you 

the exposure limits the SkyRaider Camera can handle. 

 
 
Do not forget to Left-Click on OK to have MallincamSky accept the entered exposure time. 

 
For any exposure over 3 seconds, you can determine how long your camera’s exposure time 
has left on it by looking at the bottom of the MallincamSky’s Window. There it will indicate to 
you the current time used of the exposure time that you had previously set. 

 

 
 

The SkyRaider DS10CTEC will use the following format to inform you of the current exposure 
condition: Percent completed; Time Used/Exposure Time 
 
 
If you have enabled the Dark Field Corrections for this session (Dark Fields are stored directly 
in the SkyRaider Camera and will be deleted when the camera is turned off), the SkyRaider 
will automatically apply the best Dark Field Correction to your image when Dark Field 
Correction is enabled. 

 

Exposure Time 
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Trigger Mode 
 

Trigger Mode is used mainly for exposures 
over 5 seconds (Deep Sky Objects). It is 
selected by checking the Trigger Mode Radial 
Button. This mode does not require the Green 
Rectangle for exposure control. But rather 
allows you to take a Single image, or to 
continuously Loop images from the DS10CTEC 
to check for exposure. 
 
 
 
 
You have two methods of setting your exposure to a large value:  
 
➢ You can Click in the Time Unit Box of choice and enter in an amount (i.e., 30 seconds) 

using your Keyboard. 

➢ You can Click on the up or down arrow in the Time Unit Box of choice to move the 

exposure time to your required value (30 seconds). 

Click on the Single Button to take a single exposure to see if the image of the object is close to 
the brightness you need. 
 
If you are satisfied with the single image, then Click on the Loop Button to have the SkyRaider 
DS10CTEC continuously take images at the entered exposure value (it will change its name to 
Stop, so you can again Click on the button to stop the Looping). 
 
When using Trigger Mode, you CANNOT adjust the Gain on the fly. You must stop the Loop, 
adjust the Gain, check with a Single image, then choose Loop when satisfied. You CAN adjust 
Gamma, Brightness, Contrast on the fly in Trigger Mode. 
 
You cannot Record a Video sequence when Trigger Mode is activated and 
Looping. You must first Stop the Trigger Mode, then Click on the Record 
button (which will start Looping automatically). Once you Stop recording, via 
the Record STOP button, Trigger Mode will automatically Stop Looping.  
 
To capture a sequence of images using the Mallincam DS10CTEC in Trigger Mode, there are a 
series of command controls available for you. 
 
The Sequence command recognizes if Live Stack is enabled and will include that process in the 
output images, but you must allow time for the Live Stacking to complete (especially if Align 
Frames is enabled). As it may take a few images in the sequenced before the completed Live 
Stacked image is included as part of the sequence images. 
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Clicking on the Options Button opens the Sequence Options Window. 

 

 
 
This Window allows you to either display the sequence of automatic captures in the Video 
Window, a New Tab Window on MallincamSky (not recommended… too many windows can 
appear) for each image in sequence, or Save the sequence images to a file. You have complete 
control, since you can choose a specific directory, a File Prefix, a numbering system, and even 
a file format to match your preferences. See above in Options>Preference>Record for more 
details on how to use Directory, Naming, and Prefix conventions. 
 
You can also set up a plan of shots, each with its own exposure and gain, along with pause 
time between each shot. This is different than just a sequence of shots with the same 
exposure time. 

 
If Name Format is set to nnnn (sequence), then checkmark the The sequence begins with: 
box, and choose the starting number. 
 

 
 
 
 

Here you get to create a unique sequence of shots, each with its own Exposure Time, Gain 
value, and amount of Delay before image is taken. 
 

 

Options 

Sequencer 
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Mode:  It is here that to either indicate that 

you want the Plan to be active or 
Disabled. If disabled, then the 
sequence will just produce a set number of images with current exposure settings. 
If the Mode is set to Plan, then the pattern of exposures will be taken following 
the pattern you have set up below. 

 
Number:  It is here that enter the number of different exposures you want 

included in your Plan. You can have up to 255 different exposures 
included in a Plan. 

 
Preset:  It is here that you can Name and Save your current Plan using 

the Save… control.  The Management… control allows you to 
rename and Delete your Plans. The list of current plans is 
displayed under the Management… control. 

 
Elements:  After you have set up the number of elements in your 

Plan, the Index will display the sequence number for 
that exposure.  

 
 
  

For each Column in a specific Index Row, you will enter three pieces of 
information: Exposure Time, Gain, and Delay. 

 
 

To enter an exposure for a specific sequence, just 
double-click in the intersecting Index Row and 
Exposure Time column location to open the Exposure 
Time entry box for that Row. 

  
 
  

To enter a gain for a specific sequence, just double-
click in the intersecting Index Row and Gain column 
location to open the Gain entry box for that Row. 

 
  
 

To enter a Delay for a specific sequence, just double-
click in the intersecting Index Row and Delay column 
location to open the Delay entry box for that Row. 
 

 
Repeat this process for each Index Row of your Plan, then Click on the OK button to accept 
and close the Sequence Option Window. 
 
Note:  If you Choose Plan in the Mode control, the activation button will say Plan rather than 

Sequence in the Trigger Control. 
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Use this control to enter in the number of images you would like MallincamSky to Save to your 
selected folder (from the Options Command above), or display in a Tab, or Video Window. 
 
If you Choose Plan as the Display Option, then the number indicates the last number in the 
index to display. For example, if you have 10 exposures in your Plan and you entered 4 as the 
number, then only the first 4 exposures in your plan will be displayed (saved). 
 
You will see the status of the Frame sequence and timer by a counter located on the bottom 
of the Video window if you choose Show in Video Window in Options. 
 

 
 

 
 
 

Clicking on the Sequence or Plan Button will start the sequence capturing 
process. Once Sequencing, the Sequence Button’s name will change to Stop. 
Clicking on the Stop Button will abort the sequence process.  
 
The SkyRaider DS10CTEC camera cannot be Looping at the time you Click on the Sequence 
Button. 
 

 
You can use this control in conjunction with the Live Stack to combine multiple 
exposures to create a High Dynamic Range image. See Chapter 8 for more detail on 
how to perform this. 
 
 
  

Number in Sequence 

 Sequence/Plan 
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Bit Depth 
 
Pixel Bit Depth relates the number of bits assigned to produce a 
color (or shade of Gray). The larger the number of bits, the larger 
the number of assigned colors (or shades of Gray) that the 
camera can produce for Windows display.   
 
In an 8-bit image; for each color channel (Red, Green, Blue), there are 8 bits assigned. That is, 
there are 256 (28) shades of Red, Green, and Blue available for Windows display. 
 
In a 14-bit image; for each color channel (Red, Green, Blue), there are 14 bits assigned. That is, 
there are 16384 (216) shades of Red, Green, and Blue available for Windows display. 
 
The larger the Bit Depth, the larger the data, and the harder the CPU must work to produce 
image adjustments. 
 

White Balance 
 
The White Balance control allows you to manually adjust the 
individual Red, Green, and Blue components of your image to 
better match your requirements. This command is available in 
real-time in both Video and Trigger Mode. Once this command 
is activated, a Red White Balance rectangle will appear on the 
screen. 
 
To adjust each specific colour use the Left-Click-Hold and Drag mouse technique. 

 
Once this control is expanded, MallincamSky will draw A Red Region of Interest Rectangle on 
your Video Window. You can adjust the size and location of this rectangle by using Left-Click-
Hold and Drag mouse techniques. 
 

 

 
If your colors look “off”, the White Balance button is an automated 
way to adjust the colors to a more natural interpretation. Drag or 
Resize the Red Rectangle to a pure white area and Left-Click on the 
White Balance Button to establish the video White Balance for 
future video streaming process. 
 
 
If you (or the SkyRaider Camera) ever get confused with what settings you have entered into 
the Color Balance control, you can reset these values back to their defaults by Left-Clicking on 
the Default Button. 
 
 
 
 
 
 

White Balance 
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Color Adjustment 
 

The Color Adjustment control will allow you to adjust: 
The Hue, Saturation, Brightness, Contrast, and the 
Gamma of the object that the DS10CTEC is exposing. All 
elements of this command are active in real-time in both 
Video and Trigger Mode. 
 
 
Any changes to these commands will only be displayed 
after the next camera refresh. (Which for Deep Sky 
Objects can take a while, depending upon the exposure). 
 
It is recommended as you become comfortable with 
these settings, you will determine what values are the 
best starting point so make a note of them so you can quickly get these values to a setting that 
works for you. 

 
 
 
 

This command controls the Hue of the Video image. Hue is one of the main properties of 
color. By adjusting Hue, you are changing the balance of Red, Green, and Blue in the image. 
 
You can either use the Left-Click-Hold and Drag technique to move the slider to the left or 
right, or just Left-Click on the Hue’s slider (this selects it), then use your Left and Right arrow 
keys on your Keyboard to adjust the value (small Hue adjustments are easier with this 
technique). The value of the Hue setting will be displayed above the slider. 
 

 

 
 

This command controls the Saturation of the Video image. Saturation increases the 
separation of colors on a video image. It can enhance or inhibit the colors on the video image. 
 
You can either use the Left-Click-Hold and Drag technique to move the slider to the left or 
right, or just Left-Click on the Saturation’s slider (this selects it), then use your Left and Right 
arrow keys on your Keyboard to adjust the value (small Saturation adjustments are easier with 
this technique). The value of the Saturation setting will be displayed above the slider. 
 

 
 
 

This command controls the Brightness of the Video image. Brightness makes the video image 
brighter or dimmer. This is a linear adjustment. 
 
You can either use the Left-Click-Hold and Drag technique to move the slider to the left or 
right, or just Left-Click on the Brightness’s slider (this selects it), then use your Left and Right 
arrow keys on your Keyboard to adjust the value (small Brightness adjustments are easier with 
this technique). The value of the Brightness setting will be displayed above the slider.  

Hue 

Saturation 

Brightness 
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This command controls the Contrast of the Video image. Contrast is defined as the separation 
between the brightest and darkest areas on the video image. When you adjust the Contrast, 
you increase the separation between bright and dark. 
 
You can either use the Left-Click-Hold and Drag technique to move the slider to the left or 
right, or just Left-Click on the Contrast’s slider (this selects it), then use your Left and Right 
arrow keys on your Keyboard to adjust the value (small Contrast adjustments are easier with 
this technique). The value of the Contrast setting will be displayed above the slider. 

 
 
 
 

This command controls the Gamma of the Video image. Gamma adjusts the mid-tones in a 
non-linear manner. That is, rather than make the image look brighter; it can increase the 
brightness of the shadows and mid-tones, without affecting the highlights in the image (This 
control is like adjusting the mid-tone slider on a histogram. Start with minimum Gamma. 
 
You can either use the Left-Click-Hold and Drag technique to move the slider to the left or 
right, or just Left-Click on the Gamma’s slider (this selects it), then use your Left and Right 
arrow keys on your Keyboard to adjust the value (small Gamma adjustments are easier with 
this technique). The value of the Gamma setting will be displayed above the slider. 
 
If you (or the DS10CTEC) ever get confused with what settings you have 
entered into the Color Adjustment control, you can reset these values back 
to their defaults by Left-Clicking on the Default Button. 
 

Frame Rate 
 
The speed of the through-put on the USB 3.0 port on your 
computer can depend on many parameters that are 
specific to the processes running on your computer. This 
throughput can be affected by the current Windows 
environment, CPU, graphics cards.   
 
Using the Left-Click-Hold and Drag technique, move the 
slider to the highest frame rate that your computer can 
support.  
 

 
Start with the Frame Rate slider at the highest value, and only adjust lower if video image fails 
to appear. Most will find setting frame Rate towards the Low end of the scale better. If 
MallincamSky seems to freeze, lowering the Frame Rate can sometime resolve the problem. 
 
 
 
 

Contrast 

Gamma 
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Color/Gray 
 
This control contains commands that allow the 
DS10CTEC to display its displayed images in color (these 
colors can be adjusted using the commands seen above) 
or display the image in shades of grey. Some users 
prefer the subtle contrast variations that a grey image 
provides, especially when imaging the Moon. 
 
➢ If you require the color video to be displayed in Color, then Left-Click on the Color 

choice. 

➢ If you require the color video to be displayed in shades of Gray, the Left-Click on the 

Gray choice. 

 
Flip 
 
This control allows you to Flip the orientation of the 
video image Horizontally, Vertically, or Both. This is a 
useful command, as it allows you to match the image 
orientation to that of the orientation of the actual 
object (which changes with the number of reflecting 
mirrors in your telescope). 
 
Left-Click to place a check mark in the Horizontal, and/or Vertical boxes to have the image 
immediately reflect your choices. 
 
 

Rotate  
 
This control allows you to rotate the video image, 0o, 90o, 
180o or 270o. Just click on the radial button that matches 
your desired rotation (0o is back to normal). 

 
 

 
ROI 
 
ROI or Region Of Interest allow you to isolate the rectangular portion of the video image that 
you may be interested in.  You will lose your Dark Field using this control. 
 
When you are recording video images of planetary 
objects, the size of the video can grow very quickly. 
The ROI allows you to instruct MallincamSky to only 
show and save a specific area of the screen (a smaller 
region that just contains the image of the planet as 
indicated by a blue rectangle). This has 2 benefits: smaller files sizes, and as a bonus will allow 
for a faster frame rate.  
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The ROI command only works in real-time while the SkyRaider DS10C TEC is in Video Mode. 
To set ROI in Trigger Mode, the Looping must be stopped. Then ROI can be adjusted and then 
Applied, then restart Looping to see the adjusted region. 
 
 
When selected, a Blue Rectangle will appear 
over your Video Window. You can adjust it 
using the Left-Click-Hold and Drag 
technique or Left-Click-Hold and Drag to 
place it over a specific portion of your Video 
Window.  
 
 
 
Once you have resized and placed the Blue 
ROI Rectangle on your Video Window, Left-
Click on the Apply Button to select this as 
the New Video Window. Then the Next 
Refresh will fill in the ROI window.  
 
 
 
 
You can then resize the New Video Window by either the Drop-Down Size command in the 
MallincamSky Tool Bar or by scrolling the wheel on your mouse (if your mouse has a scroll 
wheel). 
 
This command allows you to Zoom in on a specific area of your original Video image. 
 
If you (or the DS10CTEC) ever get confused with what 
settings you have entered into the ROI control, you can 
reset the ROI to its full screen by Left-Clicking on the 
Default Button or Maximum Button. You may need to set Fit to Window in the Drop-Down 
Size command in the MallincamSky Tool Bar. 
 
If you are trying to improve the frame rate (frames per second) when viewing planetary 
objects. Selecting a Region of Interest around the planet will allow MallincamSky to only 
capture that ROI portion of the whole image. As a result, the frame rate will dramatically 
increase. 
 
You can also manually set the size of the ROI by clicking on either the horizontal or vertical 

size indicator in the ROI Tab. A Window will open-up that allows you to manual select the 

Horizontal or Vertical size as determined by you.  
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Digital Binning   
 
This process allows you to increase the sensitivity of the Mallincam Camera by providing you 
the option of combining sensor cells together to increase the photon capture area. For 
example, a 2 x 2 binning will link 4 cells (in a 2 by 2 array) together, so you have about 4 times 
the capture area than one cell. But remember nothing is free, it gives up the number of 
horizontal and vertical pixel resolution by that same factor. You can have the Mallincam either 
Average the pixels or Add the pixels. The supported Binning available is 1x1, 2x2, 3x3 and 4x4. 
As an added bonus, Digital Binning helps increase sensitivity and reduces noise to some extent 
by improving Signal to Noise Ratio. 

 

 

As a user, you will decide as to what level of Digital Binning you will use. You can use a shorter 

exposure time to achieve an image, but the image will cover more space on the chip. 

When you select the Digital Binning Tab, it opens to provide the following settings: 

 

 

 
 

You have two choices here, either Additive or Average. Additive will shorten the exposures as 

it adds the values of the combined pixels. Average will keep the exposure about the same, but 

it will average the combined pixels, so producing a sharper image for the resolution. For Deep 

sky objects you might choose Additive to produce an image quickly, and Average to produce a 

sharper image with more detail. For Planets and the moon, try Average to see if it improves 

your image’s detail. Trial and error to see which is best for your environment. 

 

Method 

2 

6 5 

4 3 

7 8 

1 
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You now have the choice of the type of resolution and binning to use: 

Binning 3704 x 2778 4096 x 2160 2048 x 1080 1360 x 720 

1 x 1 3704 x 2778 4096 x 2160 2048 x 1080 1360 x 720 

2 x 2 1852 x 1388 2048 x 1080 1024 x 540 680 x 360 

3 x 3 1234 x 926 1364 x 720 682 x 360 452 x 240 

4 x 4 926 x 694 1024 x 540 512 x 270 340 x 180 

5 x 5 740 x 554 818 x 432 408 x 216 272 x 144 

6 x 6 616 x 462 682 x 360 340 x 180 226 x 120 

7 x 7 528 x 396 584 x 308 292 x 154 194 x 102 

8 x 8 462 x 246 512 x 270 256 x 143 170 x 90 

 
 
For each higher binning level you choose, the video screen window size will reduce (as you 
are combining more pixels as one), effectively lowering the number of pixels in the image 
resolution. You can use the Zoom controls to increase the image size to your needs. 

 

   
 1 (additive) 2 (additive) 

 

   
 3 (additive) 4 (additive) 

 
You will notice that the brightness of the image will dramatically increase with the larger 
binning number when Additive is chosen (resolution will decrease), so you will need to adjust 
the exposure setting accordingly. 

 

 

 
Use the large value 4 x 4 or 3 x 3 to shorten the exposure time, so that you can quickly locate 

(and if necessary, focus) the deep sky image you are interested in. Then choose a smaller 2 x 2 

or 1 x 1 binning to produce a more detailed (higher resolution) image. 

The DS26, DS2.3, DS16, and DS10 cameras have large chips, so using binning setting will still 

provide enough resolution (and Size) to image most deep sky objects.  

Number 

Usage suggestion in digital binning.  
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You must make Dark Fields with the same Digital Binning settings as you image, or else weird 
looking effects will occur. We suggest saving a set of Darks for each of the binning modes. 
 
Use a naming convection and/or a file location so that it is easy to not only choose the correct 

Darks for a binning setting, but with-in that binning setting a Dark that match your exposure 

and other settings. 

If you find that the video window size doesn’t want to return back to its 1 x 1 full screen, just 

select Video Mode, then return back to Tigger Mode. 

 

Histogram   
 
A Histogram illustrates how pixels in an image 
are distributed by graphing the number of pixels 
at each color intensity level. The Histogram 
shows detail in the shadows (shown in the left 
part of the histogram), mid-tones (shown in the 
middle), and highlights (shown in the right part). 
See Appendix for more information on 
Histograms. 
 
A Histogram can help you determine whether an 
image has enough detail to make a good 
correction. 
 
The Top Segment in the expanded Histogram 
Control shows the real-time Histogram of current 
active video. 

 
This Histogram control, as compared to the top line Icon Histogram control allows you to 
make real-time adjustments to the settings to improve the image. 
  
Two vertical line markers (white) show the upper and lower limits of the intensity levels. 
These markers can be dragged with mouse (Left-Click-Hold and Drag), or you can enter in 
specific values (left and right) to place the vertical Line markers. 
 
You use the Histogram to aid you in determining the best exposure value for your particular 
object. But try not to get too aggressive, as you can easily clip (remove) important data from 
your image. Since you are Astro-imaging, the bump of the histogram should be about ¼ from 
the left as the image will contain a larger amount of black. 

 
If you are looking at a color image, the Histogram will reflect the RGB (Red, 
Green and Blue channels histogram at the same time) values with shading 
of the same color. You can also use the Pull-Down to select the Histogram 
for just the Red, or just the Green, or just the Blue channel. 

Dark Field subtraction in Digital Binning 

This is your 
Data 

Black 

White 
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You can also directly enter the desired values in the Left or Right boxes 
below the Histogram chart for both Left and Right Histogram boundaries.  

 
You can select how you would like the Histogram data displayed. You 
have a choice of either Linear or Logarithmic (makes small graph values 
visible). 
 
You have three options for adjusting the histogram. Manual allows you 
to adjust the Histogram markers (bars or values). Once will have 
MallincamSky automatically select the best Left and Right locations for 
the Histogram. Disable will set the Left value to 0 and the Right value 
to 255. 

 
Set the exposure so that the Peak of the Histogram is some place between 50 and 100. 
 
To illustrate what you can do with the Histogram, I have (thanks to Jim Meadow’s amazing 
images) included some before and after pictures. 
 
➢ Increasing the Left Bar Darkens the image 

➢ Decreasing the Right Bar Brightens the image 

The following Before image is a 3 second exposure with Left at 0 and Right at 250 
 

 
 
The following After image, same 3 second exposure, with the Left at 25 and the Right at 50 

 

 
 
Notice that in both Histograms, the data was mostly to the left. This tells us we have some 
exposure room to play with. Do not forget Gain and Brightness also has a role as well. 

25 
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Dark Field Correction   

 
What makes the Mallincam SkyRaider series of cameras unique is the built-in ability to take 
Dark Fields. 
 
The best explanation of what a Dark Field is came from Simon Hanmer. See Appendix for his 
explanation. 
 
To have the SkyRaider camera to automatically apply Dark Fields, you need to follow the 
following procedures before imaging. 

 
 
 
 
 
 
 
Select the SkyRaiderDS10C TEC from the Camera List in the Camera Tab. 
 
 
 
 
 
Select an Exposure Time for Dark Field Correction and Start Exposing, at this point Dark 
Fields are not being created, it is just the DS10CTEC taking timed images. 
 
 
With the Camera Tab selected on the Left SideBar, Left-Click on the Capture & Resolution.  
The Exposure & Gain Window will expand allowing you to select the exposure time for the 
Dark Field. 
 
You must determine what you believe will be the maximum 
exposure for this session. As, you will create Dark Field’s with this 
time (or close to it).  Also, to want to try to match the other 
settings in the DS10CTEC in the Dark Field as you would have 
when imaging the Object. 
If you are taking a maximum exposure under 5 seconds, then 
select Video Mode, but since most Deep Sky Objects will require 
an exposure of over 5 seconds, choose Trigger Mode. 
  
Either enter the time into the appropriate boxes or use the up and 
down arrows beside the chosen Exposure time unit to set your 
maximum time. 
 
Start the SkyRaider DS10CTEC taking continuous exposures by 
Left-Clicking on the Loop button. 
 

 
 

Select SkyRaider 
Camera 

Select Exposure 
Time 

Take Dark Fields 
Check Enable 

Box 

Step 2 

Step 1 
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Ensure that the cover is either on the SkyRaider Camera or the 
Telescope itself is covered, then Left-Click on the Dark Field 
Correction Line.  
 
The Dark Field Correction Line will open allowing you to select the 
Quantity of Dark Fields and the option to start the Dark Field 
Capture process. 
 
Select up to 99 (it is recommended to start from 5 to 10) for the 
Quantity, then Left-Click on the Capture Button. MallincamSky 
will now create the Dark Fields. The Software will display its 
progress above the selected Quantity. Remember, it is beneficial 
to set the Dark Field exposure time greater than the longest time 
you will be imaging at. The longer your intended exposure, the 
larger the suggested Quantity of Dark Fields you should take.  
 
As the Dark Fields are being exposed, you can watch the exposure counter in the Dark Field 
Correction Tab go up, and on the bottom right side of the MallincamSky window, you will see 
a counter letting you know how long is left in that particular exposure. 
 
 
Once you have finished taking your Dark Fields, do not forget to remove the lens cap on your 
camera (or Telescope), so that you can continue imaging your object (I won’t mention any 
names…). 
 
Once you have collected your Dark Fields, you can then save them with the Export Button 
(choose a location and File name that allows you to locate the correct Dark Fields in case you 
would like to reuse them. Name the folders so that it is easy to retrieve Dark Fields that match 
the current imaging plan (60 s times 5). You can load previously saved Dark Fields via the 
Import Button. Just browse to the folder where you saved them when you used the Export 
Button. 
 
 
To activate the Dark Field’s just Left-Click in the Enable 
check box in the Dark Field Correction’s box to have Dark 
Fields applied in real time to your images.  
 
To image without using Dark Fields, just uncheck the Enable 
checkbox. 
 
 
It is important that you try to match the Dark Fields with the same resolution, gain, black 
level, gamma,… as would with your image, else the results will not look as great as they could. 
 
 
 
 

 
 

Step 3 

Step 4 
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Flat Field Correction   

 
 

 
When imaging using a CCD/CMOS device, and when trying to use those images for scientific 
purposes, it is essential to reduce the amount of unwanted signal and unwanted noise from 
each image frame. The optical path “noise” (some of which is actually signal), is such a 
problem that many astronomers had to suffer with. The resolution to this problem came from 
the use of Flats and applying those Flats to the images.  

 
Telescopes, CCD/CMOS chips, filters, lenses all block light as well as transmit light. They also 
harbor dust, fingerprints, and other unwanted shadow producing things in the light path. The 
result of such optical path obscuration is an unevenly illuminated CCD/CMOS chip. These 
noise variations are usually caused either by variances in sensitivity from pixel to pixel, or by 
the telescope optics.  Main causes due to the telescope are vignetting and out-of-focus dust 
on one of the lenses in the optical system. This is a real challenge for anyone doing real 
science or pushing their images to the highest level. Optical path vignetting, and other 
physical path obstructions will also cast large, non-discernable shadows onto your CCD/CMOS, 
causing a poor non-even illumination across the image field. Flat fields are used to remove 
variations in the brightness of pixels across the CCD chip.  The plan is to then “subtract” this 
consistent noise from the images being produced by the camera. 

 

 

 

 

 
A Flat Field is an image taken of an evenly illuminated object like the dusk sky, or a special 
illuminated white card hanging on the wall of the observatory or even a white T-shirt placed 
over the telescope. This is not a Flat Frame (a Flat frame is a save able image) 

 

 

 

 

 

Introduction: 

Optical Path Noise: 

Taking Flats: 

https://starizona.com/acb/ccd/ccdglossary.aspx#Vignetting
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These images are ideally taken through the telescope: 

➢ at the same temperature as your nightly images 

➢ through the same filter/s as your nightly work. 

➢ Do not change your imaging train (this includes adding or subtracting filters, 

extenders, reducers, or even rotating the camera) after you have taken your 

flats. 

➢ with integration times to allow the flat to produce an image that captures 

“noise”, but Flat images should never bloom, but should also not be less 

than a second in integration time. 

 

For precision work, 5 to 30 or more flats at an exposure of not greater than a couple of 
seconds. You want an image that shows the faults, not one that is over exposed. Practice, 
Practice, and yes, even more practice to get the flats correct. Each flat will then be averaged 
together to create a master flat which is then divided out of your light frame on a pixel-by-
pixel basis.  
 
Visit the following site for before and after images when applying Flats: 

 
http://theworldofastronomy.blogspot.ca/2016/04/astrophoto-flat-field-
illustration.html 
 
 
Ensure that you are pointing the telescope at your Flat Field 
source (dusk sky, white board), select an exposure time, then 
Left-Click on the Flat Field Correction Line.  
 
The Flat Field Correction Line will open allowing you to select 
the Quantity of Flat Fields and the option to start the Flat Field 
Capture process. 
 
Select up to 99 for the Quantity, then Left-Click on the Capture 
Button. The Software will display its progress above the 
selected Quantity. Remember, the more images you select the 
more averaged will be the Flat Field.  
 
As the Flat Fields are being exposed, you can watch the 
exposure counter in the Flat Field Correction Tab go up, and on the bottom right side of the 
MallincamSky window, you will see a counter letting you know how long is left in that 
particular exposure. 

 
To activate the Flat Fields just Left-Click in the Enable check box 
in the Flat Field Correction’s box.  All subsequent images will have 
the Flats automatically removed.  
 
To image without using Flat Fields, just uncheck the Enable 
checkbox. You can import or export the data for your Flat Fields, 
but remember this is not an Image File, it is a data file.  

Step 1 

Step 2 

 

 

http://theworldofastronomy.blogspot.ca/2016/04/astrophoto-flat-field-illustration.html
http://theworldofastronomy.blogspot.ca/2016/04/astrophoto-flat-field-illustration.html
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Black Level    
 
Black Level is defined as the level of brightness of the darkest (blackest) part of the image. In 
technical terms, the black level is the pixel level (in electrons, or volts) which corresponds to a 
pixel value of zero. The Black level adjustment on the MallincamSky allows you to adjust that 
value using the slider. 

 

 
 
The slider provides you with a range of subtle darkness adjustments from a starting point of 0 
to an end point of 31. In using this control, you can tweak your image to slightly “brighten” 
(towards level 31) or “dim” (towards level 0) the starting point for the image’s blackest 
location. 
 
Using this slider allows you to define what you believe (based on your current image) should 
be the optimum black. This control is most useful when you are experiencing a glow due to a 
bright object near the object you are imaging, and you want to tweak the darkness. 
 
You can use the Black Level to shift the peak of your histogram towards the right, this way it 
moves the left most starting point away from the left side and thus you can avoid clipping the 
blacks from the image. 
 
Since MallincamSky gives you the ability choose the Black Level for the camera, you can use 
this feature to assist in reducing the amp glow present in your image, You can also use the 
Black Level to create a well-balanced dark background against the stars in your image. 
 
Just have fun and experiment, as every telescope and seeing conditions provide for a different 
environment for the SkyRaider.  
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Live Stack 
 
MallincamSky comes with the ability to stack images to improve the signal to noise ratio. This 
feature will allow you to stack short exposures to produce an image that otherwise would 
have required a larger exposure time. Thus, you will obtain a brighter image that contains less 
noise. It also provides a technique of averaging images to reduce noise and improve overall 
final preview. This command allows users, whose equipment will not allow for long exposures 
(such as Alt-Az Mount), the ability to combine images on the fly (but can also be very 
beneficial to all mounts).  
 
The following images captured live illustrate the advantages of Stacking: 
 
 

M5, a single 5 second exposure using SkyRaider DS10CTEC on 10” 
VRC. 
 
 
 
 
M5, two 5 second exposures stacked using SkyRaider DS10CTEC on 
10” VRC. 
 
 
 
M5, three 5 second exposures stacked using the SkyRaider DS10CTEC 
on a 10” VRC. 
 
 
 
 
M5, four 5 second exposures stacked using the SkyRaider DS10CTEC 
on a 10” VRC. 
 
 
 
 
 
M5, five 5 second exposures stacked using the SkyRaider DS10CTEC 
on a 10” VRC. 
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Live Stacking can task your CPU and USB port (plus other internal Windows OS stuff). If your 
computer has a GPU (Graphics Processing Unit), then you can tell MallincamSky to use it via 
the Options>Preference>Misc control. 
 
 

 
 
 
 
 
Left-Clicking on this command will open the Live Stack Window 
 
We will see that there at two types of stacking (Additive and Average). You will use Additive 
to increase the image brightness, and you will use Average to decrease the noise (becomes 
less grainy). 

 

 
 
Here you can activate the stacking by check-boxing the Enable box and you can have 
MallincamSky Align the frames by checking the Align Frames Box. You can select the number 
of frames you would like stacked in the Number Box. You can tell MallincamSky if you would 
like the images Added (made brighter), or Averaged (made sharper), plus indicate is you are 
stacking Planets or Deep Sky Objects. This command will provide a live status of its stacking 
process in this Window. 

 
First select the object Type (Planet or DeepSky) 

 

 
 
 
 
 

Step 2 

Planet: Aligns on large objects in the 

image. 

 

DeepSky: Aligns on the stars in the 

image. We recommend using DeepSky 

 

Step 1 
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Now select how you would like the images Stacked, (Additive) or Averaged (Average) by 
making a selection in the Mode Box. We recommend using the Average setting since it will 
produce a smooth detailed image. 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
Next enter the Number of Frames you would like stacked. You can stack from 1 to 99 Frames. 
This control only works with the Additive stacking command above. 
 

 
 
Now determine if you would like the Stacking process to Align the Frames. This will produce a 
better Image but will take a bit longer. The process examines the image and determines 
alignment stars for the process. If there are not enough alignment stars, then the command 
will indicate that there is a problem, and you may need to increase the gain or exposure to 
produce more stars for the alignment routine. 
 
We recommend aligning the frames, so check the Align Frames Box. (Else you may obtain a 
Pink Floyd psychedelic effect for the image). 

 

 
 
Start the Stacking by checking the Enable Box. 
 

 
 
The stacking process will keep you informed with its status by indicating to you what the 
current input stacking number is, what the current output (how many frames are stacked), 
and via the status, if there are any issues. 
 

Step 3 

Step 4 

Step 5 

Step 6 

Additive: Adds the corresponding 

pixels. The more frames that are 

added, the fainter details then 

become more apparent and can very 

quickly increase the image brightness. 

(We recommend only using for 

outreach). 

 

Average: Takes an average of the 

corresponding pixels to help reduce 

the grain and thus improve the images 

(noise) in the image. If this is selected, 

the Number command (see below) 

does not play a role. This command will 

continuously average the next image 

into the previous average images. 

After about 20 to 30 average stacked 

images, changes become hard to 

notice. 
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If you told MallincamSky to stack 5 images, then when the 6th image is taken, it will keep 
displaying just the last 5 images stacked (the first image will be removed, this is a rolling 
stack). 
 

 
 
 
You can disable the Stacking process by just unchecking the Enable Box. 
 
  
Also do not be afraid to turn on Dark Field Subtraction to help eliminate the background 
noise. 
 
 
If the Status tells you it has an alignment failure (Not enough Stars), then just increase the 
gain. This should make more stars available to the alignment algorithm, so try again. 
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Conversion Gain     
 
A Higher Conversion Gain means higher sensitivity, as one signal electron can be more easily 
detected. The high-CG sensor shows a noticeably clear responsivity advantage; however, the 
tradeoff is clearly seen in the much lower full-well capacity as the sensor’s linear range ends at 
a much lower exposure. 
 

• Low Conversion Gain (LCG) for large charge handling capacity in bright scenes.  

• High Conversion Gain (HCG) mode with increased sensitivity and low read noise for 

lowlight scenes, providing tremendous benefit for real time imaging. 

The LCG mode is comparable to the old NO GAIN, while the HCG mode was comparable to the 
2x gain is HCG. The tradeoff is the effective-lower readout noise and doubling the signal 
output, while halving the dynamic range. 
 
Use the appropriate mode to either push the sensitivity (decreases the dynamic range) or 
increase the dynamics range (decreases the sensitivity). The choice depends upon the object 
being images. Remember, Experiment. 
 

 
  

HDR is not available in the DS10CTEC camera. 

The following images illustrate the benefits of using HCG. In both images the exposure time 

was the same. The left image had LCG checked, while the right image has the HCG checked. 

 

         

     LCG              HCG  
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Cooling   

 
The 12V power cable must be attached to the DS10C TEC for the FAN and TEC features to be 
available. 
 
The Mallincam SkyRaider DS10C TEC comes with both a Fan, which can aid in cooling the 
camera when conditions are getting warm, and a TEC (Thermoelectric Cooler).  
 
The internal TEC unit is controlled with the MallincamSky software, allowing you to set the 
temperature. The SkyRaider DS10C TEC is designed for consistent, reliable Deep-Sky imaging 
at up to about 200C to 300C below the ambient temperature.   
 

 
 

Activate TEC by clicking the radial On button, then enter a Target Temperature oC value into 
the box (0oC is recommended, but some users are having the best success at -10oC). It is also 
recommended that the temperature value you enter in the box be no more than 45oC cooler 
than the ambient temperature the DS10CCTEC camera is sitting in.  
 
The ideal temperature choice will of cause depend upon many factors (ambient temperature, 
humidity, gain…), so you will need to experiment with your system. I was having best success 
at about -10oC with the gain set at 400. 
 
So, if the temperature is 30oC outside where the camera Is located, then set the Target 
Temperature to 0oC and then left-click on the Apply button to activate it (the FAN and TEC 
lights on the back of the camera will light up to indicate activation). 
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Once activated, it will take a few minutes for the temperature inside the SkyRaider 
DS10CCTEC to stabilize. The power capacity that the TEC inside the camera is currently using is 
displayed inside the TEC box.  
 
 
 
 
When the temperature is stabilized, this power reading should be well below 100%. 
 
 
If the power continues to remain at 100%, then change the Target Temperature’s value to a 
lower number (as too much effort is used to cool the camera). 
  
 
MallincamSky displays the current temperature of the SkyRaider DS10CCTEC on the bottom 
right corner of the screen. 
 
  
 
 
If the Fan is turned Off, then TEC is automatically turned off, and the Fan automatically turns 
to High when TEC is activated. If you are finished using TEC, leave the fan On to allow sensor 
to climatize itself to the current temperature. 
 

Remember that it is wise to create Dark Frames with TEC on if you are using TEC (this way you 

have a set with TEC and a set without TEC). Most expert imagers will even create a set of dark 

frames for a specific range of temperatures. But, hey that is up to you and how much effort 

you need to put into the preparation for that perfect image. 

If you save an image in FITS format, the temperature reading is included in the FITS Header for 

that image. 

For our American friends, you can change the Temperature unit form Celsius to Fahrenheit in 

the Options->Preference->Misc location. 

 
 
When finished for the evening, turn off the TEC prior to turning off the camera to 
allow it to naturally climatize itself to the current temperature. 
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Heating   

 
This control is not available with the DS10CTEC camera. This control allows you to slowly heat 
up the camera around the sensor to help reduce (remove) any fogging that might occur due to 
a humid environment. Use the slider to increase the heat setting or disabling it to turn it off. 
 

 
 
 
 
 
 
Sharpen   

 
This control allows you to sharpen the image. Remember that being too aggressive will induce 
some rough edges around your images. Just use the slider to sharpen the image from none to 
500%. When the Sharpen slider is moved to 0, then the sharpen algorithm is disabled. 
 

 
 
 
 
 
 

Misc  

 
Currently this control will only allow you to display the image in its inverse. That is, a white 
background with black stars. Just use the check box to activate and uncheck to return to 
normal image mode. There is also a low noise filter which may help if you are obtaining some 
fine-grained noise, but currently this feature is not active with the DS10 camera. Just 
experiment with this to see if it helps (or not) with your image.  

 

 
 
Debayer allows you to choose the debayer algorithm for DS10CTEC to use working with the 
image. 
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This is the easiest method we can use to demosaic a Bayer image. The concept 
behind this method is that since there is a very high probability that the value of a 
missed pixel is very similar to the value of its existing adjacent pixel.  We can 
interpolate the missing value in each channel by taking the average of its adjacent 
pixels.  
 
This is the default algorithm used and we recommend leaving the DS10CTEC with this 
process. 
 

 
 

Since most of the artifacts are on/near the edges, instead of blindly doing bilinear 
interpolation you do edge aware interpolation. For example, below if you are trying 
to find the green value at position B, you will only take the average of the green 
values with smaller gradient. i.e., first you compute the difference of horizontal green 
values and vertical green values and pick the option with lower difference and take 
the average of those two green values.  
 

 
 

The VNG method stands for Variable Number of Gradients. It works on a 5x5 pixel 
neighborhood around each source pixel. The method first computes intensity 
gradients in the eight directions around the current pixel. Then it computes a 
threshold and takes only gradients below this threshold. In the last step, the missing 
color components for the pixel are interpolated from neighboring pixels along the 
directions of the remaining gradients. This method preserves edges much better than 
bilinear interpolation. It also produces much less color artifacts and less chrominance 
noise. 
 

 
 

(AHD) is widely used in industry, but older and slower algorithm. It selects the 
direction of interpolation so as to maximize a homogeneity metric, thus typically 
minimizing color artifacts. 
 
There is also a low noise filter which may help if you are obtaining some fine-grained noise. 
Just experiment with this to see if it helps (or not) with your image. 

 

 

Bilinear  

Edge Aware 

Variable Number of Gradients 

Adaptive Homogeneity Directed 



M A L L I N C A M S K Y  D S 1 0 C T E C  U S E R  M A N U A L  

 

168 

 

 
Preset  

 
The Preset control allows you to: 
 
Load a previous set of camera control parameters or Save the current camera control 
parameters for another session. The parameters include most of the settings in the SideBar 
including the Rectangle Regions of Interest. 
 
 
 
 
 
 
 
 

 
The Drop-Down control provides a list of previous 
(if any) saved parameter settings. Just select the 
parameter session that you require from the list. 

 
 

Left-Click on the Load command and it will load the control parameters 
from the above file in the Drop-Down List. 

 

 
Left-Click on the Save command and MallincamSky will open a window 
that will allow you to give a name to the current sessions, and then will 
save the current camera parameters under that name (see Management 
command below). 
 
 

Give a Name that is easy to determine 
what the parameters in the file contain. 
That is, choosing a name like Eagle 
Nebula Dark Skies, would indicate that 
the parameters in the File are designed 
for the Eagle Nebula when you have 
great dark skies.  

 
 
Left-Click on the Overwrite command and it will overwrite any setting 
changes you made to the current parameter file. 
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Left-Click on the Management command and a Management Dialogue 
Window will open. 

 
 
  

 

 

 

 

 

 

 

 

 

 

 

This Dialog Window will allow you to: 

 

• Rename the Preset File name 

• Remove the Preset File from the computer 

• Re-order how the Parameter names appear in the list.  

The Management Dialog will also allow you to export all the 

Parmeter Files to a *.pgt file, so that you can send this *.pgt 
file (which contains all of your parameter files) to a 
colleague. 
 
The Management Dialog will also allow you to import a 
friend’s set of parameter files (single *.pgt file which contains 
all of their parameter files) into your MallincamSky folders. 

 
 
When you import a set of parameter files into your system, it will overwrite all your Preset 
files. So, use caution. See Hint below. 
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After you have created a list of parameter files that you are using. Save them in a Preset File 
Folder (pick a location and name for This Folder such as Preset Files) on your computer under 
a name that indicates that these files are yours (such as Michael’s SkyRaider-DS10CCTEC 
Preset Files for New Hamburg).  
 
This way you can save another set of Preset files for another SkyRaider Camera In the same 
folder (Preset File Folder) this way you can load Preset files for a specific camera.  Also, you 
can also include other colleagues Preset files in the same Folder (Anita’s SkyRaider-
DS10CCTEC Preset Files for Toronto). This allows you a method to reload your Preset files 
after trying colleagues (and not have them overwritten). 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

 

 

 

 

 

 

 

Preset File Folder 
 
➢ Michael’s SkyRaider-Dsc Presets File for New Hamburg 

➢ Michael’s SkyRaider-DS10CCTEC Presets File for New Hamburg 

➢ Michael’s SkyRaider-Dsc Presets File for Mount Forest 

➢ Michael’s SkyRaider-DS16CTEC Presets File for Mount Forest 

➢ Anita’s SkyRaider-Dsc Presets File for Toronto 

➢ Anita’s SkyRaider-DS432CTEC Presets File for Toronto 

Michael’s SkyRaider-DS10CCTEC Preset 
File for New Hamburg 

 

➢ Eagle Nebula Dark Skies 

➢ Eagle nebula Light Skies 

➢ Focus and Go to Parameter 

Mic 
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C5: Installing Optional Software 

 
 
 
 
 
 

Visit the Software Downloads Page in the Support Tab located on the website: 
www.mallincam.net 

 

 
 
Locate the latest version from the list and Click on the Blue Click Here Button to download the 
Drivers and MallincamSky Software for a Windows PC. 
 

 
 
If you have a Mac, or Linux computer, there are drivers and software located in the 
downloaded zip file. 
 
Your Browser should download a zipped file called mallincamsky2019mmdd (the last eight 
numbers may be different as they will change if software is updated) 
 
Place your mouse on the zipped file, Right-Click to pop-up an Action Window, and choose 
Extract All … 
 
Just Click on the Extract button when the next Window pops-up. Windows should now open 
the actual folder that contains the software to install. 

 

 
 
 

 

Chapter 

5 
 

 

http://www.mallincam.net/


M A L L I N C A M S K Y  D S 1 0 C T E C  U S E R  M A N U A L  

 

172 

 

Double-Click on the extracted folder to open it up, revealing the main Driver and 
Software folder, Double-Click on this to open it up, revealing its contents. 
 

 
The ASCOMMallincamSetup contains the ASCOM Drivers for the camera. 
The MALLINCAMDshowSetup contains the Direct Show Drivers for the camera. 
The MALLINCAMSKYSetup contains the camera control software. 
 
 
Installing MallincamSky and its Driver  

 

Depending upon the version of Windows, you may again be asked for permission for it to 
install MallincamSky, DirectShow, or ASCOM. Just accept install, or if a blue Windows 
protected your PC popup appears, then click on the More info text.  Another Windows 
protected your PC screen will pop-up. Then select Run anyway 
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Double-Click on the MALLINCAMSKYSetup file and follow instructions to install the 
MallincamSKy software and drivers onto your computer: 
 
 
The following MallincamSky Setup Screen will then appear: 
 

 
 

 
Click on Next to start the installation process. 
 
 
The installation program now wants to know where you would like to install the software. 
Either choose your own location or select the default.  

 

 
 
Click on Install to proceed. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Step 2 

Step 3 

Step 1 
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The MallincamSky Software will take about a minute to be installed. When completed, the 
following screen will appear: 
 

 
 

Click on Finish, and the MallincamSky Icon will appear on your screen. 
 
 
MallincamSky and its drivers are typically all you need to install to control the DS10CTEC 
camera, but if you would like to have other image programs control of the DS10CTEC then you 
can install two other optional drivers: ASCOM and DIRECTSHOW. 

 
Installing DirectShow Driver 

 
DirectShow drives provide an alternative way for third party software to control most (but not 
all) of the aspects of the SkyRaider camera. Look for the Mallincam name in the camera 
selection routines of those software packages. 
 
 
Double-Click on the MALLINCAMDshowSetup File. 
 
Windows may display a warning asking for permission to run the program, if it does, select 
YES to continue. 
 
The following MallincamSky Setup Screen will appear: 

 

 

Step 1 

Step 4 

Step 5 

Uncheck the Run 
MALLINCAMSKY 3.7 

checkbox 
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Click on Next to start the installation process. 
 
The install Location Window will open, asking for the Destinations folder to install the drivers. 
We recommend using the default location. 

 

 

Click on Install to start the installation process. 

The final window will appear. This window just wants to inform, and have you acknowledged 
that the setup is completed. 
 

 

 

Click on Finish to close the process. 

 

 

 

 

 

 

 

Step 2 

Step 3 

Step 4 
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Installing Mallincam ASCOM Driver 

 

You must have already installed the latest ASCOM Platform on your computer (www.ascom-
standards.org). 

 
 
Double Click on the Driver to install it onto your computer system (Windows). Depending 

upon the version of Windows, the following screen might appear.  

 

Click on the Run Button. The following Window should now Pop-Up. 

 

Click on Next to Continue. The License Agreement Window should now appear. 

 

Step 1 

Step 2 

Step 3 

 

http://www.ascom-standards.org/
http://www.ascom-standards.org/
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Click on the ‘I accept the agreement’ Radial Button, then Click on Next. The Ready to Install 

Window will appear. 

 

 

Click on Install to install the ASCOM Driver.  

 

 

The installation process will provide you with the final Pop-up window to inform you that the 

installation was successful. Click on the Finish Button to acknowledge. 

 

 

 

 

 

 

 

 

 

 

  

Step 4 

Step 5 

Step 6 
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C6: Using Third Party Software 

 
 
 
 
 

Keeping in mind that the SkyRaider DS10CTEC is a video imager rather than a dedicated single 
shot camera, we can control the camera with other 3rd party software products via the 
DirectShow driver or the ASCOM driver.  

 
 
 
 
 
 
A Primer on Native Drivers versus SDK versus ASCOM 
 
One of the most common questions that I receive is related to ASCOM vs MallincamSky or 
NINA versus MallincamSky or SharpCap versus MallincamSky. So, I put together this simple 
primer to help answer these questions. These questions are valid as the versatility of Rock’s 
SkyRaider cameras, do provide so many options for you to experiment with. First, I would like 
to remind everybody that Rock’s SkyRaider series was designed from the ground up for Real-
Time-Video-Imaging. Every aspect of these cameras, from its built-in firmware (scientific 
quality components) to its control software (MallincamSky) was designed for Real-Time-
Video-Imaging. But its versatility (and forethought) has allowed for other imaging techniques 
to be enjoyed, so let me explain how this can happen. 
 
 
Real-Time-video-Imaging 
 
The SkyRaider’s hardware (firmware) is directly accessed through the software MallincamSky 
using an Operating System level Driver. This communication level provides direct access to 
the SkyRaider’s hardware routines and real-time-imaging and control processes. 
MallincamSky is specifically written to access the internal processes for each of the specific 
SkyRaider Cameras, that is why you choose the brand of SkyRaider from its camera List. 
Bottom line, MallincamSky provides the fastest possible and most efficient request/response 
throughput and thus the ultimate control of every process (notice the number of parameters 
you can adjust when using MallincamSky) that was designed and built into the SkyRaider 
camera. This is what the SkyRaider was designed to do, Real-Time-Video-Imaging with rea-
time tools such as Dark and Flat Field adjustments, video recording, and real-time Histogram 
adjustments. This process provides you, the user (and guests, both local and online), with 
almost immediate results when viewing objects from Deep Sky to local Planetary. This allows 
the SkyRaider series to be used for public star parties where results are presented in near real 
time and adjustment are seen as they happen. This is the design paradigm of Rock’s SkyRaider 
series of cameras. 
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Astro-Imaging 
 
There is a class of Camera Assisted Astronomers who want to work with computer automated 
long exposure imaging. They most like will be using 3rd party software such as NINA, Voyager, 
SkyX, or SharpCap that will both control their camera, mount, and other attached accessories. 
The software may be able to schedule a whole evening of image, from capturing Lights, Darks, 
Bias, Flats, Filter Wheel Control, Focus Control, and automated target acquisition with Mount 
Control all while the user sleeps or is relaxing away from the system. These specialized pieces 
of software will incorporate and integrate many different manufacturers’ hardware 
components into a seamless process. These 3rd part software packages will require access to 
the different hardware objects by interfacing with software layers that conform to (sometimes 
loosely enforced) Industry standards and protocols. Two of the currently major connection 
paradigms are using SDK and ASCOM (there are others coming down the pipeline).  I will 
discuss and introduce both the SDK and ASCOM layers in the paragraphs below. Just a 
reminder, ROCK has provided both of these software layers in his SkyRaider cameras, so users 
have the option of using the MallinCams in this arena. 
 
 
SDK 
 
This level (or layer) is a set of specific coded access routines (usually written in C++), these 
coded routines are typically referred to as SDK (Software Development Kit). These SDK 
routines are the layer of software that bridges the gap between 3rd party piece of software 
and the SkyRaider’s OS-level device driver. By definition, an SDK is a software-kit that includes 
instructions that allow developers to create and develop proprietary software applications 
using this kit. The SDK usually relies on what we call APIs (Application Programming Interface), 
which are purpose-built software routines for a specific use. When an SDK is used to create an 
application that must communicate to other applications, it includes a set of APIs for this 
functionality. 

In this Astro-imaging environment, the 3rd party software as mentioned above represents 
software programs such as SKYX, NINA, and others who have written "native Mallincam" 
drivers that access the SDK which Rock has freely provided. The SDK provides access to the 
processes inside the camera (through the OS-Level driver), but each 3rd party software does 
not know exactly what each type of imaging camera can or cannot do, so These 3rd party 
software programs will control all of the expected processes that any imaging camera should 
perform.  For example, if NINA or SKYX wants to adjust the gain of a camera, it will pass that 
request to the SDK for that camera, and the SDK for that camera will pass that request to the 
internal processes of the camera and the camera will perform that task. This is a win for the 
3rd party software as it indirectly has access to the internal processes of the camera and 
provides immediate responses. The issue or limitation is that the 3rd party software may not 
include most of internal processes or capabilities that make a camera unique. For example, 
The SkyRaider has Dark and Flat Field internal processes, this this is unique and if the 3rd party 
software does not include that in their programming, then those unique processes are not 
utilized and thus not available from those 3rd party software packages.  
  
To summarize these 3rd Party Software Applications, with their native drivers, can talk to 
Mallincam’s SDK, they can call specific and expected camera related, functions such as "set 
gamma" or "start exposure".  It is the SDK that turns those simple requests into a specific 
direct command that the SkyRaider understands. The SkyRaider may immediately respond or 
even return data back in response to that command. It is also the SDK that receives that 
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response and translates that back into something the specific Software Application can 
understand. But the 3rd Party Software Applications will/may not include all of the capabilities 
that the SkyRaider camera can perform (you may get a subset), just those that are required to 
access and control mainstream imaging procedures that is used by the 3rd party software. The 
bottom line, 3rd party software applications that utilize the SkyRaider SDK, get immediate 
control of the camera and its capabilities and thus complete throughput utilization of the 
built-in firmware, but for only those processes that the 3rd party software requires, not 
necessarily all of the capabilities of the camera. 
  
 
ASCOM  
 
Now an ASCOM driver is another layer of sitting on top of the SDK. ASCOM is a control design 
layer that requires a structured and restricted list of commands and properties (guidelines) 
that an application must use to operate and adjust the camera, telescope, or filter wheel. A 
camera’s designer, such as Rock and the SkyRaider series, will provide a ASCOM driver 
translates these functions and properties (as per the mandated ASCOM guidelines) into the 
appropriate calls to the SDK and, as explained above, the SDK in turn translates that and 
transmits that to the camera. What this means is that many application software companies 
can write a single procedure that can support any camera that provides an ASCOM driver 
without having to have specific knowledge of each and every one of those cameras. All that 
knowledge is hidden away by the ASCOM driver for that camera, which each vendor provides. 
The advantages are that a software program can access and control any camera (or other 
device) that provides an ASCOM driver. The disadvantage is that ASCOM has a restricted 
number of commands available for the software program, along with those commands are a 
required set protocols which must be followed.  The protocols dictate how the controls must 
be adjusted and can significantly reduce the throughput effectiveness (how long it takes 
before an image appears) of the camera, along with a significant reduction of all of the 
capabilities of the camera. On a good note, the ASCOM layer is always being enhanced and 
over the years it has started to incorporate more and more camera capabilities as hardware 
technology improves. 
  
To put this all together, the SDK and ASCOM layers provide access to the camera’s major 
controls, with each of these being limited to either the enforced layer protocols or the actual 
software design of 3rd party applications.  The result of these different layers is performance, 
since these limits do not exist in native drivers the dedicated software (MallincamSky) does 
not experience these issues (only hardware related restriction such as USB2 or USB3 
bandwidth, or computer processing powers). From a throughput and control aspect, the order 
of layer’s effectiveness from best to least are: Native (MallincamSky), SDK, and finally ASCOM. 
But as I have already mentioned. Rock has provided all three of these layers for you to use in 
your imaging journey. 
 
DirectShow 

 
DirectShow is a multimedia framework and API produced by Microsoft for software 
developers to perform various operations with media files or streams. Based on the Microsoft 
Windows Component Object Model (COM) framework, DirectShow provides a common 
interface for media across various programming languages and Software applications. 
DirectShow is what allows software such as OBS, AMCAP, SplitCam, etc. to display and control 
(limited) the SkyRaider series of Cameras. 
 

https://en.wikipedia.org/wiki/Multimedia_framework
https://en.wikipedia.org/wiki/Application_programming_interface
https://en.wikipedia.org/wiki/Microsoft
https://en.wikipedia.org/wiki/Software_developer
https://en.wikipedia.org/wiki/Software_developer
https://en.wikipedia.org/wiki/Microsoft_Windows
https://en.wikipedia.org/wiki/Microsoft_Windows
https://en.wikipedia.org/wiki/Component_Object_Model
https://en.wikipedia.org/wiki/Programming_language
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Using the Mallincam with 3rd Party Software Applications 
 
 
 
ASCOM Note 

When displaying images using third-party software of a color camera using RAW, the 
image will not appear in color (it can appear checkered). This is because Image data 
from colour cameras in RAW format always needs to be 'debayered' to obtain a 
colour image. 
 
 
 
Imaging in SharpCap 
 
Now this is the first generation of DirectShow/ASCOM driver interaction with Sharpcap and as 
such, not all the commands are perfected for user control. 

 
SharpCap can be obtained at http://www.sharpcap.co.uk/ 
 
Start SharpCap 
 

 

 
 
 
 
 
 
 
 

 

http://www.sharpcap.co.uk/
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Choose Cameras (DirectShow) 

 
From the Top Heading Tab, choose Cameras, then in the DirectShow Cameras heading, pick 
MALLINCAM. 

 
 
Once you have selected, the Mallincam Directshow Driver, SharpCap will display what the 

SkyRaider is imaging. 

 

The controls on the right of the screen (Exposure, Gain, Gamma, …) allow you to change the 

settings of the SkyRaider. 

If you cannot control the exposure from Sharpcap, use the Video capture Filter below to 

change the exposure. 

It takes a bit of practice to become familiar with the settings as these are more generic 

controls, the majority of the controls have their own scales (the exposure does not indicate 

seconds, but has an equivalent range from 0 seconds to 5 seconds). You will need to record 

those numbers to assist you. 
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SharpCap recognizes that the DS10CCTEC does have an extended mode for exposures that are 

over 5 seconds.  

To turn on the extended mode (over 5 seconds), then enable the LX Mode in the Options Tab 

on the Top of the screen. This lets the exposure slider now provide exposures over 5 seconds 

(even though you do not actually see the time on the slider). Disable LX mode to return to the 

5 second max exposure. 

Sharpcap will display the exposure you have set on the bottom of the SharpCap window after 

the first exposure is taken. 

SharpCap can Pop-Up the SkyRaider Video Filter (DirectShow control window).  Click on the 

Show Button in the Video Capture Control 

 

The Pop-Up Window gives you some familiarity with settings as it provides you with 

more comfortable units (exposure time in ms). 

 

You can choose the Exposure Tab in the Filter window to slide the Tab to match the 

exposure time in ms (divide by 1000 to get seconds).  

You can also Click on the Time setting on the right of the Slider to Pop-Up a window 

that allows you to directly enter in the time in ms. 

  

You can also control the Gain in the window. 
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The other Tabs in the Window will also allow you to adjust other settings in the SkyRaider 

Camera. 

 

Once you are comfortable with the settings, Click on the OK Button in the Properties window 

to close it. 

SharpCap will start the imaging process and will, on the bottom of the window, display 

information about the exposure and remaining time. You can watch the green status bar 

move to the right as the exposure is being taken. 

 

Choose Cameras (ASCOM) 

 
From the Top Heading Tab, choose Cameras, then in ASCOM Cameras, pick ASCOM 
Mallincam Driver. 

 
 
Once you have selected, the Mallincam ASCOM Driver, SharpCap will open a setup window.  

 

It is from here that you get to choose Bit Depth and Format. 

 

 



M A L L I N C A M S K Y  D S 1 0 C T E C  U S E R  M A N U A L  

 

185 

 

 

Raw Internal format: you will need to select Debayer Preview to On to see image in color 

 

 

The controls on the right of the screen (Exposure, Gain, Gamma, …) will allow you to change 

the settings of the SkyRaider. 

If you cannot control the exposure from Sharpcap, use the Video capture Filter below to 

change the exposure. 

It takes a bit of practice to become familiar with the settings as these are more generic 

controls, the majority of the controls have their own scales (the exposure does not indicate 

seconds, but has an equivalent range from 0 seconds to 5 seconds). You will need to record 

those numbers to assist you. 

SharpCap recognizes that the DS10CCTEC does have an extended mode for exposures that are 

over 5 seconds.  

To turn on the extended mode (over 5 seconds), then enable the LX Mode in the Options Tab 

on the Top of the screen. This lets the exposure slider now provide exposures over 5 seconds 

(even though you do not actually see the time on the slider). Disable LX mode to return to the 

5 second max exposure. 

Sharpcap will display the exposure you have set on the bottom of the SharpCap window after 

the first exposure is taken. 

SharpCap can Pop-Up the SkyRaider Setup (ASCOM control window).  Click on the Show Button 

in the Video Capture Control 
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This window will allow you to change the Format and adjust the Gain and Black 

Level. 

 

SharpCap will start the imaging process and will, on the bottom of the window, display 

information about the exposure and remaining time. You can watch the green status bar 

move to the right as the exposure is being taken. 

 

Imaging in MaximDL 
MaximDL is an image acquisition and composition software tool. 

 
Start MaximDL 

 

 
 
Click on the Camera Control Icon 
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Select ASCOM from the Setup Camera button. 

 

 
 

 
Now Click on the Advanced Button on the right-hand side and select ASCOM Mallincam 
Driver from the drop-down list. 
 

 
 

 
Now Click on the Properties button to open-up a Format and Bit Depth setup window. 
 

 
 

 
Choose your format and bit dept, then Click on OK to accept. Accept other Windows as well. 
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Now Select the Expose Tab on the Camera Control Window. 

  

 
 
Enter your exposure parameters and Click on the Start Button to image. 

 

 
 

Don’t forget to use screen stretch on your image. 
 

 
 

Depending upon your Format choice, you may need to debayer the image. 
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Sequence Generator Pro and SkyRaider DS10CCTEC 
 

Sequence Generator Pro is a software package that can execute complex sequences of 

capture events which will allow you to spend more time using and less time fighting with your 

equipment. You have lots of hardware that is sometimes difficult to get it all working together. 

Sequence Generator pro work with ASCOM-based SkyRaider DS10CTEC. 

 

Make sure you are using the latest version of ASCOM (both the ASCOM core and ASCOM 

Mallincam Driver). 

 

Start Sequence Generator Pro  
 

 

Select ASCOM Mallincam Driver as the camera in equipment profile. 

 

 



M A L L I N C A M S K Y  D S 1 0 C T E C  U S E R  M A N U A L  

 

190 

 

Select the required resolution and ensure that you are using Raw as the format. 

 

Your images will appear Black and White with a checkered look. This is normal if you are using 

a color camera since you will need your image processing software to debayer your saved 

images. 

Start Running Sequences based on your needs. 

 

 

If you are using Sequence Generator Pro then you will need to save flats, biases, and darks as 

you would with every other camera.  

 

 

SkyRaiderDS10CTEC 



M A L L I N C A M S K Y  D S 1 0 C T E C  U S E R  M A N U A L  

 

191 

 

The SkyX and the SkyRaider DS10CCTEC 
 

The SkyX is a telescope control software package, which can perform many tasks that are 

related to controlling a telescope. One of the capabilities is using a camera to assist in aligning 

(T-Point) and locking onto objects using a camera. 

 

We can have The SkyX use the Mallincam DS10CCTEC for this process (once camera is added). 

 

Click on Camera Setup from the Camera Tab in SkyX. This will open The Imaging System Setup 

Window. Click on Camera Setup drop down in this window. 

 
 

Select Choose from the Drop-Down list.  

 

 

SkyX will open a list of supported cameras, choose Mallincam 

SkyRaider from the list. Hit the OK button.  

 

Select Settings… from the Camera Setup drop down list. 

 

Select your Mallincam Camera from drop down list and hit OK. 

 

 

 

 

 

 

Select Connect from the Camera Setup drop down list (the fan on the camera should start). 
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The status should now say Ready as the Status: in the Setup Window. You can now close this 

window. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Now from the Camera tab you can entering an 

exposure time, binning amount, stream type (single 

exposure), frame type (light), saving parameters. 

 

Once you have the settings selected, Click on the 

Take Photo button and SkyX will take a photo. 

 

 

 

 

 

 

 

 

 

 

 

 

 

A Quick frame viewer will popup displaying the FITS image for you. Recall that RAW FITS 

images are in Black and white and will needed to be debayered to see color. 

 

The LTI version of SkyX automatically debayers the images. 
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Using SKYX along with MallincamSky 

 

Start MallincamSky, but DO NOT select the DS10CTEC camera to activate it 

 

 

Connect the DS10CTEC to the SKYX Camera control and activate it by clicking on the Connect 

Button. 

 

 

SKYX now controls the DS20CTEC. 

 

 

Use SKYX to perform a Closed Loop Slew to an object (SKYX is using the DS10CTEC to take 

images) 

 

Once telescope has object centred, disconnect the DS10CTEC from the Camera driver in SKYX 

by clicking on the Disconnect Button. 

 

 

Now activate the DS10CTEC in MallincamSky by clicking on the DS10CTEC in the Camera List. 

 

 

MallincamSky now controls the DS10CTEC. 

 

 

Take your images with MallincamSky 

 

 

When ready to slew to another object 

- just Right-Click on the Video [DS10CTEC] window and choose Close 

(MallincamSky loses control of DS10CTEC). 

- Re-activate the camera in SKYX by click on Connect button (SKYX now controls 

the DS10CTEC) 

- Closed Loop Slew to next object 

Repeat as necessary. 
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Nighttime Imaging ‘N’ Astronomy (N.I.N.A.) 
 

N.I.N.A is a complete freeware complete system control software package, which can perform 

many tasks that are related to controlling a telescope, filter wheel, Camera, ….  

   

N.I.N.A. version 2.0 and higher include the Mallincam SDK routines, thus making it a powerful 

program to control the SkyRaider series of camera and providing more control options than 

using ASCOM. 

 

When started, choose Equipment and Camera and from the drop-down list select the 

Mallincam Heading. 

 

 
 

From the Mallincam Heading locate and select the SkyRaiderDS10CTEC camera. 

 

Click on the On Button in N.I.N.A. to activate the camera. (You will be presented with the 

success connected screen. 
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Make any camera setup adjustments, and heater/cooler activation you require. 

 

 
 

 

Set the exposure time and required binning in the imagining menu in N.I.N.A. 

 

 
 

Create a sequence in sequencer and start taking images. 

 

 

Remember your can have N.I.N.A automatically debayer your images and you can choose the 

format in which you would like the images saved in. 

 

Don’t forget to stretch the image when viewing its image. Otherwise, the image will appear 

too dark). 
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C7: Upgrading, Explanations and 

  Q&A  

 
 
 

This chapter deals with issues and questions that you may have after using MallincamSky for a 
while or have encountered a problem that you do not know how to resolve. 

 
How do I 

 
How do I get rid of the Green Exposure Rectangle? 

 
First remember the Green Exposure Rectangle is only used for the auto-exposure process, but 
it can be annoying when you are imaging.  
 
➢ The way to remove it from the Video Window is to uncheck the auto-exposure box. 

 
If you require the Exposure & Gain Control to be expanded and auto-exposure turned on, but 
still do not want the Green Rectangle in the middle of your screen, try this. 
 
➢ Choose Fit to Window from the Zoom Drop down Box (on the Icon Tool Bar). Now 

just drag the Green Rectangle (Left-Click and Hold technique) to the lower left of the 

window. 

➢ Next grab one of the corners of the Green Rectangle and drag it to the matching 

corner of your Video Window. Next, grab the opposite corner of the Green 

Rectangle and drag it to the same location as the first corner. This will make a zero-

size rectangle.  

How do I Select a part of the Image and Zoom in? 

 
➢ In Video Mode, expand the ROI control (a Blue Rectangle should appear around you 

image). Using the Left-Click Hold and Drag technique, maneuver, and size the Blue 

Rectangle so that it encloses the area you are interested in. Left-Click on Apply and 

watch the part of the image in Blue Rectangle, be the whole image in the Video 

Window.  

➢ Now, Left-Click in the Blue Rectangle, and use the scroll wheel on your mouse to 

enlarge or reduce the image (you can also use the Fit to Window control on the Icon 

Tool Bar). 

➢ Left-Click on Defaults to get back to Full screen. 

➢ See ROI section in Manual for creating an ROI in Trigger Mode. 

 

Chapter 

7 
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How do I automatically save 1 image every 30 seconds? 

 
➢ Choose the Time-Lapse (Auto Capture) from the Capture Menu on the Top Menu 

Line. Now determine your naming convention and location. 

➢ Enter 30 in the Time slot 

➢ Enter the total number of images you would like (or leave unchecked, and you will 

manually stop the process when you are ready). 

➢ Left-Click on OK 

 
At the bottom of the MallincamSky Window, a running count will be displayed. 
 
➢ Left-Click on Stop Time-lapse (Auto Capture) to stop the process. 

 
How do I adjust the brightness in my monochrome SkyRaider? 

 
You will have noticed that the Brightness command in the Color Adjustment control is 
deactivated. You can use the Gamma command (moving it to the left will brighten the whole 
image, but the better control is the Histogram command in the Side Bar.  
 
Moving the Left Marker Line or the Right Marker Line (or a combination of both) to the left 
will brighten up your image in a more controlled manner. 

 
How do I Broadcast my image onto LiveSkies? 

 
As a direct way is not yet available, you will need to use a third-party software to assist you. 
 
Obtain one of the following: Open Broadcast Software, SplitCam (different opinions on which 
is the best, it becomes a personal preference). Each of these software programs will allow you 
to capture what is happening on your computer screen. The software packages also act as a 
webcam to LiveSkies.  
 
Therefore, whatever screen image these software packages are capturing, will display on 
LiveSkies as a webcam image. 
 
See Setting up to Broadcast on LiveSkies in the Appendix for more detailed instructions. 

 
Can I Use MallincamSky with One SkyRaider and Auto-Guide with another? 

 
Yes, you can open multiple instances of MallincamSky, plus you use DirectShow, WDM or 
ASCOM with the second SkyRaider. 
 

 
How Do I Pause the Video? 

 
You can Pause or Resume the live video by either choose Setup>Pause from the Top Menu 
Line, or even easier, just press on the pause key on your keyboard. 
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How do I Undo an Operation? 

 
On the SideBar, there is an Undo/Redo Tab; Just Left-Click on the Tab and it will open with a 
list of all the operations you have performed on your Image (not Video, you cannot undo 
video operations such as contrast). 

 

 
 

Just Left-Click on the location before the operation you would like to undo and MallincamSky 
will revert the image back to that step. 

 
How do I make my ROI the whole Image Again? 

 
Just Left-Click on the Defaults Button in the SideBar’s ROI control. Note, by changing the ROI, 
the Dark Fields will be removed from the SkyRaider. 

 
How do I Turn Off Dark Field correction? 

 
Just Left-Click in the Enable box to remove the check mark in the Dark Field correction control 
on the SideBar. Place a checkmark back in the Enable box to reactivate Dark Field correction. 

 
How Do I take Another Dark Field? 

 
Just retake the Dark Fields and it will overwrite the previous ones.  
 
Note: If you save (export) the current Dark Fields, you will have the option of bringing them 
back in at a later date. 

 
My ROI Window is Black? 

 
You must wait until the next exposure until the ROI Window gets filled. This can happen on 
longer exposure times. 

 
What is the Storage Temperature for the Mallincam? 

 
All MallinCam cameras are of industrial design and use industrial components which 
makes them professional instruments in sense. 
 
All MallinCam can be stored down to -35oF to +120oF (-37oC to 49oC). 
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Upgrading my SkyRaider Camera Software 
 
Rock has his software engineering team always looking at improving the software to make it 
work better for you.  Once an update is made available, you will be notified on the Mallincam 
Groups website: https://groups.io/g/MallinCam/topics. 
 
There are a variety of ways of updating the software, but the following method seems to have 
the best success rate when working with Windows. 

 
Uninstall SkyRaider Software 

 

You can use Windows Uninstaller process located in the Control Panel to uninstall both 

MallincamSky and DirectShow. But, if you are unsuccessful, then the following technique will 

also work. 

 

• Unplug the SkyRaider Camera from your 

computer. 

• Locate the MallincamSky Icon on your Desktop and 

Right-Click on the Icon to open-up a selection window.  

• In this window select Open file location 

Windows will then open up the File folder that contains the 

software and drivers from MallincamSky. 

 

 

 

We want to jump back one folder (since this contains the Uninstall software for 

MallincamSky). 

• With the folder still open, just Click on the word MALLINCAMSKY located in the 

folder address (see above image). This will take us back one folder. 

Step 1 

 

https://groups.io/g/MallinCam/topics
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• We want to run the program uninst.  So, Double-Click on the program name uninst 

and follow the instructions as Windows uninstalls MallincamSky. 

 

 

 

 

 

 

Once MallincamSky is uninstalled, Windows will take you back to the MALLINCAM folder. This 

Folder may be empty, or if you have also installed the Mallincam DirectShow drivers you will 

see a folder named MALLINCAMDshow in the window. 

 

If you did not install the DirectShow drivers then jump to Step 3, else follow Step 2 to 

uninstall the DirectShow drivers. 
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Uninstall SkyRaider DirectShow Drivers 

 

Continuing from Step 1, you should have the MALLINCAM folder Windows open with the only 

file folder named MALLINCAMDshow displayed. 

 

 

 

 

• Double-Click on the folder name to open it up. 

Window will then open-up the MALLINCAMDshow folder displaying its contents. 

 

• Again, there is a program named uninst, Double-Click on the uninst program name 

and follow instructions to uninstall the DirectShow drivers. 

  

Once the DirectShow drivers have been uninstalled, Windows will take you back to the 

MALLINCAM folder to show you that it is empty. 

 

Step 2 
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If you did not install the ASCOM drivers, then jump to STEP 4. 

 
Uninstall SkyRaider ASCOM Drivers 

 

This step is extremely easy as ASCOM will automatically uninstall the previous drivers when it 

installs the latest drivers, so just follow the instructions above in Section 7 of the User Manual 

on installing ASCOM drivers.  

 

 
Finish the Uninstalling Procedure 

 
• This is an especially important step as it clears out the Windows registries. Reboot 

your computer via the restart option. 

Now, if you haven’t already done so, download and install the latest version of MallincamSky, 

the DirectShow, and the ASCOM drives at www.mallincam.net. (Note: you want the latest 

version) 

 

 

Do not forget to plug back in the SkyRaider camera after installing the software. 
 
 
 
 
 
 
 

 

Step 3 

Step 4 

 

http://www.mallincam.net/
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Hot-Keys available to MallincamSky 
 

 
 

Command Location Function 

Ctrl-SCROLL WHEEL Main Window Zoom IN/OUT 

Ctrl-A Main Window Selects currently displayed Image 

Ctrl-B Main Window Opens Browse Window 

Ctrl-C Main Window Copies Selected image (see Ctrl-A or Image Select) to 
Windows Clipboard 

Ctrl-D Main Window De-deselects currently displayed image (see Ctrl-A or 
Image Select) 

Ctrl-H Non-Live Image 
Window Tab 

Opens Histogram Window 

Ctrl-I Main Window Opens Image Folder 

Ctrl-O Main Window Opens Image 

Ctrl-P Main Window Opens Preference Window 

Ctrl-R Main Window Opens Record Folder 

Ctrl-S Main Window Opens Save As Window 

Ctrl-T Main Window Opens Thumbnail Display Window 

Ctrl-V Other Software Saves currently copied image (see Ctrl-C) 

Ctrl-W Main Window Closes Current Window 

Ctrl-X Other Software Removes currently copied image 

Ctrl-Num(*) Main Window Image Size to Best Fit 

Ctrl-Num(/) Main Window Image Size to Actual 

Ctrl-Num(-) Main Window Decrease Image Size 

Ctrl-Num(+) Main Window Increase Image Size 

Ctrl-Num(4) Main Window Set Image Size to 25% 

Ctrl-Num(5) Main Window Set Image Size to 20% 

Ctrl-Num(2) Main Window Set Image Size to 50% 

Ctrl-Num(3) Main Window Set image Size to 33% 

Ctrl-Num(0) Main Window Set Image Size to Best Fit 

Ctrl-Shift-B Static Image 
Window 

Set to Binary 

Ctrl-Shift-C Static Image 
Window 

Crop Image after using Image Select 

Ctrl-Shift-I Static Image 
Window 

Opens Image Enhancements Filters Window 

Ctrl-Shift-M Static Image 
Window 

Opens (Hidden) Measurement Window 

Ctrl-Shift-Q Static Image 
Window 

Opens (Hidden) Histogram Equalization Window 

Ctrl-Shift-R Static Image 
Window 

Set Image Range 

Ctrl-shift-T Static Image 
Window 

Starts/Stops Stitch Process 

F1 Main Window Opens up Generic Help Manual 

F5 Browse Window Refresh 

F6 Main Window Makes Video Window Active 

F7 Main Window Activates/Deactivates Auto Capture Sequence 

F8 Main Window Performs Image Capture 

F9 Main Window Starts/Stops Video Recording of Image 

F10 Main Window Starts/Stops Batch Record Function 

Esc Main Window Enables/Disables Video image being Full Screen 

Delete Folders Deletes Selected File 

Pause ST4 Test Starts/Stops guiding process 
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First Aid for the SkyRaider Series 

 
When I click on the SkyRaider camera from the Camera list, a message pops up saying 

Failed to Start: SkyRaider 

 
There is an issue establishing full-time communications with the camera. This can occur for a 
variety of reasons but the most common one is that the cable is too long for the USB port on 
that specific computer to establish the correct timing protocol. This is more so with USB 3.0 
devices. 

 
Recommended solution: if you need to use a longer length of USB 3.0 cable for the DS10C 
TEC, then there are two options: 
 
➢ Connect a powered USB 3.0 hub to the computer and connect the USB cable 

between the hub and the SkyRaider camera. 
➢ Connect an active (not passive) USB 3.0 extension cable between the camera and the 

included USB 3.0 cable. Something along the lines of the Tripp-Lite USB 3.0 
SuperSpeed Active Extension Repeater Cable 

 

 
When I try to connect I receive message “Catastrophic failure (Exception from 

HRESULT:0x8000FFF (E_UNEXPECTED))” 

 
This message indicates that something has blocked or overwritten the driver. Installing 
another driver or even a major Windows update has played havoc with the original SkyRaider 
Drivers. 

 
Recommended Solution: Uninstall the current driver through the Control Panel (or if you 
cannot find it in the Control Panel check out the c:/PROGRAM 
FILES/MALLINCAM/MALLINCAMSKY folder, there is a program called uninst. Double-Click on 
uninst to uninstall MallincamSky and its drivers). 
 
Once uninstalled, reboot your computer, then reinstall MallincamSky again. This should fix the 
issue. 

 

 
All I see is a White image 

 
Recommended Solution: Move Gain to the extreme Left (1).  Ensure automatic exposure is 
off. Make sure you are in Video Mode. Move exposure to minimal value say 10 ms. Now 
slowly cover the telescope to see if the image darkens up to black as you completely cover up 
the telescope. If this occurs, then SkyRaider is working properly so you need to check your 
telescope and focus setup. 

 

 
The computer keeps beeping when I plug in the USB 3.0 cable 

 
Recommended Solution: The computer is not providing enough power from the USB 3.0 port 
for the camera’s transmission. Inset a powered USB 3.0 hub between the computer and the 
camera.  
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MallincamSky acts Strange After Update 

 
Recommended Solution: Reset Mallincam Sky to Default 

Factory Settings  

Go to Preset and Click on the Load Button. 

 

How do I Optimize my Computer? 

 

Recommended Solution:  Optimizing your windows computer sometime is a never-ending 
process but visit the website: 
  
https://www.youtube.com/watch?v=Hdb4iybN8gg 
 
for some great suggestions on how to optimize your computer. 
 
 
To summarize as per the research done by Doug Murphy 
 
Add as much RAM as you can into your system. 
 
Settings/System/Privacy Settings 
General: all off  
Location: all off  
Camera: all off  
Microphone: yes (for messaging, voice recorder)  
Notifications: off  
Speech: ignore  
Account info: on 
Contacts: off 
Calendar: off 
Call history: off 
Email: on 
Tasks: off 
Messaging: off 
Radios: on (for Bluetooth) 
Feedback: basic/off/never  
 
In background apps, leave on alarms and clock, photos, settings, sticky notes, voice recorder 
(need for broadcasting)  
 
  

https://www.youtube.com/watch?v=Hdb4iybN8gg
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Stacking is going terribly slow or Stops Completely. 

 
The reason for the slowing or freezing of the stacking process is not completely understood, 

but it is encountered by many processes that task the usb and video processes of computers. 

This problem is experienced by many video gamers and the solution that resolves this problem 

is to select only 1 or 2 of the CPUs running the program. The work around, is to tell 

MallincamSky to use only 1 processor rather than all of them. 

 Recommended Solution:   

Start MallincamSky 

 

 

In this Step we want to activate the Task Manger. There are a variety of ways to perform this 

task, but I find that the CTRL-ALT-DEL method is the fastest. 

Press and Hold the CTRL-ALT-DEL buttons at the same time to pop-up the Control Window. 

 

Step 1 

Step 2 
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Using your mouse, Choose Task Manager from the list. 

This will open up the task Manager Window. 

 

Locate and Right-Click on MallincamSky Process located in the Task Manager. This will open 

up a small Selection Window, Click on Go to details in that selection window. This selects the 

Details Tab in the Task Manager. 

 

 

 

Step 3 

Step 4 
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In the Task Manager Window locate and Right-Click on the mallincamsky.exe file and another 

selection window will appear, choose Set affinity from that list. 

 

This will pop-up the Processor affinity window. 

 

Uncheck <all Processors> 

 

Then Check a processor of choice (I usually select CPU 5), then Click OK to return to the task 

manager window.  

 

Close the Task Manager Window  

Note: you will have to repeat this every time you restart MallincamSky, as windows does not 

remember you selecting 1 processor from the Task Manager. 

 

Step 5 

Step 6 

Step 7 

Step 8 
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I see a Pink Floyd Kaleidoscope effect on my Screen 

 

This effect has to do with star alignment difficulties when stacking images. You need 

bright stars to get a successful frame alignment. In other words, increase gain or 

increase exposure or re-adjust histogram to deliver a brighter image. Also, investigate 

adjusting the GAMMA and Contrast.  

 

 

 

 

Some users have seen this occur when they use DeepSky to align and have had some 

success by choosing Planet rather than DeepSky in the Live Stack Type checkbox. 

 

 

 

I get the following message when using Dark: “Failed to import, mismatch” 

 

The binning you used to save the Dark Fields does not match your current binning 

setting. Just ensure that they are the same.  
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The SkyRaider is listed as Westbridge or Driver will not Connect 

 

When attempting to use MallincamSky, the camera is not available even though it is 

attached. When checking Device Manager, the camera is not listed under the camera 

section, but appears under Other Devices as WestBridge. The camera is also not 

listed in the MallincamSky. The application displays a message to connect a device 

instead. 

 

This issue occurs as a result of a failed USB configuration, typically due to shutting 

down your SkyRaider camera while the update is being applied in the background (un 

beknown to you) or Windows thinks there is a Driver Signature issue. This issue 

occurs with many USB devices but is loves to occur with video cameras. There are 

Three Steps you can try; each one goes deeper into Windows to help alleviate the 

issue. Just move through the steps until MallincamSky works with the driver. 

The solution - Step 1: 

• Hold your breath. 

• Unplug the SkyRaider 

• Uninstall MallincamSky, DirectShow (if installed), ASCOM (if installed).  

• REBOOT your computer 

• Reinstall MallincamSky (ect). 

• Plug back in your Camera. 

• REBOOT your computer 

• Check it out 

• Breath 
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The solution - Step 2: 

If Westbridge still appears, then repeat, but after unplugging the SkyRaider, follow 
the following instruction. 
 
Use Google and search “Using Device Manager to Uninstall Devices and Driver 
Packages” and following instructions on how to remove the USB device driver. 
 
A good site with step-by-step instructions is: 
 
https://www.addictivetips.com/windows-tips/uninstall-a-usb-device-windows-10/ 
 
 

The solution - Step 3: 

 

If removing the drivers did not help, there is an issue with Windows and the driver 
Signature (the internet is not sure why some computers have this issue and others do 
not, it may be related to the USB hardware ports used by that particular computer. 
Anyway, we are just going to tell Windows to not check for the Signature. 
 
This is the most extreme fix and will require you to REBOOT your computer into a 
Windows configuration Mode, so you can set the Signature setting to ignore. 
 
The following website provides step-by-step instructions for you to follow: 
 
Permit Windows (10/11) to not check for driver signatures via: 
 
https://gearupwindows.com/how-to-disable-driver-signature-enforcement-on-
windows-11-10/ 
 
 
  

https://docs.microsoft.com/en-us/windows-hardware/drivers/install/using-device-manager-to-uninstall-devices-and-driver-packages#:~:text=First%2C%20open%20Settings%20(you%20can,list%20of%20programs%2C%20select%20uninstall.
https://docs.microsoft.com/en-us/windows-hardware/drivers/install/using-device-manager-to-uninstall-devices-and-driver-packages#:~:text=First%2C%20open%20Settings%20(you%20can,list%20of%20programs%2C%20select%20uninstall.
https://www.addictivetips.com/windows-tips/uninstall-a-usb-device-windows-10/
https://gearupwindows.com/how-to-disable-driver-signature-enforcement-on-windows-11-10/
https://gearupwindows.com/how-to-disable-driver-signature-enforcement-on-windows-11-10/
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Explanations on Terms used in MallincamSKy 
 

Dark Field Explanation 

 
The following is the best explanation of what Dark Field is, and it comes from the work of 
Simon Hanmer. 
 

Dark Frame Subtraction  

First, take an image with the camera shutter closed or the camera/scope covered under the 
same conditions of exposure time and temperature as the light frames you are going to 
capture of your astronomical target.  Many astronomers will take ten or more such Dark 
Frames and then combine them into a Master Dark Frame, principally for statistical reasons: 
the more sub-frames, the better quality of master frame. 
  
This will give you a single (master) frame of hot and warm pixels generated in the imaging 
chip, electronically and thermally, including amplifier glow. 
  
Second, subtract the Dark Frame from each of the light frames in order to remove hot and 
warm pixels and amplifier glow. However, other types of noise will remain and need to be 
removed with other manipulations and software. Note: a Dark Frame is an image file and can 
be examined. 

  
Dark Field Correction 

Dark Field correction is another matter entirely. It does not refer to a single image and the 
recommended/default 10 frames captured to perform the Dark Field correction are not used 
to generate a master frame – nor are they simply subtracted from the light frames.   
 
Instead, the 10 frames are first used to perform a running stacking, analogous to the stacking 
procedure applied in both the SSI software and the new Universe/SSI software.  
 
 Running Stacking:  the first frame in the series of 10 is recorded in the camera as is. Then the 
first and second frames in the series of 10 are combined to form a new frame that is also 
recorded. Then the third frame is combined with the preceding 2 frames to form yet another 
combined frame that is also recorded … and so on until you end up with 10 frames in a series 
that represent 1, 2, 3, 4, 5, 6, 7, 8, 9 and 10 combined frames, respectively.  
 
Note that stacked and combined frame #10 represents information derived from all 10 
frames. 
  
But hold on … we are not talking CCD imaging here – this is video. When a CCD chip is 
activated, it cranks at full blast and requires effective cooling to prevent it from rapidly 
heating up beyond a user-determined temperature. But video chips work differently: they 
heat up slowly and progressively. This means that the first frame of the series of 10 was taken 
at a lower chip temperature than the final one. Therefore, each of the 10 frames records 
different levels of thermal noise. In other words, when stored in the camera, these 10 

combined frames represent a library of information that the camera and software can now 
choose from and use to CORRECT (note: not « subtract from ») the light image that we want 

to display on our computer screen. 
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 Now, how does this work in practice – and why is it called a Dark Field correction?  
  
The Dark Field correction is prepared by the user at the beginning of an observing session by 
covering the camera or scope, pre-determining the exposure time and setting the software to 
automatically take up to 10 images. We all know our equipment and the skies we observe 
under (or we certainly will with a bit of practice).  We also have an idea of what range of filters 
we might use that night and the effect they have with respect to exposure times. Take this 
into account when selecting your exposure time for your 10 dark images. 
  
But remember this is NOT a Dark Frame subtraction – the exposures required for Dark Frame 
subtraction must be almost identical to those used for the light frames of our astro-targets. 
Not so for Dark Field correction. The camera and software in the latter case are not looking 
for a single FRAME to subtract based on exposure time. They are looking at the 10 combined 
frames to see which one has the noise level that most closely matches the noise level in the 
light frame itself. In other words, they are looking for a noise FIELD. The point here is that 
camera and software will select the appropriate Dark Field for the correction, for both shorter 
and longer light frame exposure times from the same « library ». 
  
In addition, unlike the single frame of a CCD dark frame, the images used for Dark Field 
correction are interlaced combinations of odd and even scan lines. Apparently, this too factors 
into the fact that this correction removes ALL NOISE, not just hot and warm pixels. 
  
The important point to retain here is that, because of the stacking and combining to form the 
library of images for the correction procedure, long light exposures do NOT require similarly 
long exposures for the Dark Field correction images. For example, a 2-minute light exposure 
using a narrow-band h-alpha filter may still only require the user to prepare ten 30 second 
dark images for the dark field correction. The precise numbers will vary with your equipment 
and conditions. 

 
The two screen captures below demonstrate the difference that applying a Dark Field to an 
image can provide. 
 

 

 

 

 
 
 
 
 
 
 
 
 
 
 

90 second exposure, 
lens covered. No Dark 

Field Applied 

90 second exposure, 
lens covered. 10 Dark 

Fields Applied 
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Histogram Explanation 

 
A histogram is a graph that displays the distribution of brightness (luminosity) over the range 

from the darkest possible (left side) to the brightest possible 

pixel (right side). When we examine the histogram of a typical 

deep-sky image, we will notice that the intensity range (the 

bump) is both narrow and situated toward the left (dark) of 

the Histogram Window. This bump holds the bulk of the 

information about our deep-sky image, but there still are 

other details of the image that are in the Histogram that can 

be brought out. Our task is to stretch the pixels over a larger 

part of the graph to increase the dynamic range.  

In MallincamSky, there are two vertical lines (as well as numerical indicators) that show the 

Dark (left side, 0 value) and Light (right side, 255 value). This range of 0 to 255 represents 

what the Histogram window gets to play with. In a daylight image, our bump may use most of 

that range, but with deep-sky objects, we will notice a narrower bump hanging at the left side 

of the Window. This is because we have very few bright pixels and a whole bunch of dark 

pixels (after all we are shooting at night). 

What we want to do is stretch the bump by reducing the range where bright pixels lay, after 

all there are very few of them where the brightest ones in our image are just hanging to the 

right of our bump. So, if we tell the Histogram to forget about including the brightest possible 

values (which we have none of) and start displaying the Histogram at the brightness of about 

where the stars are. We can stretch the remaining data from the dark to the new bright 

marker.  

That is what moving the Right slider or reducing the right value from 255 to a smaller number 

does. This will brighten up our image because we are removing the range of brightest possible 

pixels (which we have none of) and telling MallincamSky to display (stretch) our imaging to 

only include the new range. 

Likewise, by moving the Left slider or increasing the left value from 0 to a larger number, will 

darken our image because we are removing the range of very dark pixels and displaying our 

new range (which still contains darks, but very few brights). 

 

 

 

 

 

New range 

Old range 
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The Brighter our object the more to the right the bump will be located in our Histogram. So, if 

you increase the gain, gamma, or exposure the bump will also move to the right. This requires 

you to adjust the Left and Right markers to ensure you do not clip (remove), parts of the 

image that are outside the range. 

So, what does this mean in English? As you adjust the Left and Right markers, you remove 

data that is not relevant to your image. The remaining data is then readjusted (stretched), to 

bring out more details of dimmer aspects of the image that was overridden by the previous 

settings. We have improved the dynamic range of our image, thus pulling out the fainter 

aspects of the Deep Sky Object. 

 

 

 

 

 

 

 

 

Before Adjustments 

After Adjustments 
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Camera Assisted Astronomy vs Electronic Assisted Astronomy vs Live Video Imaging 

 
Camera Assisted Astronomy 

Camera Assisted Astronomy (CAA) has many definitions, but for the purpose of 

Mallincammers, it will be synonymous with Astrophotography using the Mallincam. In CAA, 

you will obtain the best image you can. You will create a set of Dark Frames (not Dark Fields), 

Flat Frames, Bias Frame, and even Dark Flats. All images will be saved in a non-compressed 

data format (such as FITS or TIFF). These images will then be combined (calibrated) using 

specialized software (MAXIM/DL, AstroArt, PixInsight, DeepSKy Stacker, etc, …), and then 

finally enhanced, color adjusted, and tweaked, again using specialize software (Photoshop, 

etc…). 

Electronic Assisted Astronomy 

Electronic Assisted Astronomy (EAA) has many definitions, but for the purpose of 

Mallincammers, it will be synonymous with using any electronics in the process of acquiring 

an object (does not require any camera). Using a mount with Goto capabilities with a scope 

and eyepieces is considered EAA. 

Live Video Imaging 

This is when the video images and its adjustments, enhancements, stacking, Dark Fields, and 

Flat Fields, are all done live on the screen. The final image is live and can be saved, recorded, 

and broadcasted as needed. It is this process that the Mallincam SkyRaider cameras are 

designed for as their purpose, and Live Video Imaging is the objective of this User Guide. 

Can the Mallincam SkyRaider Camera do CAA 

The answer is yes, but the process will be totally different than that of Live Video Imaging. 

First, you will not be using Dark Fields or Flat Fields since you will be taking Dark Frames and 

Flat Frames. Images saved in RAW format will not include any of the Dark Fields or Flat Fields 

even if you have applied them to your image. 

 

Take Flats Frames and save them in either RAW (which is a FITS format), or RGB (use FITS or 

TIFF) format. Flat Frames are actual images which you can examine. 

Take Bias Frames and save them in the same format as the above Flats. 

Take Dark Frames and save them in the same format as the above Flats. 

Take your Light Images and save them in the same format as the above Flats. 

Now, calibrate these images with your favorite astro-image processing software, then 

enhance using your astronomy enhancing software. 

Process 
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Most CAA imagers will be using monochrome cameras and will require color filters and the 

taking and organizing these filtered images is in the wheelhouse of specialized imaging 

software. MallincamSky can perform these tasks, but you will be in the driver’s seat every step 

of the way. Therefore, Mallincam SkyRaider cameras have an ASCOM driver so these 

specialized astro-imaging software packages can control the SkyRaider camera. 

 

Lossless File Formats used by MallincamSky 

 

FITS is an open standard defining a digital file format for astronomical images and contains a 

Metadata header. This Metadata header provides keyword information that includes 

particulars about the camera and its settings used in taking that image. Your favorite astro-

imaging software can read and use this Metadata for its processing tasks. You may want to 

add a FILTER field in the Metadata to indicate what filter you used with this image. 

 

FITS is in a bayered format for color cameras (so it will look like a checkered Black and White 

images), so think of it as one image hiding 3 or 4 other images inside itself, just waiting to be 

bebayered and combined to produce a color image (which is an art in itself). 

 

TIFF files are lossless (or lossy) formats that also contain header information (not as much 

detail as in FITS). Color images can be saved in TIFF format without being bayered. 

 

 

 

 

FITS (Flexible Image Transport System) 

TIFF (Tagged Image File Format) 
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An Introduction to the Stacking Algorithm  
 
Historic Review 

 

In the 1970’s a major breakthrough took place in the world of imaging, the CCD was invented. 
This technology started slowly to replace film as the medium for taking images of the night 
sky. CCDs are still the medium of choice in the professional field of astronomical imaging. But 
in the late 1990’s advancements in CMOS technologies have started another revolution, 
CMOS optical sensors. Let the battle begin. 

 
 
Simply both CMOS and CCD’s do the same thing. They capture and convert photons (light) into 
an electrical signal that can be used by a computer. How they do it is what distinguished CCDs 
from CMOSs. 
 
CCD (Charge Coupled Device) 

 
A CCD uses a thin silicon wafer, this wafer (or chip) is divided into thousands, or millions of 
tiny light sensitive squares (or rectangles) called photosites.  Each of these photosites 
corresponds to an individual pixel in the final image.  
Think of the photosite (pixel) as a capacitor that converts the photons (light) into electric 
energy which it stores. When the CCD is finished collecting the photons, the charge is 
transferred downwards along the columns. Hence, during the CCD clocking operation, rows 
are transferred downwards to the final row (the readout register) which is used to transfer the 
charge in each pixel out of the CCD so it can be measured. In the Horizontal read-out register 
the charge is transferred in the horizontal direction, along the readout register. When a 
charge has been collected and is to be read-out it is transferred one charge packet at a time to 
an output amplifier where the charge is converted to a voltage.  

See Bucket Brigade image below for a visualization of the process. 
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CMOS (Complementary Metal Oxide Semiconductor) 

  
Unlike a CCD, a CMOS sensor’s approach the converting of light photons into a voltage signal 
by having each pixel do its own charge to voltage conversion and amplification rather than 
shuffle the electrons off the sensor and perform the charge to voltage conversion and 
amplification there. Thus, the CMOS sensor, each pixel site is essentially a photodiode and 
three transistors, performing the functions of resetting or activating the pixel, amplification, 
and charge conversion (Analog to Digital Converter, ADC). This provides both high speed for 
CMOS sensors, but also low sensitivity (as well as high fixed-pattern noise due to fabrication 
inconsistencies in the multiple charge to voltage conversion circuits). CMOS sensors can be 
designed to read each pixel individually or read a whole column simultaneously. 
 

  
 

In simple terms, the Photosites in a CCD are passive (they do not work) they just move the 
information along to a final Output Amplifier, while the photo-sites in a CMOS sensor are 
active (they do work), they amplify and can perform local processing.  
 
CMOS Imaging 

 
When the light hits the sensor of the Mallincam camera (remember the camera is configured 
as a Video camera) it is read and processed from each pixel (P). It sends all of the pixel’s data 
(which we will call a FIELD (to distinguish it from an image FRAME) to another processing 
locations via the Transport System (T) where it is temporarily stored, and more logic and 
processing algorithms can be performed on the elements of the FIELD.  This is where the 
proprietary work is performed by the Mallincam Camera including the ability to apply both 
analog and digital Gain before the FILED is sent to the computer. Note: it is these support 
circuit elements around the CMOS Pixel array that can cause AMP GLOW (see image below). 
Modern CMOS manufacturers are working on moving these support circuits away from the 
Pixel sensor array to reduce or eliminate Amp Glow noise. 
 

 
 

To assist you understanding FIELDS and FRAMES. It takes a specific number (depending upon 
camera sensor) of FIELDS in 1/30th of a second to make up a FRAME. If the required number 
of FIELDS do not make it from the Camera to the computer software (either too much 
processing is being performed by the camera or computer, or FIELDs are being requested too 
fast by the USB port) then the FRAME will not be created. If the software fails to display an 
image (FRAME), then slow down the FIELD retrieval request rate of the USB by moving the 
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Frame Rate slider to the left (slows it down). It is this issue, of the computer software not 
having enough time to correctly process the information, which causes the Pink Floyd effect 
when Live Stacking.  
 

What is happening when you Live Stack 
 
Average 

 
When this control is activated from the software, the processing takes place on the FIELD data 
which is located in the Memory and Logic circuit on the CMOS chip. For example, for any given 
exposure time, many FIELDS of data are stored in the Memory and Logic Circuits of the 
Camera. Now if you enter 5 as the Number in Live Stack, then the Logic and Processing 
algorithms will continuously combine (average) 5 sets of FIELD data to create a MASTER FIELD 
in the Camera before sending this MASTER FIELD data to the computer software. The 
computer software will continuously incorporate (via a proprietary algorithm) these received 
MASTER FIELDS into the previous image FRAME’s data (the required number of MASTER 
FIELDS must be met to create the FRAME) which will be displayed on the computer. The Input, 
Output, and Status indicators will indicate the process of the stacking. The averaging will be 
continuous with every new exposure incorporating a new MASTER FIELD. The initial output 
will provide a very noticeable increase of resolution as outliers and noise is averaged out. But, 
after many Outputs, the improvement return that you obtain in the image is diminished with 
the inclusion of more MASTER FIELDs (you may have incorporated 100’s of previous MASTER 
FIELDs). If you do not see any more image improvement, it is time to take a Snapshot of the 
image. 
 
First, you will notice a distinct delay after initially enabling Live Stacking, even after the 
camera has taken its user-determined exposure. In part, this delay reflects the fact that the 
camera circuitry is performing the compilation of the FIELDS (let us say 5 for our example). It 
must determine whether the data in the 5 FIELDs is of sufficient quality for the successful 
compilation of a MASTER FIELD. Remember, to analyze a group of fields, the CMOS sensor 
must evaluate the values at every location in every FIELD in the MASTER FIELD, it must even 
investigate every dark pixel, even if the pixel does not say anything particularly interesting 
about that location in the FIELD. Therefore, we want to keep the value in the Number box at a 
low value (e.g., 5) to minimize the amount of FIELD processing required by the camera.  
 
When a MASTER FIELD has been successfully compiled within the camera and downloaded to 
the computer the Input number is incremented to 1. Note that the Output number is still 0, 
and the Status indicator remains blank. Note that the MASTER FIELD is also stored in the 
camera memory as a reference group for comparison with successive compiled groups of 5 
fields during the ongoing Live Stacking run.  
 
The MallincamSky software in the computer will attempt to incorporate the downloaded 
MASTER FIELD with the original noisy image that was visible on the computer's screen prior to 
enabling Live Stacking. Incorporating here means averaging and maybe aligning (if enabled) 
the MASTER FIELD with the original noisy image. Note, this involves processing FRAMES or 
images for display purposes. The alignment process does use stars (if Deep Sky is selected), or 
larger areas (if Planetary is selected) in the FRAME, which is quite different from the 
processing of FIELDS in the camera. This initial computer-based processing accounts for the 
other part of the initial delay perceived by the user at the beginning of Live Stacking. If 
MallincamSky determines that alignment and averaging was successful, it will now place the 
result in the Output Stack. This constitutes an output, and the Output number is incremented 
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from 0 to 1, and the Status indicator is set to OK. Sometimes the computer will reject the 
attempted first Output (maybe not enough good stars for an alignment) and will wait for the 
camera to download a fresh MASTER FIELD, hopefully with better quality data. In this case, the 
Input Number will continue to increase until the computer software accepts the first Output 
and sets the Output Number to 1. A new image that represents the processed Stack is then 
sent to the computer screen where the user will note a significant decrease in the random 
noise. This process is then repeated until you disable the Live Stacking. 
 
The larger the value entered in the Number Box, the more processing that must be performed 
by the camera to create MASTER FIELDSs. This can cause a processing overload as the camera 
and software are trying to work together to continuously create Live Video Frames (software 
continuously saying Feed me data (via USB frame rate setting), and the camera processing and 
dumping the data) that can be displayed on the screen. So, we recommend a small number 
between 4 and 10, so that both the computer and camera are happy. Since the incorporating 
of new MASTER FIELDs is continuous, you will average hundreds of MASTER FIELDs in your 
image and after a while achieve the same result of having entered a large value in the Number 
Box, but without the CPU overhead. 
 
Note:  If you are enabling alignment of Deep Sky Objects (which uses Stars in the alignment 
process), if there is too much bouncing around of the image (either due to mount stability, 
weather conditions, Sky conditions, or image rotation due to an Alt-Az setup), the computer 
algorithms may have difficulty aligning and you could obtain the Pink Floyd effect. You can 
observe this phenomenon, by tapping your mount while imaging in Deep Sky. 
 
 

Additive 

 
When this control is activated from the software, the processing takes place on the FIELD data 
which is located in the Memory and Logic circuit on the CMOS chip. For example, for any given 
exposure time, many FIELDS of data are stored in the Memory and Logic Circuits of the 
Camera. Now if you enter 5 as the Number in Live Stack, then the Logic and Processing 
algorithms will continuously combine (add) 5 sets of FIELD data to create a MASTER FIELD in 
the Camera before sending this MASTER FIELD data to the computer software. The computer 
software will continuously incorporate (via a proprietary algorithm) these received MASTER 
FIELDS into the previous image FRAME’s data (the required number of MASTER FIELDS must 
be met to create the FRAME) which will be displayed on the computer. The Input, Output, and 
Status indicators will indicate the process of the stacking. The initial outputs will provide a 
very noticeable increase of brightness until the selected number in the Live Stack is reached (5 
in this example). But, when the Output Number exceeds the Live Stack number, you will 
notice no increase in brightness (unless the brightness of the object changes during the rolling 
stacking process) so it’s time to take a Snapshot of the image. 
 
First, you will notice a distinct delay after initially enabling Live Stacking, even after the 
camera has taken its user-determined exposure. In part, this delay reflects the fact that the 
camera circuitry is performing the compilation of the FIELDS (let us say 5 for our example). It 
must determine whether the data in the 5 FIELDs is of sufficient quality for the successful 
compilation of a MASTER FIELD. Remember, to analyze a group of fields, the CMOS sensor 
must evaluate the values at every location in every FIELD in the MASTER FIELD, it must even 
investigate every dark pixel, even if the pixel doesn't say anything particularly interesting 
about that location in the FIELD. Therefore, we want to keep the value in the Number box at a 
low value (e.g., 5) to minimize the amount of FIELD processing required by the camera. 



M A L L I N C A M S K Y  D S 1 0 C T E C  U S E R  M A N U A L  

 

222 

 

 
When a MASTER FIELD has been successfully compiled within the camera and download to 
the computer the Input number is incremented to 1. Note that the Output number is still 0, 
and the Status indicator remains blank. Note that the MASTER FIELD is also stored in the 
camera memory as a reference group for comparison with successive compiled groups of 5 
fields during the ongoing Live Stacking run.  
 
The MallincamSky software in the computer will attempt to incorporate the downloaded 
MASTER FIELD with the original image that was visible on the computer's screen prior to 
enabling Live Stacking. Incorporating here means adding and maybe aligning (if enabled) the 
MASTER FIELD with the original image. Note, this involves processing FRAMES or images for 
display purposes. The alignment process does use stars (if Deep Sky is selected), or larger 
areas (if Planetary is selected) in the FRAME, which is quite different from the processing of 
FIELDS in the camera. This initial computer-based processing accounts for the other part of 
the initial delay perceived by the user at the beginning of Live Stacking. If MallincamSky 
determines that alignment and adding was successful, it will now place the result in the 
Output Stack. This constitutes an output, and the Output number is incremented from 0 to 1, 
and the Status indicator is set to OK. Sometimes the computer will reject the attempted first 
Output (maybe not enough good stars for an alignment) and will wait for the camera to 
download a fresh MASTER FIELD, hopefully with better quality data. In this case, the Input 
Number will continue to increment until the computer software accepts the first Output and 
sets the Output Number to 1. A new image that represents the processed Stack is then sent to 
the computer screen where the user will note a significant increase in the brightness. This 
process is then repeated until you disable the Live Stacking. 
 
The larger the value entered in the Number Box, the more processing that must be performed 
by the camera to create MASTER FIELDSs. This can cause a processing overload as the camera 
and software are trying to work together to continuously create Live Video Frames (software 
continuously saying Feed me data (via USB frame rate setting), and the camera processing and 
dumping the data) that can be displayed on the screen. So, we recommend a small number 
between 5 and 10, so that both the computer and camera are happy, plus the object that you 
are imaging does not become too over exposed. Since the incorporating of new MASTER 
FIELDs is a continuous rolling loop, you will continuously add the Live Stack number of 
MASTER FIELDs to create your image and after a while, achieve the same result as having 
entered a large value in the Exposure Time control. 
 
Note:  If you are enabling alignment of Deep Sky Objects (which uses Stars in the alignment 
process), if there is too much bouncing around of the image (either due to mount stability, 
weather conditions, Sky conditions, or image rotation due to an Alt-Az setup), the computer 
algorithms may have difficulty aligning and you could obtain the Pink Floyd effect. You can 
observe this phenomenon, by tapping your mount while imaging in Deep Sky. 
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Setting up to Broadcast on LiveSkies 

 
Introduction 

 

I found that when I first started connecting to LiveSkies things started happening too fast for 

me to keep track of everything at once. So, pre-planning was the most crucial step for me. I 

found that by doing test runs in the comfort of my house allowed me to develop my 

techniques that work for the equipment and software that I use. Below are the results and 

steps that I use to broadcast on LiveSkies, feel free to follow them and/or make modification 

as you deem as necessary. 

Computer real estate will be your nemesis. So, depending upon the size of the monitor 

(laptop), the number of screens that you are using, then number of software programs that 

you are simultaneously using, will dictate how you will manage your windows. I will describe 

how I have organized my windows under a variety of situations (1 computer, 1 computer with 

2 monitors, which software packages am I using, and what am I trying to do this session).  

Remember, it is all about having fun, and time and patience are your best friends (not to 

mention all the guys and gals, and the Google – MallinCam site:  

https://groups.io/g/MallinCam/topics 

One of the most important decisions you will need to make with broadcasting the image of 

the SKYRAIDER is what Video capture software are you going to use. Some simple suggestions:  

Currently MallincamSky is not capable of modifying the Video Image and having that Video 

Image be directly captured by LiveSkies. So, if you want to use all the features of the 

MallincamSky software and broadcast those results, as well as save screen shots and videos of 

your images, then we need another program to capture MallincamSky’s output and have the 

output from that program directly linked to a Liveskies Channel.  

You currently have many choices for that screen capture program:  Splitcam, Manycam, 

WebcamMax, OBS Studio, StreamLabs OBS, …. All have about the same features, some of 

these have versions that will cost you, but all have a version that is free (reduced functions, 

advertisements, etc.).  My current program of choice is Splitcam (Visit www.mallincam.net 

software downloads for website address, or Google the software of choice). You will then use 

Splitcam/OBS along with MallincamSky Software to broadcast the images on NSN. 

To Broadcast on LiveSkies, you will need to obtain a broadcast account from Rock. Once 
obtained, you will be able to broadcast, observe other broadcasting channels, and participate 
in real time discussions. 
 
 
 
 
 
 
 

 

https://groups.io/g/MallinCam/topics
http://www.mallincam.net/
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Obtaining a Broadcast Account 

 
 

Visit https://liveskies.org 
 
 
 
 
 
 

 
Click on Sign up To Broadcast (located at top right of screen) 

Remember each channel name will have a unique email address. 
 

 
 
Complete the Registration Form 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Do not forget to check the agreement Rules checkbox and then Click on the red Create 
Account button. 
 

In a couple of Days, Rock will approve your account. If you try to broadcast 
prior to approval, Liveskies will inform you that approval is still pending. 

 

The Channel Name and 
Username should be the 

same with NO SPACES and 
SPECIAL CHARACTERS in the 

name 

Step 1 

Step 2 

Step 3 

Step 4 

https://liveskies.org/
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Logging into Liveskies 

 
 

Visit https://liveskies.org 
 

 
 

 

Click on the red Login button on the upper right of the window. 
 
 
 

A login window will pop up 
 
 

 
 
 

Enter both your Username and Password and click on the red Login button. 
 
 

You can have Liveskies remember your credentials. 
When you have successfully logged in, you will be presented with the 

main display and control window. 
 
 

 
 

It is from here that you can select your Video source, Resolution, and 
Audio source. Liveskies tries to remember what you used last time 

and will automatically fill this information in for you if it can. 
 

Step 1 

Step 2 

Step 3 

https://liveskies.org/


M A L L I N C A M S K Y  D S 1 0 C T E C  U S E R  M A N U A L  

 

226 

 

Video Source 
 
At this point, determine how you would like to broadcast your live video of MallincamSky. I 
will go into more detail with two options SplitCam and OBS in the next section. 
 
I am assuming that you have either SplitCam or OBS running and displaying the active 
MallincamSky Window. (See below on how to achieve this). 
 
Clicking on the dropdown list will provide you with the current DirectShow options available 
to you on your computer (depending upon what software you have installed). 
 

 
 

If you have installed the Directshow drivers, then Mallincam will be added to the list. 
 

Note: In using Directshow, you will see the image of what the 
camera is observing, but you will need Directshow software (such as 
AMCap) to control most aspects of the camera.  

 

If you have installed Splitcam (recommended), you will see Splitcam Video Driver in the List. 
Select your Video Source from the list. 
 
 

Video Quality 
 
From the drop-down list select the best resolution your system can handle.  
 

Start with 1080p and see if you can broadcast with this resolution. If 
you find that your system (internet) cannot handle this level of 
resolution, just take the resolution down. 

 

 
 
 

Audio Source 
 
The drop-down list will indicate what current audio devices you have available on your 
computer. Choose the one which provides the best sound quality. 

 

Step 4 

Step 5 

Step 6 
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This section explains how to Capture and Broadcast Using either SplitCam or OBS 

 

You will want to stream the MallincamSky image to the Liveskies server. I will give procedure 
for two of many options. Once you have activated your option of choice, just bring the 
MallincamSky Window up front so you can control it.  If you have multiple monitors, you can 
leave Liveskies and MallincamSky each on its own monitor, so they are available to control. 
 

Using SplitCam (either visit Mallincam.net or splitcam.com to download) 
 

 

Start MallincamSky and connect to your camera. Ensure MallincamSky is active on your 
monitor and is not reduced. 
 

 
 

Start Splitcam (I will illustrate with the latest version) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Click on the blue + beside Media Layers to select what part of the screen you would like 

SplitCam to capture. 
 

 

 
The new window will offer you many choices, but the two best choices 
will be either Share Screen or Share Window. 

• Share Screen allows SplitCam to capture the whole screen. 

• Share Window allows SplitCam to capture only a specifically 

running piece of software (such as MallincamSky). We 

recommend using Share Window. 

▪ You will not be able to annotate over Share 

Window. 

I recommend you have 
SplitCam appear on your 

task bar, so all you need to 
do is click on it, so it opens 

over the active 
MallincamSky. 

Step 1 

Step 2 
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When Share Window is selected, a drop-down box will provide a list of currently running 
programs. 

 
 

Choose MALLINCAMSKY 
 
You will now have SplitCam displaying the MallincamSky’s window in its display window. 
 

 
I recommend setting the resolution to 1920 x 1080 in SplitCam’s General Settings 

(the 3 horizontal lines beside My Project in the SplitCam screen. 
 

Splitcam will choose a default microphone for you, but you can delete it, and 

choose another microphone (or include system audio) by again clicking on the + in 

Medial Layers and selecting microphone or system audio and select your choice.  
 
On the Liveskies window, click on the red Broadcast button. 
 

 
 
If everything connects correctly, you will see “peer connection connected” at the top of the 
Video source window (the Broadcast button will change to a Stop button). 
 

 

Select Splitcam Video Driver as 
the Video Source and either select 
your microphone directly or select 

Splitcam Audio to choose the 
microphone(s) you selected in 

SplitCam 

Step 3 

Step 4 
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Live Chat 

 
On the right-hand side of the Liveskies window you will see a 
Live Chat box. It is from here that you will be able to Chat and 
see responses from other viewers in real time. Just type in your 
message and hit the red button to the right of your message to 
send it. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
Finished 

 
When you are finished with your session, just click on the red LOGOUT button at the top of 
the Liveskies screen, then shutdown SplitCam and MallincamSky. 

 
 
 

 
 
 
 
 
 
 
 

 

To control MallincamSky, just bring it to the front. If you have a 
small sized monitor, you may want to reduce the size of the 
MallincamSky window so you can also view the Liveskies 
window and participate in the chat process. 
 
Having multiple monitors gives options of placing the Liveskies 
window on one monitor while MallicamSky is on the other monitor.  
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Using OBS (Open Broadcast Software) – This is a more challenging process to initially setup 

 

Start MallincamSky and connect to your camera. 
 
 

 
 

 
Start OBS  
 

 
 
 

Click on the + in the Sources box to select a source for OBS. 

 
A new Window will open up where you can select from a list of 
possible sources. 
 
  

Two two best choices are Display Capture and Window 
Capture. 
 
We recommend Window Capture. 

 
 
 
 
 
 

Step 1 

Step 2 

Step 3 
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When the Window Capture selection appears, use the dropdown list to select MallincamSky. 
 

 
 

You will see the MallincamSky screen in OBS’s display. 
 

 
 
 
 

Click on the Gear symbol in the Mic/Aux box and then select 
Properties to choose a microphone for broadcasting from the 
drop-down list. (You can test the microphone by speaking and 
watching the green level bar change) 
 

 
 
 

Now click on the Settings tab in the Control box. 
 
 
 
 
 
 
 
 
 
 
 
 
 

If you have the 
Desktop Audio 

setting too high, then 
you will catch your 

voice on that as well 
and this can lead to 
repeated echoing 

Step 4 

Step 5 
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This will open-up the settings selection for OBS 
 

 
 
 

We want to Stream the MallincamSky Window, so select Stream from the 
selection on the left column. 
 

 
 
 

OBS will now require 3 pieces of information. 
 
1. That the service is Custom (so select it from the drop-down list) 
2. The server’s rtmp address 
3. The Stream Key name 
 
Both the rtmp address and Stream Key are located in external 
encoders window on Liveskies 

 
 
 
 

 
 
 

Step 6 
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Go back to Liveskies screen and make sure that you are not broadcasting (it will say Stopped! 
beside a red Broadcast button, do not worry about Video source) 
 
 

 
 
 
 

We need to tell OBS (and give permission) where to send the MallincamSky’s live video 
image. In the Liveskies window, place your mouse over the orange name of your channel. A 
pop-down list will appear. 
 

 
 

Move the mouse to select External Encoders on OBS Drop Down 
 

The Broadcast Video window will appear that contains all of the 
data needed for broadcasting. Only the first two lines RTMP 
Address and Stream Name contains the information OBS 
needs. What we need to do is copy the information (one piece at a time) 
and give it to OBS. 

 
 

 
 
 

Click on the red Copy button next to the RTMP Address box 
 

This copies the rtmp address information. 
 

 
Go back to the OBS window and paste (Ctrl-c) the location into the Server box 
 

 
 
 

Step 7 

Step 8 

Step 9 

Step 10 
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Go back to the Liveskies Window and click on the red Copy button for the Stream Name 
 
 
 
 

Go back to the OBS window and paste (Ctrl-c) the location into the Stream Key box 
 
 

 
 
 

Now click on Apply to OK these address locations on OBS. 
 

Liveskies has a maximum video 
bandwidth of 3500, so you will 
want to ensure that you do not 
exceed that in OBS via the 
Settings>Output control. If 
your computer has a dedicated 
Video card, see if there is a 
hardware encoderin the 
Encoder dropdown box. If soo 
try it to see if you get less cpu 
ussage when using OBS. Visit 
youtube on advice for tweaking 
the settings on OBS. 
In Settings>Video you can 
set the Base and Output 
resolution (1920 x 1080). 
Make sure they are both the 
same values. 
 

 
To start streaming just click on the Start Streaming button in the OBS control box. 
 

 
 

If everything is working, you will see a green box appear on the bottom 
of the OBS window. 

 
 

To stop streaming, just click on the Stop Streaming button in the OBS control box. 

Step 11 

Step 12 

Step 13 
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Comments about using OBS (or other streaming software) 
 

• There will be a delay (3 to 5 seconds) between 

your adjustment to the broadcast view. This has 

to do with the way rtmp works (encoding, 

buffering, …). 
 

• You do not need to be logged into your 

Liveskies account to use OBS, it will 

automatically stream to your channel (once 

you select Start Streaming). You can minimize 

OBS and use MallincamSky as you normally 

would. But, since you have not logged in, you 

will NOT be able to use the Live Chat (bummer). 

So, just log in to your Channel and then view 

your own channel to use Live Chat or Log in as 

Guest to view the channel. Some users use their 

phone to view the Live Chat and answer 

questions over the microphone in OBS. 

 

• Once you have setup the settings on OBS, it 

remembers them. So, the next time you start 

OBS, all you need to do is click on Start 

Streaming and you are broadcasting. 

 

• SplitCam (Version 10) also has the capabilities 

to broadcast on rtmp as well as directshow.  



M A L L I N C A M S K Y  D S 1 0 C T E C  U S E R  M A N U A L  

 

236 

 

Viewing a Live Skies Channel 

 

Logging into Liveskies 

 

 
 

Visit https://liveskies.org 
 

 
 

Below the main display window of Liveskies is a list of the currently broadcasting channels, or 
just click on the CHANNELS button on the top line to display currently broadcasting channels. 
 

 
 

If you just want to watch and not participate in the Live Chat, just click on the Channels Button 
to display available channels to watch. Then just click on the channel image and you will be 
presented with the live channel. 
 

If you want to participate in the Live Chat 

 

Click on the red Login button on the upper right of the window. 
 

A login window will pop up. 
 

 

Step 1 

https://liveskies.org/
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Enter both your Username and Password and click on the red Login button. 
 
 

You can have Liveskies remember your credentials. 
When you have successfully logged in, you will be presented with the 

main display and control window. 
 
 

 
 

If you have previously broadcasted, Liveskies may automatically 
activate your broadcast channel. 

 
 

Click on the Channels button at the top left of the Liveskies window. 
 

 
 

A list of available channels will be displayed. 
 

 
 

Just click on the Channel and you will be presented with the channel and the Live chat window 
 

 

Step 2 

Step 3 

Step 4 
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You can make the Broadcast Video Window full screen by clicking on the  located on the 
bottom right side of the Liveskies video window (you will not be able to see the Live Chat 
Window), or simply by double clicking on the Video Window of the broadcast (double clicking 
on the full screen broadcast channel will return it to its original size). Clicking on the 

 button will also toggle on or off the Live Chat window (also increases the size of the 
Video Window). 
 

These are great ways to see the live broadcast in amazing detail, but you lose the Live Chat Window 
 

If you are using Google Chrome (or similar), use the zoom feature (3 vertical dots on upper 
right of browser) to increase size. Experiment by increasing zoom factor. 
 
For my monitor zoom 150 gives me the best video and Live Chat arrangement, zoom 300 placed Live 
Chat underneath Video window. 
 

You can pause the video stream by clicking on the 2 vertical bars on the lower left side of the 
Liveskies video window.  

 

When you resume the video, it jumps to the current live video stream, not where you left off 
 
 

To Live Chat 

 

Just type your text in the entry box at the bottom of the Live 
Chat window and click on the red delivery button to the right of 
the entry box. 
 
Your chat and other replies will display in the scrolling Live Chat 
window. 
 

Clicking on the (Viewers Online) opens a Viewers List containing 
your current viewers. 
 
Clicking on it again, closes the Views List. 
 
 
 
 

To exit 

 

All you need to do is Log-Out by clicking on the red LOGOUT 
button on the top of Liveskies Window. 
 
You can also click on the channels but change the channel if you require. 
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One Page Broadcast Summary 
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Customizing the Screen 
 
You can customize what controls (and the defaults for most of the controls) you want active, 
by Left-Clicking anywhere in the Left Sidebar then choose the Settings choice to open-up a 
Preference Window that allows you to make various setting changes. 

 

 

 

 

 

 

Select Misc from the Preference Tab and then examine (or modify) all the controls 

and options available to you. You use the Preferences to activate (or deactivate) 

controls displayed on the left sidebar of MallincamSky, the colors of the commands 

in MallincamSky, or even the Language the controls are written in. 

       

       

 

Customize the Top Bar Icons    
 

 

This control will allow you to customize what appears on the Icon Bar. 

Left-Click on the Customize Icon to display the Add or Remove Buttons selector. 
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Toolbar 

 

Then Left-Click on the down-triangle to expand and 

select Toolbar.  

Left-Click on its triangle to expand the command to 

show the currently displayed Icons. 

Select which Icons you want displayed on the Icon Bar 

by Left-Clicking on the checkmark to add or remove 

that Icon. 

You can reset the Icon bar to its default state by Left-

Clicking on the Reset Toolbar button. 

 

Customize 

This control will allow you to customize your Icon Bar, 

by providing a process of adding or removing other 

control icons to its bar.  

The left Categories Window contains the icons 

specific to that category. 

The All-Commands category contains all available 

icons. 

Choose a Category. 

Left-Click Hold and Drag an icon from the Commands Window to the Icon bar (you 

will see a black marker bar appear when you move your cursor to the Icon Bar as 

position it where you would like to place the new icon. 

Release the mouse button, and the icon will appear where your mouse was pointing. 

Before:  

After:  

To remove an icon from the icon bar, just drag if off the icon bar. 
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Focal Reducers 
  

MFR-10 Focal Reducer 

  
Because of the Large sensor size on the SkyRaider DS10C TEC, the best focal reducer to use is 

the Mallincam 2-inch version. The MallinCam MFR-10 (MallinCam Focal Reducer-10) is a 

breakthrough in optical performance only from MallinCam. You can now have a focal reducer 

for your larger size (up to 28.4mm diagonal) CCD or CMOS sensor astronomical camera. The 

large format focal reducer has a 2" (48mm) thread on either end and comes with a T-to-2" 

adapter to allow use with all T-mount type cameras.  Reduction for a 17.5 mm back focus 

camera is 0.46X. The 3 element multi-coated system has a built-in field flattener crucial for RC 

type telescope and SCT as well. The MFR-10 will make your telescope F/ ratio faster when 

using a CCD or CMOS camera, cutting exposure time by up to 5X. Using this with a 10mm 

space provides the fastest system with the least amount of distortion effects. 

 

 

 

 

 

 

 

Universe .5X focal reducer  

 
The Universe focal reducer and a 10 mm spacer is the best match for the DS10C camera. 

Designed and built for use with the large sensor in our Universe camera, this 0.5x focal 

reducer can also be used with other large sensor cameras such as our SkyRaider DS16, DS10C, 

DS10CTEC.  The Focal Reducer has a T-mount thread on either end, allowing it to be securely 

attached between the camera and nosepiece.  Three small set screws allow you to lock the T-

mount threads after it is assembled. 
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What do those Flashing LEDs indicate on the Back of the SkyRaider Camera? 
 

There are a few different Models of SkyRaider cameras, but we will examine the two major 
styles. 
 

One LED on the Back of the SkyRaider 
 

 
 

When software has activated this camera (MallincamSky, ASCOM, or DirectShow). The Blue 
LED will flash to indicate that it is operating correctly. If the Camera has a Fan, it too will start. 
 

Four LEDs on the Back of the SkyRaider 
 

 
 
 

➢ When 12V of power is provided: the PWR LED will be ON. 

➢ When software has activated camera: the SYS LED will FLASH to indicate operating 

correctly. 

➢ When TEC is turned ON: the TEC LED will be ON. 

➢ When FAN is turned ON: the FAN LED will be ON. 
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C8: Advanced Techniques 

 
 
 

 
 

This chapter deals with detailed instructions on how to perform procedures to improve your 
image. This will be a chapter that grows as more users discover techniques that will be 
beneficial to others. 
 

How to Take Darks 
 

As mentioned in the appropriate section in the User Manual, Applying Darks is a great way to 
remove noise generated by the Camera’s environment. The following instructions will guide you 
in Taking, Saving and Applying Dark Fields. 

Determine what exposure times, gain, Digital Binning you will be creating Darks Fields for. You 
will want to define a location on your computer where you would like to store your Darks. We 
will use a convention where you can grab the correct Darks for your current imaging 
requirements. For example, if you use 10s, 20s, 30s and 40s exposure rates, and switch between 
Digital Binning 1 and Digital Binning 2, you will want to create a set of 8 Darks. 

We will great a set of 20 second Darks using Digital Binning 2. So, cover up your telescope 
objective and follow the ensuing recommended procedures. 

 

Set your Camera’s Temperature 

 

Set the temperature of the camera to that which you will be 
using for. Most of us set it to 0oC. Allow the camera to get in the 
range before you take Darks (examine the temperature value on 
the bottom right side of MallincamSky).  
 
 
 

Set your Exposure Value 

 

Since we will be using 20 seconds as an example, set the exposure to 
20s in Trigger Mode and start the camera Looping. 

 
 

 

Chapter 

8 
 

 



M A L L I N C A M S K Y  D S 1 0 C T E C  U S E R  M A N U A L  

 

245 

 

Set your Digital Binning 

 

Since we will be using 2 x 2 Digital Binning as an example, set the Binning 
to 2 x 2 using Additive. 

 

Set the Gain 

 

Since we want to bring out more noise, it is recommended that to set the 
Gain as high as you can. So, we set it to 100 in this example. 

 

Adjust the Histogram 

 

We want to bring out as much noise as we can when imaging, so set the 
Left to 0 and the Right to 100. This will emphasize the noise (red and 
green pixels). 

Your screen should look something like this: 
 

 
 
 

Set the Number of Dark Fields 

 

We want the system to incorporate several Dark Fields into its Master, 
so choose a number between 5 and 10. Remember too high a number 
will take a while to produce the required Dark Fields. We will use 5 in 
this example. So, the Dark Field capture run of 5 Dark Fields of a 20 
second exposures will take a total of 100 seconds. 
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Capture Dark Fields 

 

Click on the Capture button in the Dark Field Correction box to Start 
the capture process. There will be a running display that lets you know 
where the capture routine is at that moment. The image on the right 
shows us that it has so far captured 2 out of 5 Darks. This indicator 
number will disappear when the capture routine is complete.  

 
Export the Captured Dark Fields 

 

Click on the Export button in the Dark Field Correction box to Save the 
Master Dark Field.  

Choose a Dark Field Folder: Dark Fields 

Choose a Sub Folder if you have multiple cameras: DS10CTEC 

Use a naming standard the helps you find the correct Dark Field: 
DS10_20s_DB2_Gain100_Meade10_fr_0.5 

 
Import a Captured Dark Fields 

 

Click on the Import button in the Dark Field Correction box and select 
your previously saved Dark Master. 

 
Test the Captured Dark Fields 

 

Click on the Enable check box in the Dark Field Correction box and 
examine your image. 

Because MallincamSky is still capturing 20 second images with the lens 
cap on. When you apply the Darks, you should get a completely Black 
image (all of the colored pixels have been removed). 

 

 

Now you can remove the lens cap from your Telescope and see how your images improve 
when you apply Dark Field Corrections. 
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How to Take HDR Images 
 
High Dynamic Range is basically just the difference between the lightest light and darkest dark 
you can capture in an image. If the object exceeds the SkyRaider’s dynamic range, the 
highlights tend to wash out to white, or the darks simply become big black areas. It is 
extremely difficult to capture an image that retains both ends of this spectrum. But with 
modified imaging techniques and advanced post-processing software you can make it happen. 
 
The following images of Orion demonstrate why we want to use HDR techniques. 
 

    
 

The image on the Left provides the nebulosity of Orion, but the trapezium is blown out. While 

the image on the Right you can see the trapezium stars but have lost the detail in the 

nebulosity.  What we want is an image that contains the best of both images. 

 

What we want to do is obtain this style of image in MallincamSky using its built-in controls. 

We will call this process: Live High Dynamic Range (LHDR) viewing, an acronym coined by Jim 

Meadows. 

Now this is an incredibly challenging process, and you will start off with more failures than 

successes, but this is the pinnacle of imaging and people have spent over a year trying to 

master the technique, let alone in a live imaging environment. 

The principle here is to combine (in real time), different exposures to produce an image that 

contains the faint detail of a long exposure, but the prominent feature of a short exposure. 
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MallincamSky has of course two image presentation modes: 

Video Mode:  In Video Mode you can adjust both the exposure and the gain settings in real 

time, but you are limited to its exposure time (5 seconds). 

Trigger Mode:  In Trigger Mode, you must stop the looping, make exposure (or gain) 

adjustments, and then restart the looping. 

We will use Trigger Mode in this process (it has its advantages and disadvantages). 

Jim Meadows has provided a Blog in which he has some details of how he has accomplished 

HDT using Video Mode: 

https://remotevideoastronomy.com/blog/ds10c-live-hdr-averaging 

Now we always have had the opportunity to save our images and then utilize specialized HDR 

software to provide stunning HDR images. But remember, MallincamSky and the SkyRaider 

cameras are designed for Live Video imaging, what we want to do is to incorporate some of its 

controls to produce the best Live HDR images we can. 

I will discuss two approaches for HDR imaging: 

1)  Storing a sequence of exposures and gain values into MallincamSky and having it 

automatically set and incorporate those values in the image stacking process. 

MallincamSky will run the process for you. 

2)  You manually set up the exposure/gain (and other settings) for an image and you Click to 

add that image into the stacking process. You repeat this procedure for every new 

exposure you would like to incorporate into the Stack. 

A comment for those who need exact control. Since we are using the Live Stack in Average 

Mode, it needs an original image to work with (to average). So, in reality the first image is 

actually averaged twice. This is usually not an issue since mostly you are using it to average 

the current image with a fixed exposure. But since we are tricking the Live Stack in to 

averaging multiple exposures, this ends up being the consequence. 

That is, if you want to average a 2 second, 10 second, and 30 second exposure. The process 

will actually average two 2 seconds, one 10 second, and one 30 second exposure as a final 

image. 

The only workaround to obtain what you required exactly, in terms of average, would be for 

you to double the 10 second and 30 second exposures, to give you two of every exposure 

averaged. 

 

 

  

 

https://remotevideoastronomy.com/blog/ds10c-live-hdr-averaging
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Automated HDR 

 

Using this process, you will be able to adjust 3 values (Exposure Time, Gain, Delay time 

between exposures). 

Plan your exposures. Write down how many exposures you are doing to use (more is not 

always better) and for each exposure what Exposure setting, Gain value, and Delay time 

between each shot you are going to use. This will help you get yourself organized and provides 

a history of what was incorporated in the HDR image. Remember one bad exposure can ruin 

the final image. 

Let’s assume you are going to incorporate 4 images to create a final HDR image. 

Image Number Exposure Time Gain Time Between 

1 2 3 15 s 

2 10 1 15 s 

3 16 1 15 s 

4 30 2 15 s 

 

You can use the Time Between to make image setting tweaks (color Gamma, …). 

You will include all images EXCEPT the first into MallincamSky Sequencer. We will manually set 

the first image parameters and take its image, so the sequencer can combine the remaining 

images into the first image. 

Select Trigger Mode>Options to open up the options Window. 

 

Select Show in the video window from the provided radial button options. 

 

 

Step 1 

Step 2 

Step 3 
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Click on the Sequencer Tab at the top of the Option Window to display the Sequencer. 

 

Set Mode to Plan. 

 

Enter 1 less than the Number of images you are going to incorporate (3 in this example). 

 

Enter in the Exposure Time, Gain (enter in 100 time the value you require, i.e., a Gain of 1 is 

entered in as 100, a Gain of 2.3 is entered in as 230), and the Delay time in each cell. 

 

Recall, you Double-Click on the cell location to open up a window to enter in the value. 

 

Click on the Options’ OK button to accept these settings and close the window. 

 

Enter in the exposure, gain, and other values you need for your first image (Exposure of 2s 

and a Gain of 3 in this example). 

         

 

Enable Live Stacking but ensure it has a value of 1 in the Number and it is 

set for Average. 

 

Click on Single to take the first image in Trigger Mode.  

Step 4 

Step 7 

Step 5 

Step 6 

Step 8 

 

Step 9 

Step 10 

Step 11 
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It may take up to about 20s to register the image in Live 

Stack, you know you are successful when you see input at 

2 and output at 1. Live Stack is now pausing for you. 

 

Now Click on Plan in Trigger mode and watch MallincamSky take over Live Stack. 

 

Note: during the Delay time, you can make other image adjustments. Every time an image 

form the Plan is added to Live Stack both Input and Output will increase by 1. 

Once completed, the Output number will match the total 

number of images average (4 in this example. 

 

Uncheck enabled on Live Stacking, for you are done. 

 

Your Live Video Window will contain the Average of your images (4 in this example). 

Do not be afraid to experiment with this procedure and use image controls to enhance the 

final image. Some users will repeat multiple exposures so that they average out to improve 

the overall image. 

For Example: 5 exposures at 2s, 5 exposures at 10s, 5 exposures at 16s, 5 exposures at 30s 

 +  +  +  

=  

 

 

 

Step 12 

 
 

Step 13 
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Manual HDR 

 

We are going to use Trigger Mode and Live Stack to Average Stack our images. 

Plan your exposures. Write down how many exposures you are doing to use (more is not 

always better) and for each exposure what exposure setting, gain, and other setting values 

you are going to use for each shot. This will help you get yourself organized and provides a 

history of what was incorporated in the HDR image. Remember one bad exposure can ruin the 

final image. 

Let’s assume you are going to incorporate 4 images to create a final HDR image. 

Image Number Exposure Time (s) Gain 

1 2 3 

2 10 1 

3 16 1 

4 30 2 
 

Set up Live Stack, ensuring it is on Average and the number value is 1. 

Not enabled. 

 

Enter the Exposure and Gain value for the first image (2s and Gain of 3 in this example). 

 

Enable Live Stack. 

 
 
Click on the Single button in Trigger Mode to take the first image.  

 

It may take up to about 20s to register the image in Live 

Stack, you know you are successful when you see input at 

2 and output at 1. Live Stack is now pausing for you. Your 

image will appear in the Live Video Window. 

Set up the exposure and gain for the next image in the sequence (10s and Gain of 1 in this 
example. 
 

Click on the Single button in Trigger Mode to take a second image.  

Step 3 

Step 6 

Step 7 

Step 1 

Step 2 

Step 4 

 

Step 5 
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It may take up to about 20s to register/average the 

second image with the first image in Live Stack, you know 

you are successful when you see input at 3 and output at 

2. Live Stack is now pausing for you. Your averaged image 

will appear in the Live Video Window. 

 

Repeat this process for each image in your sequence. 

 

Uncheck enabled on Live Stacking, for you are done. 

 

Your Live Video Window will contain the Average of your images (4 in this example). 

Do not be afraid to experiment with this procedure and use image controls to enhance the 

final image. Some users will repeat multiple exposures so that they average out to improve 

the overall image. 

For Example: 5 exposures at 2s, 5 exposures at 10s, 5 exposures at 16s, 5 exposures at 30s 

 +  +  +  

=  

 

Note: we used the Single button to trigger the image capture, but if you want to capture many 

images at the same exposure settings, use the Loop command. You will have to Stop the Loop 

when you need to change the exposure. 

 

 

 

Step 9 

Step 8 
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How to Debayer a RAW Image 
 

Introduction to Bayer Pattern 

A color camera contains a mosaic of color filters in front of the image sensor. 

This is also known as the Bayer filter. The Bayer has alternating red (R) 

and green (G) filters for odd rows and alternating green (G) and blue (B) 

filters for even rows. There are twice as many green filters as red or blue ones, 

catering to the human eye's higher sensitivity to green light. 

Since each pixel of our sensor is behind a color filter, the output is an array of pixel values, 

each indicating a raw intensity of one of the three filter colors. Therefore, we need a process 

(algorithm) to estimate for each pixel the color levels for all color components, rather than a 

single component. This process is known as debayering or demosaicing. 

When you save a color image in the RAW format, the image appears Black and White (with a 

checkered overlay). What we need is processing software that can debayer our image so that 

it is in color. Most processional astronomical imaging software can debayer, but you will have 

to indicate to the software the order of the colored pixels.  You will then need to tweak the 

color and white balance to obtain an accurate color representation. 

      

 

Using PIPP 

One free piece of software that can debayer your image for you, so you can then save it in 

another colored format (such as tiff) is PIPP. 

Visit https://sites.google.com/site/astropipp/ to download PIPP (and to look at instructions) 

 

 

 

https://en.wikipedia.org/wiki/Color
https://en.wikipedia.org/wiki/Bayer_filter
https://en.wikipedia.org/wiki/Red
https://en.wikipedia.org/wiki/Green
https://en.wikipedia.org/wiki/Blue
https://en.wikipedia.org/wiki/Human_eye
https://sites.google.com/site/astropipp/
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A summary of the PIPP process is as follows: 

 

Load your image into PIPP from the Source Files tab (Add 

Image Files from PIPP button, it will display image in an 

Image Window). 

  

On Input options tab select Debayer 

Monochrome Frames with a Debayer 

pattern checked. 

 

Click Update Image on Image Window to see if color is correct (if 

not choose a different Bayer pattern from Colour Debayer 

Options and Update Image again. 

From the Processing Options tab, 

check Stretch the Histogram 

White Point and Equalize R, G, and 

B channels Individually (again click 

on Update Image to see the change). 

From Image Window, select Save Image and choose your required 

color format (TIFF). 
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C9: Pictorial Workflows 
The following pictorial diagrams 
demonstrate the steps necessary 
to perform the required 
procedure.  

   

 

Starting MallincamSky 

Start MallincamSky 

Exit MallincamSky 

Connect the 
DS10CTEC 

to your 
computer. 

Chapter 

9 
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 Start MallincamSky 

Deep Sky Object Planetary 

Trigger Mode to Image 

Activate Dark Field 

Video Mode to Focus 

Adjust Image 

Save and Record 

Exit Mallincam 

Exit Mallincam 

Save and Record 

Adjust Image (High 
Gain and Low 

Gamma 

Video Mode to Image 

Live Stack 

Start Trigger 
Mode then 

Take Dark Field 

Typical Session in MallincamSky 

Workflow 



M A L L I N C A M S K Y  D S 1 0 C T E C  U S E R  M A N U A L  

 

258 

 

Live Stack Workflow 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Expose Object 

Choose and Activate Video 
Mode or Trigger Mode 

Live Stack 

Adjust Image 

Save and Record 

Choose Mode and Type of 
Stacking. Then Align and 

Enable.  
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Dark Field Workflow 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Determine Maximum Exposure 

Choose and Activate Video 
Mode or Trigger Mode with 

Maximum Exposure 
expected 

Take Dark Field 

Enable Dark Field 

Adjust Image 

Choose Quantity and Click 
Capture to Take Dark Fields 

Check Enable Box 

Set Exposure 
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Flat Field Workflow 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Choose and Activate Video 
Mode or Trigger Mode with 

Maximum Exposure 
Required. Click on Loop 

Prepare Telescope 
for Flat Field 

Apply Flat Field 

Adjust Image 

Choose Quantity and Click 
on Capture to take Flats 

Check Enable Box 

Determine Flat Field Exposure 

Set Exposure 
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Histogram Workflow 

 

 

 

 

 

 

 

 

 

  

Expose Object 

Increase Left number 
or Move Left Bar in 

Darkens 

Decrease Right 
number 

or Move Right Bar in 

Brightens 

Select Histogram 

Select Exposure 

Decrease Exposure Increase Exposure 

Histogram Moves to 
Left 

Histogram Moves to 
Right 
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ROI Workflow 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
  

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Expose Object 

Trigger Mode 

Trigger Mode 

Video Mode 

Video Mode 
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Save a Snapshot Image Workflow 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Expose Object 

Take Picture 

Select Image 

Press Save Icon 

Select Location and 
Name 
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Record Video Workflow 

 
 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Expose and adjust image  

If No Time Limit Set 

Enter File Location, Format, 
Prefix, Type, Number of Seconds 

Select Mode  

Options->Preferences… to 
set saving location 

Choose either Video Mode or 
Trigger Mode 

Record Video 

Start MallincamSky 

Activate Camera 
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Batch Record Videos Workflow 

. 

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Expose Object 

Number of Videos, Time between 
each Video 

Enter File Location, Format, 
Prefix, Type, Number of Seconds 

Options->Preferences… to 
set saving location 

Start MallincamSky 

Activate Camera 

Activate Batch 
recording 

Done 
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Auto Capture Images Workflow 
 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 Expose Object 

Enter File Location, Format, 
Prefix, Type, Capture Mode,  

Total number of Images from: 
Options/Preferences 

Done 

Choose Exposure Mode 

Options->Preferences-
>Auto Capture … to set 

parameters 

Start MallincamSky 

Activate Camera 

Activate Auto 
Capture 
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Save Sequence of Images Workflow (Trigger Mode) 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Select Parameters 

Select Trigger Mode 
and timing 

Select Number 

Start Sequencing 

Start MallincamSky 

Activate Camera 

Enter File Location, Format, 
Prefix, Type, Capture Mode,  

Select Number of 
images and start 

process 
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Digital Binning Workflow 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

 

 

 

 

 

Choose Binning Method 
and Number 

Choose Exposure Mode 
and Time 

Start MallincamSky 

Activate Camera 
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User Notes 
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